xoops forums

sixpack

Just popping in
Posted on: 2012/7/8 14:23
sixpack
sixpack (Show more)
Just popping in
Posts: 50
Since: 2008/5/28
#1

Install xoops 2.6

Hello all,

I will try the xoops 2,6 but i have a blank page juste is the end of the installation : page_config.php.

Do you have an idea ?
After the blank page is i want to go to preference same problem blank page.
Same problem with all page preference .


Thanks in advance for your help

Six

chaoos

Just popping in
Posted on: 2012/11/24 16:33
chaoos
chaoos (Show more)
Just popping in
Posts: 77
Since: 2005/3/9 1
#2

Re: Install xoops 2.6

During installation version 2.6.0 Alpha 1 I used Slovak translation from Transifex, installed modules Profile, PM and Banners and extension Protector. After installation is complete I also show only blankscreen.

So I installed the 2.6.0 version again.

Installation in the original English, I did not install any module or extension.
Installation was fine.

In administration I installed the module Banners, and after the installation is displayed only Blankscreen. After disabling this module was all right again.

In administration I set in General Settings Slovak language from Transifex ... and again there is a problem. Page worked at 30%, many common links such as edit profile and others display the Blankscreen (mainly Administration did not work either).
When I manually via phpMyAdmin rewrote the language back to English, the problem stopped.

--------------------
PHP: 5.3.13
MySQL: 5.1.63
The unity of the masses of programmers and willingness to cooperate creating the world's top product. We can not give up before the end of our long long long journey to guaranteed success.

TheNineHertz

Just popping in
Posted on: 3/30 12:06
TheNineHertz
TheNineHertz (Show more)
Just popping in
Posts: 1
Since: 2017/11/9
#3

Re: Install xoops 2.6

yes i have same problem to install Install xoops 2.6.

Mamba

Moderator
Posted on: 3/31 1:13
Mamba
Mamba (Show more)
Moderator
Posts: 10620
Since: 2004/4/23
#4

Re: Install xoops 2.6

What kind of problems do you have?

Did you use the code from GitHub?
https://github.com/XOOPS/XoopsCore
Support XOOPS => DONATE
Use 2.5.9 | Docs | Modules | Bugs

wishcraft

Module Developer
Posted on: 8/6 23:01
wishcraft
wishcraft (Show more)
Module Developer
Posts: 3703
Since: 2007/5/18
#5

Re: Install xoops 2.6 :: install/page_dbconnection.php

After doing the composer which I think should be done for the client as part of the installation also the README.md needs to be written for Ubuntu/Debian..

Anyway as part of the installation I get to: install/page_dbconnection.php ~ and get the following error:

Quote:
Fatal error: Uncaught Error: Class 'Doctrine\DBAL\Configuration' not found in /home/mynamesnot/eclipse-workspace/xoopscore.localhost/htdocs/install/include/functions.php:318 Stack trace: #0 /home/mynamesnot/eclipse-workspace/xoopscore.localhost/htdocs/install/page_dbconnection.php(95): getDbConnection('') #1 {main} thrown in /home/mynamesnot/eclipse-workspace/xoopscore.localhost/htdocs/install/include/functions.php on line 318


I am working on the PHP.ini settings module for system as well as the .htaccess route and API, btw. mamba I looked at those api guides you sent through, and graph is just based on facebook.com graph api and the other one is oauth, there will be later oauth methods, in the api, but I remember when I implemented them in the previous historical corridor, it destroyed oauth2 on twitter and a couple of places and completely collapsed, they are essentially still both REST API just with a control class anyway...
Resized Image
www.ohloh.net/accounts/226400

Follow, Like & Read:-

twitter.com/SimonXaies
github.com/Chronolabs-Cooperative
facebook.com/mynamesnot

wishcraft

Module Developer
Posted on: 8/6 23:39
wishcraft
wishcraft (Show more)
Module Developer
Posts: 3703
Since: 2007/5/18
#6

Re: Install xoops 2.6 :: Endroid Installer did not detect a compatible project type

mynamesnot@marrickville:~/eclipse-workspace/xoopscore.localhostphp ~/composer.phar install


Quote:
Loading composer repositories with package information
Installing dependencies (including require-dev) from lock file
Nothing to install or update
Generating autoload files
Endroid Installer did not detect a compatible project type


mynamesnot@marrickville:~/eclipse-workspace/xoopscore.localhost/xoops_libphp composer.phar install


Quote:
No composer.json in current directory, do you want to use the one at /home/mynamesnot/eclipse-workspace/xoopscore.localhost? [Y,n]? Y
Loading composer repositories with package information
Installing dependencies (including require-dev) from lock file
Nothing to install or update
Generating autoload files
Endroid Installer did not detect a compatible project type
Resized Image
www.ohloh.net/accounts/226400

Follow, Like & Read:-

twitter.com/SimonXaies
github.com/Chronolabs-Cooperative
facebook.com/mynamesnot

geekwright

Quite a regular
Posted on: 8/7 3:03
geekwright
geekwright (Show more)
Quite a regular
Posts: 247
Since: 2010/10/15
#7

Re: Install xoops 2.6 :: Endroid Installer did not detect a compatible project type

This works fine (just tested on Ubuntu 18.04):

git clone https://github.com/XOOPS/XoopsCore.git yourdir
cd yourdir
cp composer
.json.dist composer.json
./xoops_lib/composer.phar self-update
./xoops_lib/composer.phar install


You should not be in xoops_lib when you run composer install. Also, XoopsCore does not contain a composer.lock file, so you might have better results starting from a fresh clone.

Installing composer globally is preferred over depending on the included composer.phar, but for now it will work if updated.

The message "Endroid Installer did not detect a compatible project type" is just informational. It is telling you that it didn't find a Symfony project to add itself to, which is as it should be.

For now, XoopsCore is targeted to developers only, and it is expected that developers have or will build their own proficiency with composer.