xoops forums

phppp

XOOPS Contributor
Posted on: 2004/3/10 16:16
phppp
phppp (Show more)
XOOPS Contributor
Posts: 2857
Since: 2004/1/25
#11

Re: Newbb forums admin error

suspending progress:

for vicbiz's server, error_reporting is turned off.
hence no bug info.
Have to wait...

look forward to info from other sites.

JackJ

Community Support Member
Posted on: 2004/3/10 17:47
JackJ
JackJ (Show more)
Community Support Member
Posts: 747
Since: 2003/8/31
#12

Re: Newbb forums admin error

Hello there,

I had a try in admin played aroung a little. Switched debug on in general settings.

Firstly do you have register_globals = on? There can be problems with this off. (I dont know if you have root access to your server config)

Edit: just noticed this is an old post, should work with register globals off now I think.

See this thread here for more information:

https://xoops.org/modules/newbb/viewto ... de=flat&order=ASC&start=0

Here is some of the degug errors: (I took out the start of your path information)

Notice: ob_end_flush(): failed to delete and flush buffer. No buffer to delete or flush. in home/include/cp_functions.php on line 174

Notice: Constant _MI_NEWBB_NAME already defined in home/modules/newbbpro/language/english/modinfo.php on line 6

Notice: Constant _MI_NEWBB_DESC already defined in home/modules/newbbpro/language/english/modinfo.php on line 9

Notice: Constant _MI_NEWBB_BNAME1 already defined in home/modules/newbbpro/language/english/modinfo.php on line 12

With some versions of php there also is a problem in newbb with 2.06

newwbb 206 patch

http://www.peak.ne.jp/xoops/modules/m ... nglefile.php?cid=2&lid=16

I would uninstall the forum, and all the versions of the forum you have on your server again, and do a clean install--there is "already existing language defines" on your system in newbbpro




TriKster

Just popping in
Posted on: 2004/3/10 21:20
TriKster
TriKster (Show more)
Just popping in
Posts: 13
Since: 2004/3/7 2
#13

Re: Newbb forums admin error

Quote:
I would uninstall the forum, and all the versions of the forum you have on your server again, and do a clean install--there is "already existing language defines" on your system in newbbpro


I am getting more confused by the minute.

Ok, when you say "uninstall" do you mean, to go into the admin section and remove the "forum" module?

Do you also mean to say ftp into the directory where the forum modules existed and delete them completley from the server?

And then you go onto say to "do a clean install"

A clean install of what? The whole XOOPS? or just the module for the forum? If just the module, where do I get this module from?

If not, and you are actually suggesting to "nuke" the whole site and start from scratch.. then that I cannot do.. Wipe out 3 existing sites.. and redo them again!? Are you guys serious?

Crap..

This is getting messier by the day..

Are there no XOOPS developers monitoring these forums?

Why can't someone just fix the stupid forums module and tell us chickens how to properly install it and get things rolling again?


Please advise

Thank you

Sincerely,

TriKster Abacus

samuels

Quite a regular
Posted on: 2004/3/10 21:39
samuels
samuels (Show more)
Quite a regular
Posts: 249
Since: 2003/10/30
#14

Re: Newbb forums admin error

@TriKster
There are another modules. Newbbex,IPB, phpbb all of them are adapted to xoops.

JackJ

Community Support Member
Posted on: 2004/3/10 22:01
JackJ
JackJ (Show more)
Community Support Member
Posts: 747
Since: 2003/8/31
#15

Re: Newbb forums admin error

mmmmmmm I said "uninstall the forum", looks like plain english to me? It is a common way in XOOPS to quickly attempt to resolve a module problem.

A clean install means uninstall the module in Xoops, delete the files on your server, and upload a fresh set of files.

If you had read what I said, it would have saved you writing all that Crap?


ladon

Quite a regular
Posted on: 2004/3/10 23:49
ladon
ladon (Show more)
Quite a regular
Posts: 284
Since: 2003/10/31
#16

Re: Newbb forums admin error

Please keep it friendly. All who work on XOOPS and it's modules do it for free in their spare time. So please don't flame. Also i'd advise you to read posts made by people who are trying to help you twice before you post a reply.

Please don't see this as an attack. Just some advice. I for one am thankfull for all the hard work the XOOPS team has done and is doing for people like us. Same goes for anyone who try's to help xoopsusers in trouble, like you atm.

Good luck with your websites

vicbiz

Just popping in
Posted on: 2004/3/11 1:06
vicbiz
vicbiz (Show more)
Just popping in
Posts: 10
Since: 2004/2/23
#17

Re: Newbb forums admin error

I 100% agree with you ladon.

I also have problem with Forum module, but I trully appreciate to all XOOPS members. Please everyone let's be friend and help each other, and make XOOPS be better.

Thanks

Jae Moon

TriKster

Just popping in
Posted on: 2004/3/11 3:31
TriKster
TriKster (Show more)
Just popping in
Posts: 13
Since: 2004/3/7 2
#18

Re: Newbb forums admin error

Well,

Back again ready for some more anti TriKster flames and aggressive hate..

Ok, I backed up my /modules/newbb/ directory locally.

I removed the module and uninstalled it from the admin section.

Then I deleted the /newbb directory completely off of the server.

Where do I get this module again to replace it?

I did a search in "downloads" and did not find any newbb modules.. and a global search on the xoops.org webpage came back with zero info either.

Also I did a seach on google and on the xoops.org site for "phpbb" and "xoops + module + phpbb" .. still noting

But I did find a module named: Newbbex

I uploaded the newbbex module directory into the onsite's module directory, then went to the admin page and tried to install/add the module, but I only see this error above where the module is supposed to be (the uninstalled modules)

"Module File for Not Found!Module File for Not Found!Module File for Not Found!Module File for Not Found!Module File for Not Found!"

And an empty spot where the new module is supposed to be that says:

"Module File for Not Found!"

I also did a global xoops.org search for "module installation".. I will just note: 8-(

Do I have to set some kind of permissions to make this module work?

This is very disheartening and I am about to lose my hair/mind over this problem.

I am sorry if I appear to be pretty much an "ignoramus" about this problem.. I am no webmaster or php guru by any means..

Just a guy tryin to get his domains up and running online.

Please advise

Thank you

Sincerely,

TriKster Abacus

TriKster

Just popping in
Posted on: 2004/3/11 3:51
TriKster
TriKster (Show more)
Just popping in
Posts: 13
Since: 2004/3/7 2
#19

Re: Newbb forums admin error

Ok

It seems the permissions where off for the files in the forum Newbbex directory.

The files where only rw, I had to make them r for all.

Anyhow, now the forumEx or Newbbex module installed.

But it has the same problem as the newbb forum module also.

It lets you create a "Category" but it wont successfully let you create a forum under the "Category" itself.

And if you hit the webpage, and then the forum as a registered user, you still do not see anything of any of the newly created "categories"

The forum setup page for newbbex looks exactly like it did with newbb, down on the bottom on the left hand side it says "menu" but it does not show anything to click on.

Anyhow.. just thought I would post what I have done, and to add my info in case others are stuck in the same rutt as I am.

Thank you

Sincerely,

TriKster Abacus

phppp

XOOPS Contributor
Posted on: 2004/3/11 13:32
phppp
phppp (Show more)
XOOPS Contributor
Posts: 2857
Since: 2004/1/25
#20

Re: Newbb forums admin error

my suggestion:
Don't try newbb_P, newbb_E before your find out the reason.

such hacks are originated from newbb and with more opportunities of creating bugs than the original version.