xoops forums

Kainaij

Quite a regular
Posted on: 2008/5/6 22:27
Kainaij
Kainaij (Show more)
Quite a regular
Posts: 256
Since: 2004/10/5
#11

Re: Login issue...

I just was conversing with Herve and he gave me a tip that worked for him:

Quote:
I also had problems with sessions.

To solve it, I changed the file /Xoops/kernel/session.php

I have replaced this line:

var $enableRegenerateId = false;



with:



var $enableRegenerateId = true;



May be it can work for you?


It did...so far. If I don't reply back to this thread, then it did the job. Thanks a bunch Herve.

DobePhat

Friend of XOOPS
Posted on: 2008/5/6 22:34
DobePhat
DobePhat (Show more)
Friend of XOOPS
Posts: 656
Since: 2003/4/15
#12

Re: Login issue...

Should work!
Also had that problem and was fixed with same method as well as well. Sorry I woulda shared that sooner, but thought your problem was different.

So while this issue is fixed...what happens when you try to login with the wrong password--please share if you find yourself in a perpetual (wrong password) loop.

-thanks

Kainaij

Quite a regular
Posted on: 2008/5/6 22:57
Kainaij
Kainaij (Show more)
Quite a regular
Posts: 256
Since: 2004/10/5
#13

Re: Login issue...

Hey DobePhat,

Just tried out logging in incorrectly, and thankfully I was redirected to /user.php.

I hope it stays that way, hehe.

Thanks for the heads up BTW, later.

krauh

Just popping in
Posted on: 2008/5/7 3:01
krauh
krauh (Show more)
Just popping in
Posts: 70
Since: 2005/2/25
#14

Re: Login issue...

Was having this problem on a subdomain
That fixed it.

Thanks

Quote:
To solve it, I changed the file /Xoops/kernel/session.php

I have replaced this line:
var $enableRegenerateId = false;
with:
var $enableRegenerateId = true;

Kainaij

Quite a regular
Posted on: 2008/5/8 19:58
Kainaij
Kainaij (Show more)
Quite a regular
Posts: 256
Since: 2004/10/5
#15

Re: Login issue...

Just a note conversing with Herve, he says that he's had to apply this hack to all his sites with the latest core (2.0.18.1). Good to know and I thought I'd pass that on.

Thanks again Herve.

gordo

Just popping in
Posted on: 2008/5/14 8:17
gordo
gordo (Show more)
Just popping in
Posts: 49
Since: 2006/8/17
#16

Re: Login issue...

Was just faced with a login proble, I would insert my details then it would thank me for logging in. but I wasn't I was presented with the login screen again.

I followed the advice of changing the sessions php file and it works

brilliant show the value of posting answers to problems and of course searching for your answer

rpilney

Just popping in
Posted on: 2008/5/22 17:10
rpilney
rpilney (Show more)
Just popping in
Posts: 76
Since: 2006/1/25
#17

Re: Login issue...

I have done a search for login issues which lead me to this post. I upgraded to .18 from 17 and now I can't login to the site. It says thanks for logging in then goes right back to the login screen. I did as suggested early in this post and emptied the sessions table and that did not help.

I am at a loss. last night I upgraded to 17 and had no issues other than I could not reply to a PM so I decided to upgrade to .18

I was able to request a new password.

I editd the session.php file and that did the trick!

Thanks! :)

thebeastmast

Just popping in
Posted on: 2008/6/3 5:44
thebeastmast
thebeastmast (Show more)
Just popping in
Posts: 2
Since: 2008/6/2 0
#18

Re: Login issue...

"I just was conversing with Herve and he gave me a tip that worked for him:

Quote:
I also had problems with sessions.

To solve it, I changed the file /Xoops/kernel/session.php

I have replaced this line:

var $enableRegenerateId = false;

with:

var $enableRegenerateId = true;

May be it can work for you?

It did...so far. If I don't reply back to this thread, then it did the job. Thanks a bunch Herve."

Thx.
This worked for me.
Did I say thank you.
If not thank you.
I now officially love you.

Thx The BeastMaster

barryc

Just can't stay away
Posted on: 2008/6/10 18:27
barryc
barryc (Show more)
Just can't stay away
Posts: 480
Since: 2004/3/20
#19

Re: Login issue...

I'm glad I found this thread when I searched for login problems. This morning on my site, suddenly, nobody could log in. Like a few others here, trying to log in would give the Thanks for Loggin In message, but then you'd be taken back to the login page. What I found, after being alerted to the possibility of a problem in the _session table, was that the latter was corrupted. Doing a Repair Database fixed it, I'm glad to say.

I think it would be useful to have an FAQ on this subject that points out that the _session table needs to be specifically checked.


Barry Cooper
Barry Cooper
Sweet Home, Oregon

Kainaij

Quite a regular
Posted on: 2008/6/10 22:33
Kainaij
Kainaij (Show more)
Quite a regular
Posts: 256
Since: 2004/10/5
#20

Re: Login issue...

I'm glad that I've been able to help. It's nice when after you find a solution that you report back to the thread.

Y'all owe me and Herve a beer each. hehe. ;)