1
rpilney
Re: XOOPS security and php settings
  • 2008/7/30 4:54

  • rpilney

  • Just popping in

  • Posts: 76

  • Since: 2006/1/25


my site got hit with a php/ms06-014!exploit

it wrote code in the index.php file on line 46

there was info in there that I am not sure I am supposd to repost here so I wont but when users came to the site it would state that the site either had the above exploit using CA or a trojan using another anti virus program.

the file size changed to 3k


not sure what other files might have been messed with. I did not see any other files or folders that were changed on or near the date of that index.php file.

using XOOPS 2.0.18.1 with protector.


FYI



2
rpilney
can not edit forums in NewBB 2.0 version 2.02 (2.02)
  • 2008/5/29 7:49

  • rpilney

  • Just popping in

  • Posts: 76

  • Since: 2006/1/25


Ever since I upgraded to version XOOPS 2.0.18.1 I can't edit my forums. I see the image below:


click to see larger----
Resized Image


Not sure what would change to make it where I can't see the forum after I click the edit button.

Style sheet in a theme wouldn't change the admin view not that I know of so not sure what else to look for.

Any help would be appeciated.



3
rpilney
Re: Upgrade from 2.0.13 -> 2.0.18
  • 2008/5/24 20:17

  • rpilney

  • Just popping in

  • Posts: 76

  • Since: 2006/1/25


ok I figured out the cuase now just for the solution.

My theme does not work with the upgrade. I used the theme that is on the xoops.org page and comes with the upgrade and everything works.

sooo... how do I get the old theme to work with the new upgrade?

thanks!



4
rpilney
Re: Upgrade from 2.0.13 -> 2.0.18
  • 2008/5/24 17:32

  • rpilney

  • Just popping in

  • Posts: 76

  • Since: 2006/1/25


thanks for the reply. I failed to mention that I had cleared the cache, templates, sessions, and updated system module as well as optimized the tables.

I get the errors like:

Line 6
char 2
Error Object expected


or

Line 5
Char 3
Error Object doesn't support this property or method.
.../modules/shoutbox/shoutframe.php



I can delete PM's but I can not reply to them.


I can manually put in teh code for a smiley and it will show but I can't click on one from the list and have it show up.


some good news.. the site is loading much much better. Just loads with erros on the the page and have 3 items I need to function that don't.

Thanks again! :)



5
rpilney
Re: Can not reply to PM's
  • 2008/5/23 22:45

  • rpilney

  • Just popping in

  • Posts: 76

  • Since: 2006/1/25


Now I think I am having javascript issues because I can't click on smilies and get them to work, can't reply to PM's and where the who's online block is when I click on "more" it does nothing.

I looked all day today for the solution. Most of the day the xoops.org site would not load for me. Funny because my site was not loading and that was why I finally upgraded. lol

Any ideas why these 3 things are not working? I checked the theme.html file and it looks fine. I could not figure out what php file might make it not work. I looked through files that looked like they might cause the problem. No luck. I don't have enough coding skills to know what to look for and the other sites I could find on PHP were over my head. :(

Thanks!



6
rpilney
Re: Upgrade from 2.0.13 -> 2.0.18
  • 2008/5/23 22:41

  • rpilney

  • Just popping in

  • Posts: 76

  • Since: 2006/1/25


I just did the same thing this week and have the same report but those files are teh ones the instructions tell you to take out. That test file, in my opinion, was made to test full installs. I went back and added manually the files but it worked fine. I had to edit the sessions.php file yesterday so I could login again. It was keeping users out.

Now I think I am having javascript issues because I can't click on smilies and get them to work, can't reply to PM's and where the who's online block is when I click on more it does nothing.

I made a post and I am hopeful to get a reply on that. I looked all day today for the solution. Most of the day the xoops.org site would not load for me. Funny because my site was not loading and that was why I finally upgraded. lol

I put the remember me hack in last night and it works still. Everything else appears to work fine on the site.

Good luck! :)



7
rpilney
Re: Autologin hack for XOOPS 2.0.18.1
  • 2008/5/23 7:28

  • rpilney

  • Just popping in

  • Posts: 76

  • Since: 2006/1/25


works great. thanks!



8
rpilney
Can not reply to PM's
  • 2008/5/22 21:07

  • rpilney

  • Just popping in

  • Posts: 76

  • Since: 2006/1/25


after upgrading my site to 2.0.18 I can no longer reply to a PM.

I did a search for reply and PM issues and did not see anything.

Anyone have this issue or some tips on how to resolve it?

Thanks,
Roger

PS when I try to use the optimize dbtools the site times out and get server not found. Not sure if that issue is the same but it was a primary reason I tried to upgrade.


The error it shows at the bottom of the page for the PM is:

Line: 1049
Char: 1
Error: Object expected
Code: 0
URL: http://www.MYURL.com/readpmsg.php?start&total_messages=17



9
rpilney
Re: Login issue...
  • 2008/5/22 17:10

  • rpilney

  • Just popping in

  • Posts: 76

  • Since: 2006/1/25


I have done a search for login issues which lead me to this post. I upgraded to .18 from 17 and now I can't login to the site. It says thanks for logging in then goes right back to the login screen. I did as suggested early in this post and emptied the sessions table and that did not help.

I am at a loss. last night I upgraded to 17 and had no issues other than I could not reply to a PM so I decided to upgrade to .18

I was able to request a new password.

I editd the session.php file and that did the trick!

Thanks! :)



10
rpilney
Re: database hangs when site loads
  • 2008/5/22 6:02

  • rpilney

  • Just popping in

  • Posts: 76

  • Since: 2006/1/25


ok I figured out the method to my madness when I installed the site a few years ago and upgraded to 2.0.17 but stil having the time out issue. I ran the xoops_md5 file and all appeared good there as well. So now what?

applied upgrades:
upd-2.0.13-to-2.0.14
upd-2.0.15-to-2.0.16
upd-2.0.16-to-2.0.17


XOOPS Version:
XOOPS 2.0.17.1 RC2

XOOPS Template Set:
default

PHP Version:
4.3.11

MySQL Version:
4.0.27-max-log

Server Software:
Apache

User's Browser:
Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 2.0.50727; InfoPath.1)




TopTop
(1) 2 3 4 ... 7 »



Login

Who's Online

67 user(s) are online (41 user(s) are browsing Support Forums)


Members: 0


Guests: 67


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Jul 31
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits