xoops forums

hervet

Friend of XOOPS
Posted on: 2004/11/30 17:20
hervet
hervet (Show more)
Friend of XOOPS
Posts: 2267
Since: 2003/11/4
#11

Re: What is there in line 34 of databasefactory.php ?

Did it changed something ?
Posted on: 2004/11/30 17:33
ackbarr
ackbarr (Show more)
Posts: 1449
Since: 2002/10/2
#12

Re: What is there in line 34 of databasefactory.php ?

sounds like MySQL is hitting its max_connections limit, which defaults to 100. You could try increasing this limit to a larger number, but make sure it is more then the apache connection limit. It might also help to lower the apache KeepAliveTimeout setting to about 5 to force connections to terminate quicker

* Edit - MySQL connections should be set higher than apache, not lower as I originally typed.

hervet

Friend of XOOPS
Posted on: 2004/11/30 17:35
hervet
hervet (Show more)
Friend of XOOPS
Posts: 2267
Since: 2003/11/4
#13

Re: What is there in line 34 of databasefactory.php ?

more cache will be a good solution too

shivaji

Friend of XOOPS
Posted on: 2004/12/15 8:26
shivaji
shivaji (Show more)
Friend of XOOPS
Posts: 179
Since: 2003/9/18
#14

Re: What is there in line 34 of databasefactory.php ?

Quote:
hervet wrote: IPB must use too much queries


Our new IPB 2.03 -XOOPS plugin does not change anythings of XOOPS cores and installed on separate /Forum folder, so this is not a problem of IPB code.

shivaji

Friend of XOOPS
Posted on: 2004/12/17 14:33
shivaji
shivaji (Show more)
Friend of XOOPS
Posts: 179
Since: 2003/9/18
#15

Re: What is there in line 34 of databasefactory.php ?

> You could try increasing this limit to a larger number, but make sure it is more or set to higher then the apache connection limit.

I have had max_connections=500 set ever since the very first evidence of problems with MySql on this server; it has not addressed the issue. From eve

> It might also help to lower the apache KeepAliveTimeout setting to about 5 to force connections to terminate quicker.

I doubt that changing anything in Apache would help an issue with MySql. Keepalive is turned off in Apache anyway.

> Is TurkMCache is installed in this server ?

No.

> It appears that some hosting service providers are imposing their own "unadvertised" restrictions on SQL queries. (hijacked from other thread)

This is a dedicated server running "stock" Red Hat MySql code; no restrictions are placed on any of MySql parameters.

shivaji

Friend of XOOPS
Posted on: 2004/12/17 17:34
shivaji
shivaji (Show more)
Friend of XOOPS
Posts: 179
Since: 2003/9/18
#16

Re: What is there in line 34 of databasefactory.php ?

Quote:
hervet wrote: Did it changed something ?


hervet, I will get back after doing some more research. During peak time still line 34 databasefactory.php.

patchwork

Just popping in
Posted on: 2005/5/3 13:19
patchwork
patchwork (Show more)
Just popping in
Posts: 11
Since: 2005/4/29
#17

Re: What is there in line 34 of databasefactory.php ?

I managed to resolve this error in my site by changing the password used to access MySql and reflecting this change in the mainfile.php.

All previous attempts of rewrite the password failed. You really HAVE to change the password.

Hope it helps!

hervet

Friend of XOOPS
Posted on: 2005/5/3 18:07
hervet
hervet (Show more)
Friend of XOOPS
Posts: 2267
Since: 2003/11/4
#18

Re: What is there in line 34 of databasefactory.php ?

patchwork,

I would like to congratulate you for what you have done.
You have searched (and find) a post relative to your problem without creating a new one !
It's so unusual...

Bye,
Hervé

cmacone

Just popping in
Posted on: 2005/5/28 21:28
cmacone
cmacone (Show more)
Just popping in
Posts: 47
Since: 2004/8/25
#19

Re: It Helped! What is there in line 34 of databasefactory.php ?

Thanks... I experienced that problem, and as I am the administrator of my own dedicated server, I went in and put up both the max amount of users and the bandwith, and it fixed the problem.

landry

Just popping in
Posted on: 2008/6/18 1:44
landry
landry (Show more)
Just popping in
Posts: 22
Since: 2005/6/7 2
#20

Re: What is there in line 34 of databasefactory.php ?

I am having the same issue on a site that receives very little traffic. It was suggested elsewhere that the database password should be changed, but I"m unable to do that at this time. Is there another solution?


Suggestion to change pwd:
https://xoops.org/modules/smartfaq/faq ... &com_order=0#comment41137