1
chrometuna
Mangling themes and destroying stuff.
  • 2010/3/28 22:47

  • chrometuna

  • Just popping in

  • Posts: 67

  • Since: 2004/7/24


Hi!
I'm not really a total noob, but I havnt posted here in a long while. Yes, Ive done searches, but havnt really found what Im looking for.

Ive got a site at:
www.chrometuna.com

I really liked the maitsco classic theme, but I needed to butcher it.

I wanted my 'broadcast box' to appear as high in the page as I could get it, and still have some kind of menu in view. I wanted it all the way across the page.

With the help of this topic:

https://xoops.org/modules/newbb/viewto ... t_id=82188#forumpost82188

I accomplished that fairly well.
Now I'm trying to find a way to make that box ONLY appear on the front page, and one other page. I know I can do that by fiddling with boxes eventually.

But one thing I am trying to do NOW is put boxes, for things like "Top story" or "Spotlight" in a couple of the sliding boxes at the top of the page.

I kinda sorta got it to work in one of the sliding boxes, but how do I get it (With different boxes/content) to show up in all THREE sliders? You'd have to look at my page to see what I mean. Is there a way to show a different box in each slider box? Like a "recent news" box, and "Spotlight news" box, and whatever box? ATM I am using the boxes sacrificed for right collumns.

Is there a way to use <start rightbox loop> <end rightbox loop> then <start right box loop> etc, to make different boxes from different modules that would normly be on the right side?

Im not sure how to phrase the question to show what I am asking.

Also, with AMS, clicking on the "read more" leads to a broken link, or just the same intro text and no artical. Whats up with that?

NOW an easier question: I want to make those sliding boxes smaller, to fit the size of the sliding pics Im using. I havnt found a size code or line that will make those boxes smaller. I COULD make the pics smaller to fill the whole box. But I wanted the boxes smaller. AND maybe to add yet another box up there.

Any help? Or have I made any sense at all?






2
chrometuna
The little X Xoops logo in the address bar?
  • 2006/3/28 8:55

  • chrometuna

  • Just popping in

  • Posts: 67

  • Since: 2004/7/24


How do I get rid of, or change the little XOOPS logo in the address bar?

Like if I wanted to make my own sites logo show up there instead of the XOOPS one?

Thanks

Cheers
bc



3
chrometuna
Re: wysiwyg and SPAW editors in 2.2.3 and/or zmagazine
  • 2006/3/28 8:54

  • chrometuna

  • Just popping in

  • Posts: 67

  • Since: 2004/7/24


Quote:

JackJ wrote:
Hello there,

On my test site you can see the layout of some categories:

http://www.macambridge.com/zmagazine+index.category+1.htm


OK....half of my stupidity was not remembering that SPW etc do not work in Firefox, which I find disturbing.

NOW....this is probably more of that blindness....but HOW do you get the photos to appear in the summeries?

How do I get the photos to appear in the catagory summeries on the frontpage of zmagazine?

Cheers
bc



4
chrometuna
Re: wysiwyg and SPAW editors in 2.2.3 and/or zmagazine
  • 2006/3/22 21:19

  • chrometuna

  • Just popping in

  • Posts: 67

  • Since: 2004/7/24


Any help?



5
chrometuna
wysiwyg and SPAW editors in 2.2.3 and/or zmagazine
  • 2006/3/22 11:23

  • chrometuna

  • Just popping in

  • Posts: 67

  • Since: 2004/7/24


I couldn't find a solution for this after several searches.

I just installed 2.2.3 and noticed the SPAW editor module, and I installed that.

I am using zmagazine for my main news/content module. But I cannot get the SPAW editor to work with it (No selection menu, just the standard XOOPS editor)

Whats the trick to getting SPAW, or any other wysiwyg editor working in all of the modules?

I tried editing the xoopseditor.php class file, as per other suggestions, but that did not work.

I am sure that in past XOOPS installations I have had SPAW and KOIVI working in zmagazine, but I cant get them to work in it now.

Any help? Please? None of the other articles or support forums posts really addressed this. Isnt there one of the xf-section type modules that includes SPAW with it?

Cheers
bob c



6
chrometuna
Re: Extended profiles: Field-tab not working
  • 2006/1/1 22:04

  • chrometuna

  • Just popping in

  • Posts: 67

  • Since: 2004/7/24


Quote:

armitage wrote:
I hate to me-too, but I am having the same problem:

Xoops 2.2.3-RC1
Apache 2.0.54
MySQL 4.1.12
PHP 4.4.0

Fields Tab in module profile yields:

Fatal error: Call to a member function on a non-object in /path-to-apache-root/html/modules/profile/admin/field.php on line 93

Any help would be much appreciated.


I am in the same situation, I hope that someone can help us sort this out?

Can extended profiles be uninstalled and then re-installed to fix the problem? It might have been a mistake to make the entire XOOPS so dependent on extended profiles.

Could someone help us?

Cheers
bob c



7
chrometuna
Re: Multiple Forums or Cloned Forum modules?
  • 2005/12/27 17:48

  • chrometuna

  • Just popping in

  • Posts: 67

  • Since: 2004/7/24


OK, I reverted to the "original" newbbex module and to the original error. (So that I could start making changes fresh)

I get:
Fatal errorCannot redeclare get_total_topics() (previously declared in /modules/newbbex/functions.php:25in /modules/newbb/include/functions.php on line 643


So is there a simple change I can make to one of these lines/files?

And will that just lead me to the next error?

I am sure that someone else will benifit from this thread and info, as it is something that I havnt found a satisfactory solution for.

Thanks!

Cheers
bob c



8
chrometuna
Re: Multiple Forums or Cloned Forum modules?
  • 2005/12/27 16:45

  • chrometuna

  • Just popping in

  • Posts: 67

  • Since: 2004/7/24


Quote:

Bender wrote:
You could use a grep tool and rename this funtion within newbbex module to something different since it seems this name is used in both modules then.

Problem is that you might have to redo this with every moduleupdate in the future. (which is not so much of a problem as long as it will only affect a handfull of functionnames)


OK.
Now pardon my ignorance, but what is a "grep tool"? And how do I use it?

Is this a matter of both modules trying to use the same database table? If so, the why do I only get this error in newbbex and not CBB?

Cheers
bob c



9
chrometuna
Re: Multiple Forums or Cloned Forum modules?
  • 2005/12/27 7:59

  • chrometuna

  • Just popping in

  • Posts: 67

  • Since: 2004/7/24


OK, Ive tried this, and here is the error messages that I get:

Quote:
Fatal error: Cannot redeclare get_total_topics() (previously declared in /public_html/modules/newbbex/functions.php:25) in /public_html/modules/newbb/include/functions.php on line 643


I did some searching on these errors here, but my little brain couldnt make sense of the info, or find any real solutions?

CBB works fine, no errors after installing newbbex. But newbbex shows these errors (And nothing else on the page)

What code modifications can I make? And where?

And how can I use koivi or spaw editor with this forum?

(I also cant seem to get SPAW to work in the news module...but it DOES work in the zmagazine module?)

I thank anyone for any help!

Cheers
bob c



10
chrometuna
Re: Multiple Forums or Cloned Forum modules?
  • 2005/12/27 7:50

  • chrometuna

  • Just popping in

  • Posts: 67

  • Since: 2004/7/24


Quote:

JMorris wrote:


If it were me, I would run two distinctly different modules. This would help reduce the risk of accidental data corruption on update that you would have with cloned modules.

I would suggest using CBB for the forum that requires the most granular permissions and using Newbbex for the more general forum. I hope this answers your question.

Best Regards,

James


That is close to the answer I was looking for.

But it seems to me like I tried this, and the two modules comflicted.....like they tried using the exact same database tables?

Isnt CBB just a re-wired version of newbbex?

Im not sure if I am ready yet to tackle cloning a forum module....seems like I have read here that those are particularly tricky. But I would bet that there are enough people like me that would really dig a cloned forum module?

Too bad that most of us that want such a thing are not able to DO it!

Thanks!
Cheers
bob c




TopTop
(1) 2 3 4 ... 6 »



Login

Username:
Password:

Lost Password? Register now!

Who's Online

75 user(s) are online (39 user(s) are browsing Support Forums)


Members: 0


Guests: 75


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: May 31
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits