XOOPS: XOOPS 2.0.2 released!

Posted by: onokazuon 2003/4/25 13:49:33 9065 reads XOOPS Team is pleased to announce the 3rd stable release of XOOPS 2.0. It includes some important security related bug fixes therefore it is highly recommended that all users upgrade to this version.

Changes
========
- security fix to prevent malicious cross site scripting attacks (Onokazu)
- fixed character encoding problem for some languages when using the mailer class (Onokazu)
- fixed some major bugs in the xoopsheadline module (Onokazu)
- fixed some cookie related problems in the forums module (mvandam)

Requirements
========
PHP 4.1.0 or later (on IIS, 4.3.1 or later)
MySQL 3.23.xx

Install
========
Download the full package, unpack it and upload all files included. Point your browser to /install/index.php to start the installer. Please read docs/INSTALL.html for details on installation and/or read the Install and Upgrade sections of the Wiki ( http://wiki.xoops.org ).

Upgrade
========
Upgrade from XOOPS 2.0.1
1. Download the fix package (tar.gz / zip) for XOOPS 2.0.1, unpack it and upload all files included (files will be overwritten).

Upgrade from XOOPS 2.0.0
1. You must first upgrade to XOOPS 2.0.1. To do so, download the fix package (tar.gz / zip) for 2.0.0, unpack it and upload all files included (some files will be overwritten).
2. Point your browser to http://path_to_xoops/upgrade/xoops2_0_to_2_0_1.php and follow the instruction displayed.
3. Now that you have upgraded to 2.0.1, follow the upgrade instruction above for XOOPS 2.0.1.

Upgrade from XOOPS 2.0 RC3
1. You must first upgrade to XOOPS 2.0.0. To do so, download the fix package (tar.gz / zip) for XOOPS 2.0 RC3, unpack it and upload all files included (some files will be overwritten).
2. You have now upgraded to 2.0.0. Follow the upgrade instruction above for XOOPS 2.0.0.

Upgrade from XOOPS 2.0 RC2
1. Read this article and upgrade to XOOPS 2.0 RC3 first. Then follow the upgrade instruction above for XOOPS 2.0 RC3.

Upgrade from XOOPS 1.3.x
1. Download the full package, unpack it and upload all files included (some files will be overwritten).
2. Point your browser to /install/index.php to start the installer. The installer will automatically detect your 1.3.x and upgrade to 2.0.1. Please read docs/INSTALL.html for details on installation and/or read the Install and Upgrade sections of the Wiki (wiki.xoops.org).

Language
========
Language files can be (or will be) downloaded here.