1
sailjapan
Smarty.class.php line 1092

I see an awful lot of problems in the forums from users whose error report includes this line:
Quote:
Smarty.class.php line 1092


Run a search of the forums for it, and you'd be amazed!

Is there a way the support team could put together a list of common error reports and add them to the FAQ? I'll help find them if someone can provide the fixes

Oh, and what does this error report indicate, btw?
Never let a man who does not believe something can be done, talk to a man that is doing it.

2
sailjapan
Re: Smarty.class.php line 1092

am I the only one with access to this forum?
Never let a man who does not believe something can be done, talk to a man that is doing it.

3
bprado
Re: Smarty.class.php line 1092
  • 2009/6/4 17:51

  • bprado

  • Not too shy to talk

  • Posts: 103

  • Since: 2008/9/9 1


im waiting for answers from the XOOPS experts!!!

in my research i find that old templates are not compatible with the new version, old templates that dont have the "xo" variables!!!

4
ghia
Re: Smarty.class.php line 1092
  • 2009/6/4 23:24

  • ghia

  • Community Support Member

  • Posts: 4953

  • Since: 2008/7/3 1


I found mosttimes this error was because a template was not present in the database. Some causes are:
- Installation of a new templateset or cloning the default one, can make that with installation or deinstallation of modules and themes some templates are missing. These have to be generated by the admin function.
- Theme overloading: the theme can provide templates for some modules. When they call different (sub)templates, switching themes can confuse the system.
- After editing templates the debug for smarty should be put on to check for errors and the required modules should be updated in admin module manager. Check also the verbose for errors and correct them immediatly. Failing to do so can also have inconsistent templates in the database.
- Errors in templates can also lead to various results.
Quote:
in my research i find that old templates are not compatible with the new version, old templates that dont have the "xo" variables
That should not be much a problem. Most older themes and templates work with the newer XOOPS (in their limitations), but newer themes with older XOOPS require some conversion.

Login

Username:
Password:

Lost Password? Register now!

Who's Online

69 user(s) are online (39 user(s) are browsing Support Forums)


Members: 0


Guests: 69


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: May 31
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits