1
pinay007
Moved servers, and got these errors...
  • 2005/12/21 8:01

  • pinay007

  • Just popping in

  • Posts: 8

  • Since: 2005/11/16


I recently moved servers for one of my XOOPS sites (the SQL information didn't change, the domain name didn't change, just a standard server move), and I got the following errors...

Quote:
Fatal error: Call to a member function on a non-object in /home/fanders/public_html/class/theme.php on line 499
Notice [PHP]: Undefined index: enable_badips in file class/xoopssecurity.php line 215
Notice [PHP]: Undefined index: language in file include/common.php line 152
Notice [PHP]: Undefined index: language in file include/common.php line 172
Notice [PHP]: Undefined index: use_ssl in file include/common.php line 183
Notice [PHP]: Undefined index: use_mysession in file include/common.php line 185
Notice [PHP]: Only variable references should be returned by reference in file kernel/module.php line 1338
Notice [PHP]: Only variables should be assigned by reference in file include/common.php line 215
Notice [PHP]: Undefined index: banners in file include/common.php line 235
Notice [PHP]: Undefined index: debug_mode in file include/common.php line 235
Warning [PHP]: in_array(): Wrong datatype for second argument in file include/common.php line 235
Notice [PHP]: Undefined index: theme_fromfile in file class/template.php line 66
Notice [PHP]: Undefined index: sitename in file class/theme.php line 417
Notice [PHP]: Undefined index: slogan in file class/theme.php line 418
Notice [PHP]: Only variables should be assigned by reference in file kernel/config.php line 239
Notice [PHP]: Undefined index: slogan in file class/theme.php line 436
Notice [PHP]: Undefined index: closesite in file include/common.php line 238
Notice [PHP]: Undefined index: use_mysession in file include/functions.php line 411
Notice [PHP]: Undefined index: theme_set in file class/theme.php line 253
Notice [PHP]: Undefined index: theme_set in file include/functions.php line 462
Notice [PHP]: Undefined index: language in file class/theme.php line 263
Notice [PHP]: Undefined index: theme_set in file include/functions.php line 462


Any ideas on how to fix it? Thanks!

2
dap997
Re: Moved servers, and got these errors...
  • 2005/12/21 17:09

  • dap997

  • Friend of XOOPS

  • Posts: 37

  • Since: 2005/2/20


Any one?

dap

3
Arowana
Re: Moved servers, and got these errors...
  • 2005/12/21 18:27

  • Arowana

  • Friend of XOOPS

  • Posts: 323

  • Since: 2004/8/6 2


did you set the permissions on the proper directories?

cache - 777
uploads - 777
template_c - 777

Delete everything out of your template_c but the index.html file

database prefix didnt change at all? I know when I moved servers it went from server1_databasename to server2_databasename

might want to upload all the files again OR OR OR OR
Get the same version of XOOPS and Modules you were running before the move. Then install all that that, finally run your SQL back up file so it will import all your info and settings.

James
Arowana

4
pinay007
Re: Moved servers, and got these errors...
  • 2005/12/22 21:46

  • pinay007

  • Just popping in

  • Posts: 8

  • Since: 2005/11/16


Quote:

Arowana wrote:
did you set the permissions on the proper directories?

cache - 777
uploads - 777
template_c - 777

Delete everything out of your template_c but the index.html file

database prefix didnt change at all? I know when I moved servers it went from server1_databasename to server2_databasename

might want to upload all the files again OR OR OR OR
Get the same version of XOOPS and Modules you were running before the move. Then install all that that, finally run your SQL back up file so it will import all your info and settings.


Nope, my database prefixes didn't change. I did try to reupload everything and that didn't work.

I think I might try your second fix. Thanks!

5
liture
Re: Moved servers, and got these errors...
  • 2005/12/29 19:21

  • liture

  • Just popping in

  • Posts: 42

  • Since: 2005/8/10


I have simply white page and can not see anything, can you please advise?

6
nickpope
Re: Moved servers, and got these errors...
  • 2005/12/29 19:40

  • nickpope

  • Just popping in

  • Posts: 20

  • Since: 2004/10/15


Quote:

liture wrote:
I have simply white page and can not see anything, can you please advise?


I just moved servers and got the white page. Double check your folder and file permissions - I found several folders and files with the wrong permissions, after setting the permissions correctly it was all good.

7
liture
Re: Moved servers, and got these errors...
  • 2005/12/29 19:51

  • liture

  • Just popping in

  • Posts: 42

  • Since: 2005/8/10


thank you for your prompt reply, I already checked uploads, cache and templates_c they all have 777 and mainfile.php has 644..aby other folder with special permission needs?

And can you tell me how can I turn un debug mode for version 2.2.2 if have only access to the files and database?

Cheers!

8
Bender
Re: Moved servers, and got these errors...
  • 2005/12/29 19:55

  • Bender

  • Home away from home

  • Posts: 1899

  • Since: 2003/3/10


Quote:
And can you tell me how can I turn un debug mode for version 2.2.2 if have only access to the files and database?


The answer is in here:

https://xoops.org/modules/smartfaq/faq.php?faqid=80
Sorry, this signature is experiencing technical difficulties. We will return you to the sheduled signature as soon as possible ...

9
nickpope
Re: Moved servers, and got these errors...
  • 2005/12/29 20:05

  • nickpope

  • Just popping in

  • Posts: 20

  • Since: 2004/10/15


Quote:

liture wrote:
thank you for your prompt reply, I already checked uploads, cache and templates_c they all have 777 and mainfile.php has 644..aby other folder with special permission needs?

Cheers!


mainfile.php should be 444 but I don't think that is your problem.

What I did was setup a new installation of XOOPS in a temporary sub domain, then compare all the folder/file permissions. Most of the files had the wrong permissions.

10
liture
Re: Moved servers, and got these errors...
  • 2005/12/29 20:22

  • liture

  • Just popping in

  • Posts: 42

  • Since: 2005/8/10


I have checked the link before posting but the sction wher eit mentions 2.2.2.:
------------
2a. In XOOPS 2.2, go to your site's root file "recovery.php" and set the debug settings through the interface here
-------

I did not find it in the file, ther eeven no debug word in it...I know am newbie, but I need help urgently..please be patient

Login

Who's Online

36 user(s) are online (13 user(s) are browsing Support Forums)


Members: 0


Guests: 36


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Aug 31
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits