xoops forums

destrux

Moderator
Posted on: 2002/10/3 19:01
destrux
destrux (Show more)
Moderator
Posts: 57
Since: 2002/6/3 1
#11

Re: "Sorry, you do not have the permission to access this area...."

In your case you just need to go to your admin control panel and then system and groups. There you will see your access rights. Adjust access of the forum for your anonymous group.

destrux

Moderator
Posted on: 2002/10/3 19:04
destrux
destrux (Show more)
Moderator
Posts: 57
Since: 2002/6/3 1
#12

Re: "Sorry, you do not have the permission to access this area...."

densma - you can find that code in language/english/global.php. Or change english to whatever language pack you are using as default. The code you are looking for is this

define("_NOPERM","Sorry, you don't have the permission to access this area.");

mwoodwar

Just popping in
Posted on: 2003/1/13 15:48
mwoodwar
mwoodwar (Show more)
Just popping in
Posts: 2
Since: 2002/10/5
#13

Re: "Sorry, you do not have the permission to access this area...."

Well, I got stuck in the "you do not have access" loop this morning, and found it MOST disturbing. Thankfully I came across Frankenstein's post stating:

you can set the permission again by steps :
go to phpadmin
open your sql
go to xoops_modules
set the valua of isactive to 0 then go to the main site and login again

My question is...what did I do to cause this, and can I do something to keep from having it happen again?

Mark

TooBaked

Just popping in
Posted on: 2003/3/9 10:11
TooBaked
TooBaked (Show more)
Just popping in
Posts: 37
Since: 2003/2/9 5
#14

Re: "Sorry, you do not have the permission to access this area...."

This post is not good sorry for the ugly space but there was an expired domain with porn ads hope you can understand. mod should delete this post.

TooBaked

Just popping in
Posted on: 2003/3/9 18:35
TooBaked
TooBaked (Show more)
Just popping in
Posts: 37
Since: 2003/2/9 5
#15

Re: "Sorry, you do not have the permission to access this area...."

this one too please ugly space this post has expired

tripmon

Module Developer
Posted on: 2004/3/3 13:23
tripmon
tripmon (Show more)
Module Developer
Posts: 462
Since: 2004/2/28
#16

Re: "Sorry, you do not have the permission to access this area...."

Need more info.... put the bowl down...

Stop day dreaming of luscious nugs.....

What page are you hitting to get that?

Can you get to:
yourURL/user.php?

Does it give the same message?

If you can log in you can go to, or type in
yourURL/modules/admin.php

Go into groups and set permissions on all modules active in the anonymous group.

GL,
Trip

arvindg1

Just popping in
Posted on: 2004/3/11 1:40
arvindg1
arvindg1 (Show more)
Just popping in
Posts: 17
Since: 2004/2/21
#17

Re: "Sorry, you do not have the permission to access this area...."

i am having a similar problem with xfsection module. i can use most of its features, but when i click on the "general configuration" option, i get the "Sorry, only the Webmaster can change XF-Section's configuration" message.

my account is a webmaster account. i had removed the original webmaster account that was first created with xoops. i have multiple other accounts that are in the "Webmaster" group. how can i re-create that first webmaster account?

Stewdio

Community Support Member
Posted on: 2004/3/11 2:55
Stewdio
Stewdio (Show more)
Community Support Member
Posts: 1560
Since: 2003/5/7 1
#18

Re: "Sorry, you do not have the permission to access this area...."

The webmaster account (original one) is linked to uid=1. In some modules, if you have deleted the original webmaster that was created upon installation, you may encounter issues.

I ran into this once before and was unaable to replace the the original properly so I just did a reinstall. This was one of the first times I used XOOPS so it wasn't a big deal, but in your case, you may not want to do that if your site is already live or you have spent a lot of time on it.

Anyone here happen to know how to recreate the original webmaster uid so that our friend here can get back to business?

arvindg1

Just popping in
Posted on: 2004/3/11 3:17
arvindg1
arvindg1 (Show more)
Just popping in
Posts: 17
Since: 2004/2/21
#19

Re: "Sorry, you do not have the permission to access this area...."

the seems like exactly the problem stew. anyone know how i can create user with uid=1? help!

fredski

Quite a regular
Posted on: 2004/4/22 10:36
fredski
fredski (Show more)
Quite a regular
Posts: 265
Since: 2004/1/26
#20

Re: "Sorry, you do not have the permission to access this area...."

My particular problem with this "sorry, you do not...." text appearing is when my registered users try to access a foum I have setup for them, I set the level of the forum to registered users and made it private so guest users can't read the posts, Problem is my registered users can't get in to view or post because it says "sorry, you do not....". the only way I can do it at the moment is have the forum public but only allow registered users to post, which isn't what I need.
Does anyone have a workaround for this??????