xoops forums

navin

Just popping in
Posted on: 2004/4/8 6:52
navin
navin (Show more)
Just popping in
Posts: 13
Since: 2004/4/5 1
#1

USER with NO AVATARS , WHY?

Whenever i log on,i tried to change the avatar but no way out!! i did every possibilities.

From member menu, i tried to click the available registered user. Then , the coming up page shows blank. So, please so me the way, how should i solve this problem!

I uploaded my own avatar to the host and it shows System avatar list. I thought it should be custom avatar.

But i think first that page should come up which should be shown after i click the registered user.

i'm the webmaster of the web site.

Thanks, please help me.

kahumbu

Documentation Writer
Posted on: 2004/4/8 7:06
kahumbu
kahumbu (Show more)
Documentation Writer
Posts: 277
Since: 2003/8/23
#2

Re: USER with NO AVATARS , WHY?

I'm not sure if this will help, but there is a minimum no. of posts before a user can upload an avatar.

Go to Sys Admin -> Preferences -> User Info. See if the "Allow custom avatar upload?" is set to "Yes". And then go to the next line, "Minimum posts required", and input a reasonable number. For my site, I set it to 10 posts.

Then check to see if you can upload an avatar. Even Webmasters are not exempt to this. Lower the number first if you want to put your avatar, and then raise it back to whatever you want for the other users.

navin

Just popping in
Posted on: 2004/4/8 12:22
navin
navin (Show more)
Just popping in
Posts: 13
Since: 2004/4/5 1
#3

Re: USER with NO AVATARS , WHY?

Since, i'm on the initial stage of my website publishing. I just did make "1" in place of "O" for the minimum posts required to upload avatars. I also set YES to custom avatar upload. Still, nothing shows when i wanted to change avatar and click on the user.

I don't know what is the problem?


Penultimate

Just popping in
Posted on: 2004/5/24 4:22
Penultimate
Penultimate (Show more)
Just popping in
Posts: 6
Since: 2004/5/24
#4

Re: USER with NO AVATARS , WHY?

Yep..i'm having the same problem and can find no answers anywhere here...probably just don't know where to look. hook us up, xoops-gurus

limecity

Friend of XOOPS
Posted on: 2004/5/24 5:06
limecity
limecity (Show more)
Friend of XOOPS
Posts: 1602
Since: 2003/7/6 0
#5

Re: USER with NO AVATARS , WHY?

step back to the basic procedure..
did you chmod the upload folder to 777 ?

Penultimate

Just popping in
Posted on: 2004/5/25 3:08
Penultimate
Penultimate (Show more)
Just popping in
Posts: 6
Since: 2004/5/24
#6

Re: USER with NO AVATARS , WHY?

unfortunately, basic procedure to me does not include chmoding anything. please explain what that means.

Herko

XOOPS is my life!
Posted on: 2004/5/25 7:14
Herko
Herko (Show more)
XOOPS is my life!
Posts: 4238
Since: 2002/2/4 1
#7

Re: USER with NO AVATARS , WHY?

First of all, when you get a blank page, turn on PHP-debug mode in the system admin -> preferences -> general settings page. Then, return to the page that produces the blank page, and note the errors that cause the page to break. That way you can detrmine the offending broken code, and we can give a specific answer. XOOPS is a complex system, without this information we're just guessing.

Secondly, the chmod issue. This is a command for linux and unix (web)servers to set the read/write/execute rights for each file and folder. To set multiple combinations quickly, this command works with 3 digit combinations. 444 is read only, 666 is read and write, 777 is full access rights. XOOPS requires the cache/, templates_c/ and uploads/ folders to be given full access rights (chmod 777).
Setting these rights depend on where you're running the webserver (if it's a localhost or on space provided by the hoster), the server's operating system (is it a windows server or a linux/unix server), and the FTP client (to give the chmod command itself). The most common setup would be you have uploaded the filesd to a webspace on a shared hosting provider, using a linux webserver. That means it depends on your FTP client. Most clients I have worked with have a 'properties' or 'commands' menu in the right-click contextual menu. Thus, rightclick on the uploads/ folder, select 'properties' or 'commands', and then select CHMOD. Check your FTP client's help menu for clear instructions on how to CHMOD a file or folder.

I hope this makes it more clear for you

Herko

Penultimate

Just popping in
Posted on: 2004/5/25 22:12
Penultimate
Penultimate (Show more)
Just popping in
Posts: 6
Since: 2004/5/24
#8

Re: USER with NO AVATARS , WHY?

absolutely that helped. thanks a ton!

navin

Just popping in
Posted on: 2004/5/30 12:54
navin
navin (Show more)
Just popping in
Posts: 13
Since: 2004/4/5 1
#9

Re: USER with NO AVATARS , WHY?

Hello, i already did that chmod stuff but that's not working. So, when i enabled the PHP Debuf mode as described above. I got so many unknown warning codes. When i click one of the member, it shows me the page like below:

------------------
Warning: open_basedir restriction in effect. File is in wrong directory in /home/usr/local/share/doc/vhost/navinpcfreak.com/httpdocs/xoop/modules/myalbum/xoops_version.php on line 105

Warning: Bad arguments to implode() in /home/usr/local/share/doc/vhost/navinpcfreak.com/httpdocs/xoop/modules/xoogle/include/xoogle.php on line 87

Notice: Undefined index: estimatedTotalResultsCount in /home/usr/local/share/doc/vhost/navinpcfreak.com/httpdocs/xoop/modules/xoogle/include/xoogle.php on line 163

Notice: Undefined index: page in /home/usr/local/share/doc/vhost/navinpcfreak.com/httpdocs/xoop/modules/xoogle/include/xoogle.php on line 165

Notice: Undefined variable: post in /home/usr/local/share/doc/vhost/navinpcfreak.com/httpdocs/xoop/modules/xoogle/include/xoogle.php on line 169

Notice: Undefined index: soap_error in /home/usr/local/share/doc/vhost/navinpcfreak.com/httpdocs/xoop/modules/xoogle/include/xoogle.php on line 125

Warning: Invalid argument supplied for foreach() in /home/usr/local/share/doc/vhost/navinpcfreak.com/httpdocs/xoop/modules/xoogle/include/xoogle.php on line 133

Notice: Undefined variable: ret in /home/usr/local/share/doc/vhost/navinpcfreak.com/httpdocs/xoop/modules/xoogle/include/xoogle.php on line 140

Fatal error: Call to a member function on a non-object in /home/usr/local/share/doc/vhost/navinpcfreak.com/httpdocs/xoop/userinfo.php on line 157
----------------
i'm totally unknown with this stuff..
What is wrong?? please help me ..
oh lords of XOOPS..

regards
Navin