xoops forums

mrphilong

Quite a regular
Posted on: 2009/11/4 22:59
mrphilong
mrphilong (Show more)
Quite a regular
Posts: 351
Since: 2006/7/14
#1

xlanguage in xoops 2.4

include_once XOOPS_ROOT_PATH.'/modules/xlanguage/api.php';
    
into XOOPS/include/common.php 
    RIGHT BEFORE 
        
// #################### Include site-wide lang file ##################
        
if ( file_exists(XOOPS_ROOT_PATH."/language/".$xoopsConfig['language']."/global.php") ) {
            include_once 
XOOPS_ROOT_PATH."/language/".$xoopsConfig['language']."/global.php";
        } else {
            include_once 
XOOPS_ROOT_PATH."/language/english/global.php";
        }


XOOPS/include/common.php is not the same as previous version of Xoops, does anyone know where about to insert XOOPS_ROOT_PATH.'/modules/xlanguage/api.php'; in XOOPS/include/common.php ?

Burning

Theme Designer
Posted on: 2009/11/4 23:09
Burning
Burning (Show more)
Theme Designer
Posts: 1163
Since: 2006/8/22
#2

Re: xlanguage in xoops 2.4

hi'

You should try after line 149 and this code
xoops_loadLanguage('pagetype');

Mamba

Moderator
Posted on: 2009/11/4 23:55
Mamba
Mamba (Show more)
Moderator
Posts: 10418
Since: 2004/4/23
#3

Re: xlanguage in xoops 2.4

No need to do anything anymore.

Just download the updated version, install it, and you're done.

Thanks to Preloads and to Trabis, with this new version of xLanguage, starting with XOOPS 2.4, there is no need to hack anything anymore.

Burning

Theme Designer
Posted on: 2009/11/5 0:10
Burning
Burning (Show more)
Theme Designer
Posts: 1163
Since: 2006/8/22
#4

Re: xlanguage in xoops 2.4

Excellent news

Thanks !

ghia

Community Support Member
Posted on: 2009/11/5 0:46
ghia
ghia (Show more)
Community Support Member
Posts: 4946
Since: 2008/7/3 1
#5

Re: xlanguage in xoops 2.4

Shouldn't the version number not be incremented to 3.02?

It seems these proposals were not incorporated. Don't know if they are for real.

mrphilong

Quite a regular
Posted on: 2009/11/5 1:15
mrphilong
mrphilong (Show more)
Quite a regular
Posts: 351
Since: 2006/7/14
#6

Re: xlanguage in xoops 2.4

Upgraded to preload version and hack for php5.2 but still doesn't work.

Mamba

Moderator
Posted on: 2009/11/5 6:26
Mamba
Mamba (Show more)
Moderator
Posts: 10418
Since: 2004/4/23
#7

Re: xlanguage in xoops 2.4

Quote:
Shouldn't the version number not be incremented to 3.02?

Done

Quote:
It seems these proposals were not incorporated. Don't know if they are for real.

Trabis did only a change to make it work with preloads, but nothing else. It would be nice if somebody could update the module with these hacks, and whatever else is needed...

Mamba

Moderator
Posted on: 2009/11/5 6:28
Mamba
Mamba (Show more)
Moderator
Posts: 10418
Since: 2004/4/23
#8

Re: xlanguage in xoops 2.4

Quote:
Upgraded to preload version and hack for php5.2 but still doesn't work.

Did you update the module in Admin?
What kind of errors are you getting now?

ghia

Community Support Member
Posted on: 2009/11/5 7:57
ghia
ghia (Show more)
Community Support Member
Posts: 4946
Since: 2008/7/3 1
#9

Re: xlanguage in xoops 2.4

Check also by switching the language in the XOOPS general preferences, if the site works OK in both languages.

poehoes

Friend of XOOPS
Posted on: 2009/11/6 13:09
poehoes
poehoes (Show more)
Friend of XOOPS
Posts: 24
Since: 2003/3/27
#10

Re: xlanguage in xoops 2.4

Great! Now i can upgrade without extra steps


In the Trunk there still exists a readme.txt that gives the old instructions (hackin into common.php). Maybe that should be deleted too?