xoops forums

RiazShahid

Quite a regular
Posted on: 2008/10/17 10:14
RiazShahid
RiazShahid (Show more)
Quite a regular
Posts: 254
Since: 2007/6/26
#11

Re: Xoops is over loading the server

Is it the problem of only the home page or other pages as well?
My host is too good, this is not their issue, but its in my xoops.
My XOOPS version is 2.0.17
I use random entries for home page, so must use Cache?
Total 75 Queries on home page, with following 16 blocks.

User Menu: No Cache
Login: No Cache
Search: No Cache
Main Menu: No Cache
Themes: No Cache
My Tabs Block: No Cache
Updates: No Cache
Recently added books: No Cache
Recently added works: No Cache
Recently added "Books": No Cache
Promoted Literature: No Cache
Random item !: No Cache
Random item !: No Cache
Random item !: No Cache
Recent items List: No Cache
Meta Albums: No Cache

TIMER is as under;

XOOPS took 11.366 seconds to load.
XOOPS Boot took 0.380 seconds to load.
Module init took 0.003 seconds to load.
XOOPS output init took 10.970 seconds to load.
Updates(5) took 0.008 seconds to load.
Recently added books of ....(2) took 1.562 seconds to load.
Recently added works on (6) took 2.269 seconds to load.
Recently added ".... Books"(3) took 2.254 seconds to load.
Promoted Literature(7) took 0.002 seconds to load.
Module display took 0.001 seconds to load.
Page rendering took 0.008 seconds to load

RiazShahid

Quite a regular
Posted on: 2008/10/17 10:23
RiazShahid
RiazShahid (Show more)
Quite a regular
Posts: 254
Since: 2007/6/26
#12

Re: Xoops is over loading the server

Quote:

JAVesey wrote:
Sounds like your hosts are trying to maximise the number of accounts using the server.
I think you need to speak to them - they will probably try to get you to upgrade to a higher spec server with less users but it's worth a try.

Already done that. Our hosts are friendly to us, they upgraded us to 200 megabytes of memory consumption, isn't it enough for Linux?

Anonymous

Posted on: 2008/10/17 10:24
Anonymous
Anonymous (Show more)
Posts: 0
Since:
#13

Re: Xoops is over loading the server

Quote:
RiazShahid wrote:

My host is too good, this is not their issue, but its in my xoops.


Sorry, I don't agree. This is a server issue - look at these timings:

Quote:
RiazShahid wrote:

XOOPS took 11.366 seconds to load.
XOOPS output init took 10.970 seconds to load.


Thes two show that it's a server issue.....

Sounds like to like your hosting company but you must be practical.

Anonymous

Posted on: 2008/10/17 10:31
Anonymous
Anonymous (Show more)
Posts: 0
Since:
#14

Re: Xoops is over loading the server

For comparison, my homepage timers - queries/blocks as before, no caching, uk based host in the middle of busy Friday morning, XOOPS 2.3.1:

XOOPS took 0.841 seconds to load.
XOOPS Boot took 0.049 seconds to load.
Module init took 0.012 seconds to load.
XOOPS output init took 0.772 seconds to load.
Module display took 0.001 seconds to load.
Page rendering took 0.003 seconds to load.

Quite a difference, eh?

Don't close your eyes/mind to the obvious

usmanghani

Just popping in
Posted on: 2008/10/17 10:55
usmanghani
usmanghani (Show more)
Just popping in
Posts: 3
Since: 2008/10/17
#15

Re: Xoops is over loading the server

Awesome figures.

I would like to know these:
1. PHP version.
2. XOOPS version.
3. Linux Distro/version
4. Are there any specific settings you did to optimize.
5. Running PHP as mod_php or over CGI? I am assuming your Web Server is Apache.

Anonymous

Posted on: 2008/10/17 11:01
Anonymous
Anonymous (Show more)
Posts: 0
Since:
#16

Re: Xoops is over loading the server

Some info:

XOOPS Version: XOOPS 2.3.1
PHP Version: 5.2.5
MySQL Version: 4.1.20-log
Server API Version: cgi-fcgi
OS Version: Linux
safe_mode: off
register_globals: off
magic_quotes_gpc: on
allow_url_fopen: on
fsockopen: on
allow_call_time_pass_reference: on
post_max_size: 8M
max_input_time: 60
output_buffering: on
max_execution_time: 30
memory_limit: 12M
file_uploads: on
upload_max_filesize: 8M

webserver is Apache. Does this help?

dslchart

Not too shy to talk
Posted on: 2008/10/17 11:29
dslchart
dslchart (Show more)
Not too shy to talk
Posts: 112
Since: 2008/9/7 1
#17

Re: Xoops is over loading the server

if you have a root server you can install the eaccelerator.

ghia

Community Support Member
Posted on: 2008/10/17 11:56
ghia
ghia (Show more)
Community Support Member
Posts: 4954
Since: 2008/7/3 1
#18

Re: Xoops is over loading the server

The numbers for the loading times are greatly dependent on the configuration of XOOPS. Some modules and blocks give a larger bite in the available server recources than others.
Quote:
I use random entries for home page, so must use Cache?
Total 75 Queries on home page, with following 16 blocks.
When using no cache, every page output has to be recalculated from scratch, which means a lot of useless work for the processor. So, put as many caches on as possible.

Rethink the layout of your pages: 16 blocks!
Are they all necessary? Do they have to show on every single page?
They all together initiate 75 queries, which I find also very much. Some may be easy, but I fear that some are quite unoptimised or have to crunch many records.
You may try them one by one in phpmyadmin to single out the heaviest.

With these figures, I'm not surprised some hosters liked more to see you go, then to come.

young

Just popping in
Posted on: 2008/10/17 12:21
young
young (Show more)
Just popping in
Posts: 99
Since: 2006/1/16
#19

Re: Xoops is over loading the server

i face the same problem before when my visitor getting more after 3 years running the site in a shared hosting with 300 account in a server.

After move to a higer spec server where only 15 account hosted in the server, then the problem gone.

this is not only happened to xoops, i has discuss with the hosting company, even using others scripts or cms, shared hosting is not suitable for high traffic sites.

trabis

Core Developer
Posted on: 2008/10/17 12:55
trabis
trabis (Show more)
Core Developer
Posts: 2269
Since: 2006/9/1 1
#20

Re: Xoops is over loading the server

Quote:

young wrote:
this is not only happened to xoops, i has discuss with the hosting company, even using others scripts or cms, shared hosting is not suitable for high traffic sites.


True, my site is around 200 users online and shared hosting is not suitable anymore.

Atention, your XOOPS is taking to much time to load. I believe that the problem is in a bad query. Perhaps you have a table with thousands of entries like a news module or something and you have a select statement without any limit. This has happened to me with the news module when using 'previous and next article' option The query was selecting 15000 news and the more news I had, the more slow my site become. This was a slow death, a killing me softly bug. Ask your hosting company if they know what is the file that is consuming resources. Probably it is in the module most used in your website.