xoops forums

ozboof

Friend of XOOPS
Posted on: 2008/7/4 13:32
ozboof
ozboof (Show more)
Friend of XOOPS
Posts: 67
Since: 2003/10/28
#1

TinyMCE debug error

Trying to install TinyMCE in a test site with 2.0.18.1 and im getting this error below when trying to edit new article there no editor showing on the page just wondering if there is a fix or something i may have over looked .

Quote:
Warning: fgets(): supplied argument is not a valid stream resource in file /modules/tinyeditor/include/initcode.php line 227Warning:

fclose(): supplied argument is not a valid stream resource in file /modules/tinyeditor/include/initcode.php line 231

ghia

Community Support Member
Posted on: 2008/7/10 23:53
ghia
ghia (Show more)
Community Support Member
Posts: 4954
Since: 2008/7/3 1
#2

Re: TinyMCE debug error

You probably have a problem with your settings for the CSS-file. You are using the TinyEditor module?

For TinyMCE you need to place xoops_editor.css in every modules/xxxxx map of the modules where the tinymce editor is to be used.

frankblack

Just can't stay away
Posted on: 2008/7/11 7:48
frankblack
frankblack (Show more)
Just can't stay away
Posts: 830
Since: 2005/6/13
#3

Re: TinyMCE debug error

tinyeditor has a fallback for using the theme's style.css when a special CSS file for the editor is not given in the preferences. Unfortunately under some circumstances this is not working reliable. Visit preferences for tinyeditor and make an entry in editor css like this (just an example):
/themes/default/style.css

or better: write a special editor css for tinyeditor.

HTH