xoops forums

drewdizzy

Just popping in
Posted on: 2006/1/28 18:03
drewdizzy
drewdizzy (Show more)
Just popping in
Posts: 23
Since: 2004/5/5 0
#41

Re: "Sorry, you do not have the permission to access this area...."

Quote:

saladin wrote:
I was having a siimilar problem where new members could no register.

The Anon. group needs to have block access to Members and Extended Profiles.

I appear to have fixed my site like this. Please test user registration if you have time:

http://www.area51.gen.nz



After searching a million times for this help, you finally solved my problem.

Thanks.

eightfan

Just popping in
Posted on: 2006/4/27 15:00
eightfan
eightfan (Show more)
Just popping in
Posts: 7
Since: 2004/5/28
#42

Re: "Sorry, you do not have the permission to access this area...."

where do u find extended profiles? I only have a members in my group authorization admin area. thx
Posted on: 2006/4/27 21:07
jensclas
jensclas (Show more)
Posts: 2089
Since: 2004/10/31
#43

Re: "Sorry, you do not have the permission to access this area...."

You probably can;t see it because you needs XOOPS 2.2 version...


"XOOPS 2.2.4 has the extended user profiles module, which allows you to easily add custom fields."

if you wait for the next release it will probably be there.

freakingid

Just popping in
Posted on: 2006/11/16 18:49
freakingid
freakingid (Show more)
Just popping in
Posts: 10
Since: 2005/8/18
#44

Re: "Sorry, you do not have the permission to access this area...."

Okay, I freaked out when I had this problem today. But I now have solved it.

The problem turned out to be with the xoops_session table. Someone said to go empty the table.

When I went to empty it... well, just look at it in phpmyadmin... it said it could not open the file (the MySQL data file... xoops_session.myi or whatever)

phpmyadmin showed the table as "in use"

In phpmyadmin, I selected the table and did a "repair table" and now everything is okay.

I have no idea how to keep this problem from happening... I am assuming it will happen again, since it looks like a zillion people have had this problem.

Paul

lucidlee

Just popping in
Posted on: 2007/4/2 1:26
lucidlee
lucidlee (Show more)
Just popping in
Posts: 33
Since: 2004/10/21
#45

Re: "Sorry, you do not have the permission to access this area...."

I'm also experiencing this notice, but its cause seems to be a variation on others experience.

1. I can logon as superuser but am immediately redirected to the lost password page after the message that "I don't have permission to...".

2. I still get bounced after I empty the session table, flush browser cache, cache & templates_c directories etc. Read/write settings on those directories are correct and a session is created when I logon.

3. I tried using phpMyAdmin to change the startpage to other modules but got the same result so its seems that for some reason module access permissions are either messed up or there is something else missing in the code.

All of this applies to a dev version of my site which I haven't touched for a month or so, but the last action I performed was to replace the multimenu module (1.8-->1.9.1). This module happened to be the startpage which in retrospect is unfortunate because I wasn't logged in at the time and so couldn't run the upgrade script.

After I got the login problem I reverted to the previous version of the module but the problems persist. Its possible that the problem was pre-existing but a month away from the project is a long time.

Are there any more suggestions for diagnosing the source of the problem?
Lee
-----------
Complexity? Its just lots of simple things connected in lots of simple ways...

srikrishnak

Just popping in
Posted on: 2007/4/20 4:29
srikrishnak
srikrishnak (Show more)
Just popping in
Posts: 1
Since: 2007/4/20
#46

Re: "Sorry, you do not have the permission to access this area...."

Hi,
I've the same problem exactly. I just installed it without any errors and when I tried to login it gives me an error saying "Incorrect Login".
tried emptying the folders as mentioned in the above post but problem still exists.
Empty the table via PHPMYADMIN also.

lucidlee

Just popping in
Posted on: 2007/5/20 14:01
lucidlee
lucidlee (Show more)
Just popping in
Posts: 33
Since: 2004/10/21
#47

Re: "Sorry, you do not have the permission to access this area...."

Hooray!
I don't quite understand how or why it suddenly goes awry but I believe I DO have a solution: turn off custom sessions and/or change the name of the custom session prefix.

I did both and was able to get a couple of users, hitherto locked out, to login and navigate normally.

Update: Changing the name of the session prefix did not seem to work for my members, but turning off sessions altogether certainly does.
Lee
-----------
Complexity? Its just lots of simple things connected in lots of simple ways...

michi

Just popping in
Posted on: 2007/6/1 21:17
michi
michi (Show more)
Just popping in
Posts: 2
Since: 2007/6/1 2
#48

Re: "Sorry, you do not have the permission to access this area...."

ok. I'm EXTREMELY frustrated at this point.

I have basically the same problem as the first guy: I can log in and browse the site, but members get the sorry message. (Unlike the first guy, though, annonymous users can see the site just fine, as long as they're not attempting to log in.)

I verifed that registered users had access to all modules. I emptied and repaired the xoops_session table. I made sure the main.php had the right URL. I turned off custom sessions.

...I honestly don't know where the sorry page is in order to add the no cache statements in the header, so I haven't tried that yet. But everything else failed.

razenyc

Just popping in
Posted on: 2008/3/13 4:27
razenyc
razenyc (Show more)
Just popping in
Posts: 6
Since: 2006/7/18
#49

Re: "Sorry, you do not have the permission to access this area...."

I seem to have this issue, but only with one specific module, my Document Management System. I can access the other areas of the site fine, but I get errors, even logged in as admin, saying that I do not have access. I emptied out my table, tried changing the isactive to 0 (which just deactivates the modlue, doesnt do much good)

Im at a loss for how to fix this, since the other sections work ok. All the module access permissions are checked in the admin side for the groups, and the users are added to their groups respectively. Ideas?

olmiller

Just popping in
Posted on: 2008/3/19 17:51
olmiller
olmiller (Show more)
Just popping in
Posts: 5
Since: 2008/3/18
#50

Re: "Sorry, you do not have the permission to access this area...."

Folks,

I seem to have raised the bar on this one! I am running XOOPS 2.0.16 and protector 3.0. I get this message on my homepage so cannot login at all. I thought I had one admin tab but did not. Is there a command line or sql way to be able to login as webmaster? I have mod-backup 3.0 with a recent backup to recover the last working config, but need to login to get to it. All constructive comments welcome. Thanks in advance.

--Otto