11
hiflyer
Re: not logging in using IE 7
  • 2008/1/17 16:40

  • hiflyer

  • Not too shy to talk

  • Posts: 107

  • Since: 2006/3/7 3


I just got this bug on a fresh install (no added modules - purely out-of-the-box) of 2.0.18 with IE7 in 2 different computers. Firefox works fine.
Clearing cookies/history sometimes works but not this time.

Changing regenerate = false worked.

12
MikeShane
Re: not logging in using IE 7
  • 2008/1/23 16:00

  • MikeShane

  • Community Support Member

  • Posts: 144

  • Since: 2008/1/5 2


This fix has worked fine no problems logging in now thanks
Musicians for musicians entertaining the world, what starts as a dream can live in reality!

13
chardiar
Re: not logging in using IE 7
  • 2008/1/23 16:50

  • chardiar

  • Just popping in

  • Posts: 91

  • Since: 2004/8/16


I can't still login in xoops.org with microsoft internet explorador.

14
DobePhat
Re: not logging in using IE 7
  • 2008/1/23 19:37

  • DobePhat

  • Friend of XOOPS

  • Posts: 656

  • Since: 2003/4/15


hmm This post is made from IE7.

I mean I usually use Firefox and im inclined to believe the IE7 is buggy so i tried it. BUT, no problems here.

Again I think this is more of a user setting, firewall, windows defender, ISP; I dunno. But It seems to be unique to certain users, I really wouldn't call it a bug in xoops.

15
bumciach
Re: not logging in using IE 7
  • 2008/2/12 15:21

  • bumciach

  • Not too shy to talk

  • Posts: 153

  • Since: 2007/6/25


I have this problem too. Firefox works fine, but IE can't login.
This problem have started when I moved XOOPS 2.0.18 from windows server to server under Linux (with newer versions apache, mysql, php). But there was a few minutes when everything worked fine... strange!

I changed '/kernel/session.php' file, uninstalled Protector module, etc. Nothing.

I switched 'Use custom session' to 'NO' and this resolved problem... for now.

EDIT: After one day it still works! Turning off 'Use custom session' option (General Preferences) is the solution.

16
karasu
Re: not logging in using IE 7
  • 2008/2/16 0:10

  • karasu

  • Just popping in

  • Posts: 22

  • Since: 2006/6/26


Hello All

i've got this problem on yesterday and i'll try all the way that post in this topic

but, that can't solve my problem T^T

so do anyone have more any suggestion

my system is

xoops 2.0.18-1rc
SQL: 4.0.26-nt
PHP: 4.4.5

thank you in advance

p.s. i use ie6 and flock

Now i can sole the problem by use phpmyadmin go to repair the session db table and the problem gone

^^

17
hiflyer
Re: not logging in using IE 7
  • 2008/3/9 16:53

  • hiflyer

  • Not too shy to talk

  • Posts: 107

  • Since: 2006/3/7 3


Oh yay. I upgraded from 2.0.17 to 2.0.18.1 and now the issue is back - but the regenerate=false fix no longer works. I believe custom session is off but I can't get in with Firefox or IE to verify it. The usual trick of clearing cookies doesn't work either. Neither did repairing the session db table.
Tried a different computer, even used Blazer browser on my Treo - get sent right back to the login screen. Already getting emails from users so it's quite widespread if not 100% (used to be just occasional).

Another user just advised me same issue with Safari browser.

Help!!

18
mubarak
Re: not logging in using IE 7
  • 2008/3/9 21:51

  • mubarak

  • Just popping in

  • Posts: 3

  • Since: 2008/3/9 1


Dear PHPPP,

I have read in changelog from 2.0.18 to 2.0.18.1 that you have made this change:

Improved: Turned enableRegenerateId off in XOOPS session to avoid problems with IEs (phppp)

But using private sessions with this setting, it seems impossible to login (explorer 6 and firefox 2.0.0.12 in a system updated from 2.0.9 to 2.0.18.1)

I find no setcookie anywhere for private session, other than in session.php (update_cookie) and it seems to be called only with enableRegenerateId true.

I need to set enableRegenerateId On in the script (kernel/session.php) to make it work.

I couldn't yet test it with explorer 7.

Could it give some problems?

Thank you, bye. Have a good work (could you say like this? bleah ... my terrible english )

19
hiflyer
Re: not logging in using IE 7
  • 2008/3/10 13:57

  • hiflyer

  • Not too shy to talk

  • Posts: 107

  • Since: 2006/3/7 3


mubarak -

Thanks - it works!
The old fix was to change kernel/session.php to regenerate = false (see post #11 above) but apparently that now creates the bug in 2.0.18.1...!
Set it to true and now it's working fine (even in IE)!
(But my 4 other 2.0.18.1 sites work fine with no change to that file/switch...)
That should keep phppp up at night for a while. I might try mirroring the trouble site and upgrading to 2.3.0a and see what happens.

20
dvdtgreen
Re: not logging in using IE 7
  • 2008/6/22 14:03

  • dvdtgreen

  • Just popping in

  • Posts: 2

  • Since: 2004/11/15


My site was installed in XOOPS 2.0.17.1.S3
and also has this problem when use IE6 or IE7 can not login.
I use the method
Quote:
check XOOPS/kernel/session.php
Line #78
var $enableRegenerateId = true;
change to
var $enableRegenerateId = false;
To see if it fixes your problem.


It worked.

Thanks a lot PHPPP

Login

Who's Online

62 user(s) are online (30 user(s) are browsing Support Forums)


Members: 0


Guests: 62


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Aug 31
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits