Module System Problem - Unable to write to main menu

By mistake I deleted Module System inside Modules but recover it again and its workin fine. But I cannot update or whatever I install it will not show left block in the administrator ( Control Panel Home ). I have installed ShoutBox, Gallery and Chat but it will not give me to hadle them in the Admin, I can only see them in the site. Below is the msg I received when I click update for system module:

failed open fileModule data updated.
Updating templates...
Template system_imagemanager.html inserted to the database.
Template system_imagemanager.html recompiled.
Template system_imagemanager2.html inserted to the database.
Template system_imagemanager2.html recompiled.
Template system_userinfo.html inserted to the database.
Template system_userinfo.html recompiled.
Template system_userform.html inserted to the database.
Template system_userform.html recompiled.
Template system_rss.html inserted to the database.
Template system_rss.html recompiled.
Template system_redirect.html inserted to the database.
Template system_redirect.html recompiled.
Template system_comment.html inserted to the database.
Template system_comment.html recompiled.
Template system_comments_flat.html inserted to the database.
Template system_comments_flat.html recompiled.
Template system_comments_thread.html inserted to the database.
Template system_comments_thread.html recompiled.
Template system_comments_nest.html inserted to the database.
Template system_comments_nest.html recompiled.
Template system_siteclosed.html inserted to the database.
Template system_siteclosed.html recompiled.
Template system_dummy.html inserted to the database.
Template system_dummy.html recompiled.
Template system_notification_list.html inserted to the database.
Template system_notification_list.html recompiled.
Template system_notification_select.html inserted to the database.
Template system_notification_select.html recompiled.
Template system_block_dummy.html inserted to the database.
Template system_block_dummy.html recompiled.

Unable to write to main menu.

Rebuilding blocks...
Block User Menu updated. Block ID: 1
Template system_block_user.html updated.
Template system_block_user.html recompiled.
Block Login updated. Block ID: 2
Template system_block_login.html updated.
Template system_block_login.html recompiled.
Block Search updated. Block ID: 3
Template system_block_search.html updated.
Template system_block_search.html recompiled.
Block Waiting Contents updated. Block ID: 4
Template system_block_waiting.html updated.
Template system_block_waiting.html recompiled.
Block Main Menu updated. Block ID: 5
Template system_block_mainmenu.html updated.
Template system_block_mainmenu.html recompiled.
Block Site Info updated. Block ID: 6
Template system_block_siteinfo.html updated.
Template system_block_siteinfo.html recompiled.
Block Who's Online updated. Block ID: 7
Template system_block_online.html updated.
Template system_block_online.html recompiled.
Block Top Posters updated. Block ID: 8
Template system_block_topusers.html updated.
Template system_block_topusers.html recompiled.
Block New Members updated. Block ID: 9
Template system_block_newusers.html updated.
Template system_block_newusers.html recompiled.
Block Recent Comments updated. Block ID: 10
Template system_block_comments.html updated.
Template system_block_comments.html recompiled.
Block Notification Options updated. Block ID: 11
Template system_block_notification.html updated.
Template system_block_notification.html recompiled.
Block Themes updated. Block ID: 12
Template system_block_themes.html updated.
Template system_block_themes.html recompiled.

Module System updated successfully.

I want someone to help me fixed this since I cannot reinstall again since I need all my database. I have try all possible but didnt help me. I even installed XOOPS in other directory and use mainfile.php to connect new database in mySQL but all gone.

I need your help to fixed. Thank you.

Re: Module System Problem - Unable to write to main menu
  • 2006/5/5 1:30

  • jlm69

  • Module Developer

  • Posts: 719

  • Since: 2002/7/19

Try to check your permissions in the templates_c folder and the cache folder, make sure they are writable.
That should fix your problem.


Re: Module System Problem - Unable to write to main menu

Yes jlm69, the templates_c, cache and upload folder were writable but still not working. It shows the same error msg. Do I need to do something with mainfile.php? but I am not sure which or where to fixed or why this is happening.
I cannot modify anything now in Admin since whatever I did will not take in action.

I cannot remove left and right -block menu now can add more. I install gallery, chat and shout box but will not show in Left Admin so I cant do anything with.

Re: Module System Problem - Unable to write to main menu
  • 2007/11/8 11:34

  • CarrieD

  • Just popping in

  • Posts: 50

  • Since: 2006/1/19

Thought I would raise this post again....

I am having similar problem trying to reinstall WFSECTION mod on my site.

Have checked all the file attributes on the files listed in this post.

HELP! still receive the same error message.

Re: Module System Problem - Unable to write to main menu
  • 2007/11/8 15:44

  • nachenko

  • Quite a regular

  • Posts: 356

  • Since: 2005/1/18

Are you sure mainmenu template is correctly uploaded? Check in your server the file is in modules/system/templates/blocks, and check the name and content.

Maybe the file is damaged.

Re: Module System Problem - Unable to write to main menu
  • 2007/11/8 19:30

  • stuie200

  • Friend of XOOPS

  • Posts: 161

  • Since: 2004/1/4 2

Maybe totally unrelated but I had the same problem on my site a few weeks ago and i tried everything to get round it.

I finaly fixed it by uploading a complete install of the latest version (following the upgrade instructions word for word) and updated the system module and that cured it.

Hope that may be of some help.


"I'm as confused as a baby in a topless bar."

Re: Module System Problem - Unable to write to main menu
  • 2007/11/15 6:45

  • yongniya

  • Just popping in

  • Posts: 2

  • Since: 2007/11/15

I have the similar problem happened in my server.
With the directory cache/ uploads/ template_c/ is wirted by webserver user.
I same try to remove it and then reinstall, but the remove button cannot be find at the module menu?
Hope who can help!
Please told me where is mistake?

Re: Module System Problem - Unable to write to main menu
  • 2007/11/24 18:09

  • Peekay

  • XOOPS is my life!

  • Posts: 2335

  • Since: 2004/11/20

I have recently had a similar problem with XOOPS 2.0.16.

I always set the cache folder permissions to 777 but 'adminmenu.php' (which is inside cache) remains set at 644 - which is the normal default for files.

On most sites, updates are no problem, but on one I got the "cannot write to main menu" error. To correct this, I had to set adminmenu.php to 666. (you may want to try that).

I have no idea why this happens. I have re-uploaded clean files so there are no corruptions AFAIK. The only significant difference is that the site which caused the problem is 2 levels down from root, i.e. example.com/subdir1/xoopsdir.
A thread is for life. Not just for Christmas.

Re: Module System Problem - Unable to write to main menu
  • 2008/6/10 7:42

  • Pakaj

  • Friend of XOOPS

  • Posts: 34

  • Since: 2004/5/5 6

I had the same problem, when I moved my site from one server to another. After setting attributes of adminmenu.php to 666 (before was 644) things gone back to normal.



Lost Password? Register now!

Who's Online

65 user(s) are online (40 user(s) are browsing Support Forums)

Members: 1

Guests: 64




Goal: $100.00
Due Date: Nov 30
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits