31
libervis
Re: Could not register new user.
  • 2005/9/12 23:10

  • libervis

  • Not too shy to talk

  • Posts: 183

  • Since: 2004/7/4 1


Guess what! The problem is solved! But not until I practically deleted the whole site and started all over, restored the profile related database tables for a few times, messed with xoops_newblock table for some odd reason of c_type structure column missing (something obviously totally unrelated). In the end it turned out that Gravies was right and that I just didn't pick up a message quite well and wondered around instead.

What I mean is this. What finally solved the problem was checking the last entries in the xoops_user_profile module. As it appears, every times me or anyone else tried to register it created a yet another pretty much empty entry with the "posts" column filled with "-1". So, even if I restored the xoops_user_profile_field table, and any other related table for that matter as well as deleted the c_templates files it didn't solve the problem as those trash entries went in the way somehow. Deleting them solved the problem.

I wasted quite alot of time rebuilding my site from scratch (from db backup of course) and I should have probably lost alot less of time over this if I only figured to look into the end of the xoops_user_profiles table. Gravies mentioned something like that on IRC, but I thought he was talking about deleting those users from the XOOPS user admin area (with the status of "-1"). Well, I obviously misread him.

All in all, I am very happy to have this problem solved and that I can again welcome new users to my site. And the time I lost rebuilding the site wasn't really for nothing. The "recent blog entries" block that cause 500 internal server error was solved as well and I took the chance while I was at rebuilding to port my content from buggy wfsections 2.01 module to awesome new smartsection 1.1 beta for 2.2. It works like a charm.

Anyway, before I stop ranting here is one error I am still getting in MySQL debug when deleting users (which could possibly cause some trouble and should thus be killed ASAP):

Quote:
Queries module

SELECT * FROM xoops_users u, xoops_user_profile p WHERE u.uid = p.profileid AND uid = '478' LIMIT 0, 1
( 0.006545)
DELETE FROM xoops_users WHERE uid = 478
( 0.076539)
DELETE FROM xoops_user_profile WHERE profileid =
Error number: 1064
Error message: You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 1
( 0.000143)

DELETE FROM xoops_groups_users_link WHERE uid = '478'
( 0.054166)


As you can see it's in "Queries module" section of the debug window and the error is in bold text.

According to the error it is in MySQL syntax and causes the inability to delete an user entry from xoops_user_profile table.

That is why I had to manually delete those bad registration profiles from it to resolve the above problem.

Extended profiles module of both 2.2.2 and 2.2.3 XOOPS is obviously still buggy. I hope the next release is finally "ironed out".

Thank you
Daniel
XOOPS Site: Libervis.com :: For a Free World

-- Libervis Network --

32
succhi
Re: Could not register new user.
  • 2005/9/20 8:28

  • succhi

  • Just popping in

  • Posts: 20

  • Since: 2004/3/20


I have found a fix to the problem of not having the user_profile deleted when trying to delete a user. The problem is that the profile found in the User object doesn't have the key set so it can't delete itself using it's own key. In Kernel/User.php assignVars($vars) is used to fill either the User object's vars or the Profile vars however the "profileid" doesn't get set. I have edited the following code so that it gets set. I don't know if this introduces any other problems but I don't think so as there is no var "profileid" initiated as part of the creation of XoopsUser so AFAIK a value can't be assigned to it anyway.

function assignVars($vars) {
$uservars = array_keys($this->getVars());
foreach ($vars as $key => $value) {
/* edit the following line to remove || $key == "profileid" */
// if (in_array($key, $uservars) || $key == "profileid") {
if (in_array($key, $uservars)) {
$this->assignVar($key, $value);
}
/*
* Dynamic user profiles - Mith
*/
else {
$this->_profile->assignVar($key, $value);
}
/*
* Dynamic user profiles end
*/
}
}

I hope that makes sense.

33
EP1988
Re: Could not register new user.
  • 2005/11/21 19:06

  • EP1988

  • Just popping in

  • Posts: 6

  • Since: 2005/11/21


guys, i'm having a problem with some crap on my website.
www.phalasteen.com/index.php (Apparently the Could not register new user. Issue is still happening)

anyway, I barely edited the site, a friend of mine registered yesterday, and when i told another friend o register, the message came out..

What should i do.
I don't have the extended profile or whatever.. i'm dyin

please help mates.

thx

34
EP1988
Re: Could not register new user.
  • 2005/11/21 21:12

  • EP1988

  • Just popping in

  • Posts: 6

  • Since: 2005/11/21


Well here's the issue

if i register a user while i'm already logged on. It works.

But if i log off and try to register, it won't work.

PLLEEAASEE HELP!

35
m0nty
Re: Could not register new user.
  • 2005/11/21 21:18

  • m0nty

  • XOOPS is my life!

  • Posts: 3337

  • Since: 2003/10/24


extended profile needs to be installed for registrations to function (i think)

36
EP1988
Re: Could not register new user.
  • 2005/11/21 21:59

  • EP1988

  • Just popping in

  • Posts: 6

  • Since: 2005/11/21


I have XOOPS V. 2.0.13.1

do i have to upgrade?


edit: recommend, to WHAT should I upgrade.

37
MissAntroph
Re: Could not register new user.
  • 2006/3/2 3:32

  • MissAntroph

  • Just popping in

  • Posts: 5

  • Since: 2006/2/6 0


Same Problem here. I someone try to create an account with special characters in the password => Could not register new user.

(special characters like "," , etc. )

38
pablo103
Re: Could not register new user.
  • 2008/12/15 21:02

  • pablo103

  • Not too shy to talk

  • Posts: 181

  • Since: 2008/2/3 1


XOOPS IS A PIECE OF SHIT!

39
sailjapan
Re: Could not register new user.

You're replying to a two and a half year old post and slagging the project with out any explanation as to why. What's your problem?
Never let a man who does not believe something can be done, talk to a man that is doing it.

40
Anonymous
Re: Could not register new user.
  • 2008/12/16 4:22

  • Anonymous

  • Posts: 0

  • Since:


!!!

Login

Username:
Password:

Lost Password? Register now!

Who's Online

74 user(s) are online (47 user(s) are browsing Support Forums)


Members: 0


Guests: 74


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Nov 30
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits