xoops forums

vrreddy

Just popping in
Posted on: 2005/9/15 17:03
vrreddy
vrreddy (Show more)
Just popping in
Posts: 21
Since: 2005/1/29
#1

admin.php giving blank page

Hello all,

i am running XOOPS for the past six months with out any problem. from few days i am unable to go to administration section, if i click on administration menu i am getting blank page. i am able to login and do the updates from the front end but not able to see the admin section. i dont know what went wrong, please help me.
URL: http://www.bioinfo-online.net
thanks in advance
reddy
Posted on: 2005/9/15 17:11
ackbarr
ackbarr (Show more)
Posts: 1449
Since: 2002/10/2
#2

Re: admin.php giving blank page

Step 1. Follow the instructions to enable php debugging on your website (methods 2 or 3)

Step 2. Try to access admin.php again

Step 3. If any error messages are displayed, please respond to this thread with the error messages.
Site Hosting - PlanetXoops

vrreddy

Just popping in
Posted on: 2005/9/16 9:44
vrreddy
vrreddy (Show more)
Just popping in
Posts: 21
Since: 2005/1/29
#3

Re: admin.php giving blank page

Hello ackbarr,
Thanks alot for for your help.
I enabled the debugging, now i got this error.
Parse error: parse error, unexpected T_STRING in /home/bioinfo/public_html/cache/adminmenu.php on line 4

I corrected the problem and now i am able to go to aministration.

Thanks
reddy

erik_do

Just popping in
Posted on: 2006/1/9 14:20
erik_do
erik_do (Show more)
Just popping in
Posts: 5
Since: 2002/9/12
#4

Re: admin.php giving blank page

Hi,

got the same issue. how did you solve it?
Posted on: 2006/1/9 14:27
ackbarr
ackbarr (Show more)
Posts: 1449
Since: 2002/10/2
#5

Re: admin.php giving blank page

simplest solution, delete the /cache/adminmenu.php script from your site then re-enter the Administration Menu. XOOPS will act like this is your first time entering the Administration Menu and regenerate the adminmenu.php script.

While you are deleting the adminmenu.php script, you should also check that permissions are set properly on the /cache folder.
Site Hosting - PlanetXoops

erik_do

Just popping in
Posted on: 2006/1/10 13:52
erik_do
erik_do (Show more)
Just popping in
Posts: 5
Since: 2002/9/12
#6

Re: admin.php giving blank page

got further but got more error messages:

Warning: xoops_cp_header(): Failed opening '/modules/system/cache/adminmenu.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /public_html/include/cp_functions.php on line 26

and it doesn´t recreate the adminmenu file.

the one I removed was located in modules/system/cache/adminmenu.php

maybe its because its an old version of xoops. but it just doesnt recreate adminmenu.
Posted on: 2006/1/10 13:57
ackbarr
ackbarr (Show more)
Posts: 1449
Since: 2002/10/2
#7

Re: admin.php giving blank page

no, more than likely permissions on the /cache folder itself has changed so that the web application can no longer write to that folder.

Try changing the permissions to 777 on *nix/Apache machines or giving IUSR_<SERVERNAME> full control on that directory on a Windows machine. If you are unsure how to do this, check with your hosting provider.
Site Hosting - PlanetXoops

bkohl

Just popping in
Posted on: 2008/3/16 10:21
bkohl
bkohl (Show more)
Just popping in
Posts: 4
Since: 2008/3/16
#8

Re: admin.php giving blank page

ok. I've solve the problem.
i am running XOOPS 2.0.18 with apache2 and php5.

the problem is, that when you modify the settings then the file /cache/adminmenu.php will be deleted and normaly a new one should be created. the second stage doensn't work onmy installation - so the folder /cache is empty (and 0777).

the solution ist to backup before the file adminmenu.php. after you modify the settings and become the blank opage upload the backuped file adminmenu.php and SET THIS FILE ON 0777. now you can go into the administration and you should now update the system module (go on modules/update system module). after that give adminmenu.php normal permission (0644).

I know that this is a really strange procedure evertime when you change someting you should do that - but on my installation it works.

Write if it also works on your installation.

azfaiz

Just popping in
Posted on: 2008/3/23 16:14
azfaiz
azfaiz (Show more)
Just popping in
Posts: 5
Since: 2006/8/15
#9

Blank page in PHP5.0

Hello guys.
Im one of XOOPS clan..Im from Malaysia..

Asking some tips on blank pages in my school site. The urls are:
1. http://skparithajiaman.net/v3/user.php. Once user logged in.
2. In admin.php
3. It also occurred in modules/wmpdownloads but I fixed it already (courtesy from xoops.org forum)

Can anyone out there help me? I already turn on the debug mode. Thank you in advance.

Mamba

Moderator
Posted on: 2008/3/26 4:03
Mamba
Mamba (Show more)
Moderator
Posts: 10988
Since: 2004/4/23
#10

Re: Blank page in PHP5.0

So what is your debug saying? Any error messages?
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs