1
fosterm
Need Help with Browser Inconsistencies
  • 2009/3/30 19:57

  • fosterm

  • Just popping in

  • Posts: 93

  • Since: 2005/8/7 2


Hiya

I wasn't for sure where to ask this question...please move it if it is in the wrong area.

I am running 2.3.1 and for some time now I have had visual discrepancies when using the latest Firefox.

If you look at my site www.montgomerycountymonitor.com with Internet Explorer, you will see how I want the site to look.

Viewing the site with Firefox, causes some issues.

For example on the front page the forums block as well as other blocks, are all left justified when viewed using Foxfire.

Also, some of the blocks, when viewed in Firefox have bullets to the left of the text. These bullets are not visible when viewed with Internet Explorer.

My visitors at this point breakdown as follows 80% use internet explorer, 10% use Firefox and the additional 10% is spread among various others browsers.

I have tried many times over the last year to attempt to address this issue, but have been unable to successfully rectify the differences between the two browsers.

Does anyone have any suggestions or is anyone willing to fix the issue for payment?


Thanks

Foz

2
ghia
Re: Need Help with Browser Inconsistencies
  • 2009/3/31 1:03

  • ghia

  • Community Support Member

  • Posts: 4953

  • Since: 2008/7/3 1


For the blocks remove the
#centercolumn .blockContent, .xo-blockcontent {
    
display:    inline-block;
}


The bullets are stated in your default html.css of FF3 and contain a
ul  { list-style-typedisc; }
Add a
ul  { list-style-typenone; }
to your theme.css to make them disappear.

3
fosterm
Re: Need Help with Browser Inconsistencies
  • 2009/3/31 19:13

  • fosterm

  • Just popping in

  • Posts: 93

  • Since: 2005/8/7 2


Hi ghia

With your help and after tinkering around a bit in my css I figured out how to disable the bullets (yay - thank you very much).

I had a difficult time making the blocks present properly. I could not find Quote:
#centercolumn .blockContent, .xo-blockcontent {
display: inline-block;


in my css file.

I downloaded the add-on called firebug and tinkered around with my site a bit.

While tinkering with the blocks, firebug indicated the some aspects of the blocks were controlled by the file xoop.css.

I did not realize there was a xoops.css (located in the root directory).

Inside xoop.css I found the code you mentioned and removed it as you suggested.

That fixed the block issues.

Thanks for all your help ghia. This issue had me perplexed for many months.

Thanks to you I was able to resolve it.

Foz

Login

Username:
Password:

Lost Password? Register now!

Who's Online

80 user(s) are online (49 user(s) are browsing Support Forums)


Members: 0


Guests: 80


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Jun 30
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits