xoops forums

Forum Index


Board index » All Posts (beach_defend)




beach_defend

Just popping in
Posted on: 2006/10/30 12:25
beach_defend
beach_defend (Show more)
Just popping in
Posts: 29
Since: 2004/12/8
#1

Re: Blocks Admin

Thanks for clearing it up for me.

I'll get around it another way, I guess.

I might look to see how it works in 2.2 as well.

Again, thanks.


beach_defend

Just popping in
Posted on: 2006/10/30 10:03
beach_defend
beach_defend (Show more)
Just popping in
Posts: 29
Since: 2004/12/8
#2

Re: Blocks Admin

But I may want the User Menu available to other users on a different page.

What I still don't understand why when I set visibility on 'top page' for one group, it sets it for all groups.

This seems to be strange, or there is no reason to select the user group at the top, if visibility is set across all user groups.

Am I missing something?

Thanks again for your help.


beach_defend

Just popping in
Posted on: 2006/10/30 6:57
beach_defend
beach_defend (Show more)
Just popping in
Posts: 29
Since: 2004/12/8
#3

Re: Blocks Admin

Another, simple example is that I want thw Logon block on the top page for anonymous users but not for people who have logged in, because that would be silly.


beach_defend

Just popping in
Posted on: 2006/10/30 6:31
beach_defend
beach_defend (Show more)
Just popping in
Posts: 29
Since: 2004/12/8
#4

Blocks Admin

Hi,
I'm sure this has been covered, but I cant find a reference to my issue.

I'm using 2.0.15 on a site and have been trying to get it setup.

I want some blocks to show on the 'Top Page' depending opn the group one belongs to.

So, I go the Blocks CPanel and set the permissions as follows

Page: Top Page Group: Anonymous User Visible: All

Main Menu => Visible = No
User Menu => Visible = No

Submitting this gives the right result.

So, now I do:

Page: Top Page Group: Registered Users Visible: All

Main Menu => Visible = Yes
User Menu => Visible = No

Submit -

Gives the last result for BOTH Anonymous Users and Registered Users.

If I change the Anon folk back, it changes back for Registered users.

To me this is a bug.

BTW - I have set group access corectly, because on some pages the blockd that are not visible on the top page may in fact be visible.

This is causing me great grief at present, in fact due to time pressures I'm going to try the same on 2.2

Thanks in advance,
Barry


beach_defend

Just popping in
Posted on: 2006/10/22 23:44
beach_defend
beach_defend (Show more)
Just popping in
Posts: 29
Since: 2004/12/8
#5

Re: help wanted for eguide

Hi,
I've just started using eguide, so I'm not much use at the present for youe issue, but will be working with over the next few months, so hopefully we can collaboate a litle.

I am trying to work out how to have eguide use a wysiwyg editor for registering events.


beach_defend

Just popping in
Posted on: 2006/1/3 6:51
beach_defend
beach_defend (Show more)
Just popping in
Posts: 29
Since: 2004/12/8
#6

Using Xoops Smarty Interface

I have a number of applications, alol developed using PEAR::HTML_QuickForm, HTML_QuickForm_Controller, DB_DataObjects and Smarty Templates etc.

I have replaced our authentication/authorisation with the XOOPS equivalent so that one of these apps now works as a XOOPS Module.

I am about to look through the XOOPS API Documentation but would appreciate any pointers to a detailed, explanation of the woirking of Themes and templates.

I am not considering a change to the fundamental application framework we have but will be happy to publish any progress if there is any interest.


beach_defend

Just popping in
Posted on: 2005/12/9 12:42
beach_defend
beach_defend (Show more)
Just popping in
Posts: 29
Since: 2004/12/8
#7

Re: Upgrade 2.0.X => 2.2.3

It seems that most of the issues seem to relate to extended profiles.

Now I seem to be able to have most of the site work in Firefox, but in IE I either get a whie page of death (I have selected PHP Debug as well as added ini_set('display_errors',1) and error_reporting(E_ALL) which still gave a WPOD. I even updated php.ini in depsaration to set display_errors = 1, and STILL get a WPOD.

So I've now got an inoperable company site and not sure what to try next.

I'm really desparate and don't to rebuild the site from scratch.

.... and I need some sleep.....


beach_defend

Just popping in
Posted on: 2005/12/7 13:16
beach_defend
beach_defend (Show more)
Just popping in
Posts: 29
Since: 2004/12/8
#8

Upgrade 2.0.X => 2.2.3

I've applied the upgrade script to a Xoops2.0 site to upgrade to 2.2.3.

After some initial issues I have the site up. I can log in, but when I go to the administration forms, it says that we have no users, even though I've logged in as root!

I get the following error:
Fatal error: Call to a member function on a non-object in /www/<path>/html/class/theme.php on line 499


If I'm using IE, the page flickers, tries to reload heaps of and then finally brings up a broken, half page.

In Firefox it is Ok but as I said I cant actually get to any privileged areas outside of the admin system.

I am going to look at the code now but would really appreciate any thoughts, help etc.

Having looked into it a bit more, it seems that there must be an issue with the authentication.

adding
echo "Echo in theme.php Line 496:<br><pre>";var_dump($GLOBALS['xoopsUser']);echo "</pre>";

outputs
object(xoopsuser)(11) {
["vars"]=>
array(9) {
["uid"]=>
array(6) {
["value"]=>
NULL
["required"]=>
bool(false)
["data_type"]=>
int(3)
["maxlength"]=>
NULL
["changed"]=>
bool(false)
["options"]=>
string(0) ""
}
["loginname"]=>
array(6) {
["value"]=>
NULL
["required"]=>
bool(true)
["data_type"]=>
int(1)
["maxlength"]=>
int(25)
["changed"]=>
bool(false)
["options"]=>
string(0) ""
}
["uname"]=>
array(6) {
["value"]=>
NULL
["required"]=>
bool(true)
["data_type"]=>
int(1)
["maxlength"]=>
int(55)
["changed"]=>
bool(false)
["options"]=>
string(0) ""
.
.
.
etc

I am about to look at the authentication

I am currently running php4.3.5


beach_defend

Just popping in
Posted on: 2005/12/7 13:11
beach_defend
beach_defend (Show more)
Just popping in
Posts: 29
Since: 2004/12/8
#9

Re: Update 2.0.13.1 to 2.2.3 Final - Stuck on Closed For Maintenance Screen

I am geeting other problems do I'll move onto another topic.
Will return here if I find out what is happening.

I should note here that I can access the site in Firefox but IE gets serious load errrors that seem to be Javascript related. Hard to describe, but it looks like a recursive reload of the page for a long time and then ulitmately half a page and some exposed html tags.

I'll start aonther thread...


beach_defend

Just popping in
Posted on: 2005/12/7 11:55
beach_defend
beach_defend (Show more)
Just popping in
Posts: 29
Since: 2004/12/8
#10

Re: Update 2.0.13.1 to 2.2.3 Final - Stuck on Closed For Maintenance Screen

Hi again,
I added
ini_set('display_errors','1');
error_reporting(E_ALL);

and get


Fatal error: main(): Failed opening required '....../class/smarty/core/core.load_plugins.php' (include_path='.:/www/includes:/www/includes/phpreports:/usr/local/php/includes:/usr/share/pear') in /www/html/xoops-2.0.7.3/html/templates_c/db%3Aprofile_admin_fieldlist.html on line 3

So I uploaded the new Smarty directory contents and it seems to have worked, though there are some permission issues with wiwmod.

I'll go back now and try to figure out what to do next.



TopTop
(1) 2 3 »