1
zakharov
Mediawiki 1.67 - Upgrading the version of Mediawiki
  • 2008/4/5 23:54

  • zakharov

  • Just popping in

  • Posts: 12

  • Since: 2004/7/10


Hello fellow Xoopsters!

Unfortunately, the version of PHP is limited on my server, so the best version of Mediawiki I can use is 1.6.10. When I installed the Mediawiki Module @ 1.67, I found that the version of Mediawiki installed was, well, 1.6.7.

I was wondering if you had any advice on what I could do to update that to version 1.6.10. I tried following the directions on the Mediawiki site on how to do a proper upgrade, but I received errors regarding DefaultSettings.php and SiteConfiguration.php in the \includes\ folder of the module.

Any advice?



2
zakharov
Re: Problem with ArMS 4.0 - Can't get articles to display in proper order
  • 2005/3/22 23:01

  • zakharov

  • Just popping in

  • Posts: 12

  • Since: 2004/7/10


A couple hours of sleep has led me to find that it is rather as simple of replacing "DESC" with "ASC". The question is, which one? I've pinned it down to filter.php, functions_general.php, search.php and view.php. Before I go on a tweak-fest, anyone have any idea where I should begin?



3
zakharov
Problem with ArMS 4.0 - Can't get articles to display in proper order
  • 2005/3/22 17:04

  • zakharov

  • Just popping in

  • Posts: 12

  • Since: 2004/7/10


Hey everyone, Zak here.

My site (http://www.transversegames.com - use user: test-accounts pw: tests if you wish you sign in, though you don't need to) is a pet project of mine and several very close friends. We've all worked or have had a lot if interest in the gaming industry and the site is the home of the fruit of our labors on this side project we've been working on for several years.

The main problem I'm having is that we are using ArMS as part of our "two pronged delivery" method on the site. The first of which is to download the "books" in PDF format, the second is to have a constantly updated version online using ArMS. This way if we screw up, we can correct it. If people want to share their thoughts and opinions, they can. Then when the next time comes along, we take all the text in ArMS, get everything and set up, and viola, new PDF document.

The problem is, ArMS displays the articles based on post date, meaning that once an author finishes a chapter in their book and goes to start another, the second would appear over the first one, when it should be the other way around.

I've loaded the ArMS directory into Dreamweaver and did a search for "sort by date asc" or whatever the string is (I'm tired) and I couldn't find anything, even with several variations. The only thing I can seem to link it too is "arms_loop" and "$arms_articals" in view.php.

Is there anyway I can get ArMS to display the other way around, with newer posts on the bottom?



4
zakharov
Re: Spotlight not showing entire "The Scoop"
  • 2004/9/20 8:57

  • zakharov

  • Just popping in

  • Posts: 12

  • Since: 2004/7/10


Anyone?



5
zakharov
Spotlight not showing entire "The Scoop"
  • 2004/7/20 17:44

  • zakharov

  • Just popping in

  • Posts: 12

  • Since: 2004/7/10


hhttp://www.transversegames.com

acct: test_account
pw: test1

What I would like to have, and I've been trying to figure out how to get it, is to have the Spotlight module show the entire "The Scoop" of a news post, but instead, it cuts it off. In fact, if possible, I would like to go without having to use the "extended text" part of the news with Spotlight (Ver 2).

Any ideas on how to fix it?



6
zakharov
Re: Problem with Istats\Web Stats 2.1
  • 2004/7/11 18:30

  • zakharov

  • Just popping in

  • Posts: 12

  • Since: 2004/7/10


I've made some changes and have some progress...

Now it's updating, but it's only per IP. The numbers keep updating between my laptop and PC (behind a router)

Total Pages: 9
Total Visits: 9
Total Days: 1
Average Visits per day: 9.00
Average Visits per hour: 0.38
Average Visits per week: 63.00
Average Visits per month: 270.00
Busiest Date: 11-07-2004
Busiest Day Visits: 9
Visitors Today: 9
Visitors this week: 9
Visitors this month: 9
Busiest Week: #28 2004
Busiest Week Visits: 9
Busiest Month: 07/2004
Busiest Month Visits: 9

to

Total Pages: 10
Total Visits: 10
Total Days: 1
Average Visits per day: 10.00
Average Visits per hour: 0.42
Average Visits per week: 70.00
Average Visits per month: 300.00
Busiest Date: 11-07-2004
Busiest Day Visits: 10
Visitors Today: 10
Visitors this week: 10
Visitors this month: 10
Busiest Week: #28 2004
Busiest Week Visits: 10
Busiest Month: 07/2004
Busiest Month Visits: 10

But my buddy (on a different IP and OS) gets a different one (lower). To test this, he got his to be equal to mine + 1, and I increased it by one to see if it would increment like it should, no luck.

Hmm...



7
zakharov
Re: Problem with Istats\Web Stats 2.1
  • 2004/7/11 17:55

  • zakharov

  • Just popping in

  • Posts: 12

  • Since: 2004/7/10


Woopsie, my bad. Thanks!

I'll try that now.



8
zakharov
Problem with Istats\Web Stats 2.1
  • 2004/7/11 15:10

  • zakharov

  • Just popping in

  • Posts: 12

  • Since: 2004/7/10


hhttp://www.transversegames.com

acct: test_account
pw: test1

The Istats block worked... or so I thought. I finally figured out what I had wrong and fixed it, but now it won't update past "1". Any ideas?



9
zakharov
Re: Unable to uninstall module
  • 2004/7/10 9:36

  • zakharov

  • Just popping in

  • Posts: 12

  • Since: 2004/7/10


No go. Same blank page.

Quote:

Mithrandir wrote:
try manually going to
http://www.---.com/modules/system/admin.php?fct=modulesadmin&op=uninstall&module=dirname

where "dirname" of course responds to the directory name of the misbehaving module.



10
zakharov
Re: Unable to uninstall module
  • 2004/7/10 8:47

  • zakharov

  • Just popping in

  • Posts: 12

  • Since: 2004/7/10


I get a blank page.

http://www.---.com/modules/system/admin.php?fct=modulesadmin&op=uninstall&module=

http://www.---.com/modules/system/admin.php?fct=modulesadmin&op=uninstall&module=xoopsheadlines

See the difference between the two links though? That's all I can really provide since the PHP debug brings up nothin'.

-Zak SawyerQuote:


Mithrandir wrote:
Can you turn on php debug in system admin -> preferences -> general settings and try uninstall it again and report error messages here?




TopTop
(1) 2 »



Login

Who's Online

237 user(s) are online (199 user(s) are browsing Support Forums)


Members: 0


Guests: 237


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Jun 30
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits