XOOPS

XOOPS 2.5.11 RC-3 available for Testing

Mamba  11-Nov-2023 06:30 11480 Reads   18 Comment(s) 
2.5.11 RC3
The XOOPS Development Team is pleased to announce the release of XOOPS 2.5.11-RC3.

NEW in XOOPS 2.5.11: Support for Smarty 3.x

Please help make XOOPS better by testing and reporting any issues!

The XOOPS Development Team is pleased to announce the release of XOOPS 2.5.11-RC3.

NEW in XOOPS 2.5.11:
- Support for Smarty 3.x
- new functionality in Upgrade, helping to convert Smarty 2 templates to Smarty 3
- default value for notification method for new users
- adjustments for PHP 8

NEW in XMF 1.2.28:
- ULID format

Please help make XOOPS better by testing and reporting any issues!

This is a release candidate intended for testing only. Use in a production system is not without risks.

The feature set is complete and is now fixed for 2.5.11. Only bug fixes will be accepted.

Please download from the current master!
If you are downloading this release for testing, please download from the current master instead.

Any bugs that have been found and fixed will be included in your testing that way, so we all won't keep finding and reporting the same bug over and over.

You can grab the current master here: https://github.com/XOOPS/XoopsCore25/archive/master.zip

Full Changelog: v2.5.11-RC2...v2.5.11-RC3
Rating 5.00/5
Rating: 5.0/5 (1 vote)
Voting is disabled!
user

 Re: XOOPS 2.5.11 RC-3 available for Testing


Glad to see XOOPS is going forward. Implementing bootstrap is great, the system core is getting stronger with all the new updates. Reading stuff online, seeing how good is built the core, I am wondering, if could be implemented some using js framework, like event driven capabilities with vue, or other js framework. Using content the old way, but using an "event driven system" (for a messaging system, or cart, or chat, or booking, or what ever is appropriate ...), could be a boost of developers attention. Somehow, using modules (for what template to use, with or without vue syntax) or system preferences (for node.js event URL setting), some modules would be more interesting, the system would be very attractive for some professional approaches. That being said, I experienced some wordpress approach, trying to help some friends. Is a nightmare. Glad to meet XOOPS and read some code of it. Trying to see a way to become more event driven, though.

 
user

 Re: XOOPS 2.5.11 RC-3 available for Testing


MI PIACE! Lucio

 
user

 Re: XOOPS 2.5.11 RC-3 available for Testing


Hi Blindman,

Some people were already using Vue.js in XOOPS Modules, like the Equipment module

There are definitely many opportunities for improvement in the Core, as well as XMF, but it would be up to the Core Team, and the people who would like to help and be involved.

Right now the focus is on XOOPS 2.5.11 Final with Smarty 3.

Next version, potentially called 2.7.0, will focus on adding Smarty 4/5, and making it fully compatible with PHP 8.3. The minimum supported PHP version will be PHP 8.1, which will enable us to take advantage of all the new features, and cleanup the legacy code, adding namespaces, enforce strict typing. and add full use of Composer.

The main goal is still to merge the current version of XOOPS with the XOOPS version called 2.6.0 that is lurking there, and which has already many of the modern features that should be in XOOPS. My guess is that once we have XOOPS 2.7.0 released, we'll try to merge it with the XOOPS 2.6.0 into a new XOOPS 4.0, but it will be up to the Core Team, as I'm just helping out!

 
user

 Re: XOOPS 2.5.11 RC-3 available for Testing


I entered the term TAG in the search field and this error came up (both on xoops.org and on my test site www.audizioni.it/audizioni/): Error : RuntimeException: Query Failed! SQL: SELECT * FROM `wfdownloads_downloads` WHERE (`cid` IN () AND ((`title` LIKE '%tag%' OR `description` LIKE '%tag%')) AND (`published` > '0' AND `published` = '1700582159') AND `cid` IN ())) ORDER BY published DESC - Error: You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near ') AND ((`title` LIKE '%tag%' OR `description` LIKE '%tag%')) AND (`published`...' at line 1

 
user

 Re: XOOPS 2.5.11 RC-3 available for Testing


Hi audizioni,

Thanks for the report.

Please respond to my question in the Forum

 
user

 Re: XOOPS 2.5.11 RC-3 available for Testing


RC-3 theme Write php $xoopsTpl->assign() No effect? My theme.tpl

{php}
    
global $xoTheme$xoopsTpl;
    
$xoTheme->addScript("browse.php?Frameworks/jquery/jquery.js", array( 'type' => 'text/javascript'));
    
$xoTheme->addScript("js/bootstrap.bundle.min.js", array( 'type' => 'text/javascript'));
    
$xoopsTpl->assign('xoops_module_header'$xoTheme->renderMetas('script'true));
{/php}
Can't add script on $xoops_module_header~ Can u help me.

 
user

 Re: XOOPS 2.5.11 RC-3 available for Testing


I finished the question

{php}
    
global $xoTheme;
    
$xoTheme->addScript('browse.php?Frameworks/jquery/jquery.js', array( 'type' => 'text/javascript'));
    
$xoTheme->addScript('js/bootstrap.bundle.min.js', array( 'type' => 'text/javascript'));
    
$_smarty_tpl->assign('xoops_module_header'$xoTheme->renderMetas('script'true),false);
{/php}

 
user

 Re: XOOPS 2.5.11 RC-3 available for Testing


Hi., I have a site with 500 error, probably because the host changed to PHP 8.2 (can also use 8.1 atm). Will this version work?

 
user

 Re: XOOPS 2.5.11 RC-3 available for Testing


Im work in php8.2,used XOOPS 2.5.11 RC-3

 
user

 Re: XOOPS 2.5.11 RC-3 available for Testing


New install php 8.1 internal 500 error, nothing in the logs page display only A problem has occurred on our server! Page is currently unavailable We are working on a fix Please come back soon ... Error : SmartyException: Unable to load template 'db:system_homepage.tpl' reinstall again and now : Error : TypeError: fwrite(): Argument #1 ($stream) must be of type resource, bool given

 
user

 Re: XOOPS 2.5.11 RC-3 available for Testing


I had some smarty errors uncatched by Apache logs, but I got rid of them by replacing --->>>> html comments - >> with smarty type html comments ---> inside theme's templates, frontEnd theme and the backEnd theme. I tried to put the code here , but ... I could't. Not realy understand why, but I got rid of errors after this replacement (on WAMP, PHP 8.2).

 
user

 Re: XOOPS 2.5.11 RC-3 available for Testing


Also, I had to replace includeq with include into templates files, in order to work. Just telling you what I did to make it work on my WAMP - php 8.2 instalation.

 
user

 Re: XOOPS 2.5.11 RC-3 available for Testing


Installation problem is solved by installing RC2 and upgrading to RC3 and it works now but there is now an problem with uploading images via image manager , get error about missing filename. RC3 is very buggy

 
user

 Re: XOOPS 2.5.11 RC-3 available for Testing


Trying to install with php.8.1. I get internal server error : Error : TypeError: fwrite(): Argument #1 ($stream) must be of type resource, bool given on: /install/page_tablesfill.php

 
user

 Re: XOOPS 2.5.11 RC-3 available for Testing


More errors here with template : Error : SmartyCompilerException: Syntax error in template "db:db:qpagescategos.html" on line 12 " " - Unexpected "<"

 
user

 Re: XOOPS 2.5.11 RC-3 available for Testing


Thank you all for testing! We've made some updates, so please rerun the tests with the latest code:https://github.com/XOOPS/XoopsCore25/archive/master.zip

 
user

 Re: XOOPS 2.5.11 RC-3 available for Testing


Hi mamba , want to share what the changes were ?

 
user

 Re: XOOPS 2.5.11 RC-3 available for Testing


Hi Yurdal,

1) the multi-image upload should be fixed now

2) we also fixed the issues with email templates in Notifications, reported by Alain

3) With errors like the one you've mentioned: Unexpected "<", check your template that it conforms to Smarty 3

Hi Cadch,

You will not be able to use PHP tags in Smarty in the future:

{php}> <{/php}


Hi Runeher,

1) currently PHP 8.2 is not officially supported, this is because it is not officially supported by Smarty 3

2) Once we release XOOPS 2.5.11 with Smarty 3, we plan to release soon after a new version of XOOPS that will have PHP 8.1 as a minimum supported, and will have Smarty 4

The biggest problem will be with older modules that will simply crash on PHP 8.2.

Hi Blindman,
1) you can try to post a screenshot of your code, in case XOOPS refuses to post the code. You can also try to post the code on GitHub (I hope, you have an account there)

2) The Upgrader's "preflight.php" should replace all "includeq" with "include" in templates. You can always re-run it.

 


Login

Who's Online

214 user(s) are online (1 user(s) are browsing Publisher)


Members: 1


Guests: 213


Johndavid,

more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Feb 29
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits

Categories