1
shalommemphi
Login Problems

I have noticed on one of my sites a problem logging into the site.

I login and even get the (Thank You For Logging In) but when the page reloads I am NOT LOGGED IN.

Here is the strange problem. If I use the normal CORE LOGIN box it works fine. But when I use the login box on my THEME (Dreamy) it doesn't work. IT USE TO WORK FINE.

I have checked my sessions db, cleared, dropped it, checked it until it showed OKAY. Still does not work.

Anyone else have this problem??
Helping each other with Knowledge

2
kerkyra
Re: Login Problems
  • 2008/2/16 21:44

  • kerkyra

  • Just can't stay away

  • Posts: 553

  • Since: 2005/2/14


hallo there, i just installed the new version of xoops, 2.0.18 rc1. I get the same prob in IE AND firefox. Custom session is off, but yet when i log in, it shows a session number on the url (redirects me to
www.myurl.com/Index.php?&PHPSESSID=blablabla
)with capital I...
, shows the welcome message, but then i cant go in the administration area (because when i click on the link,it tries to get me there without adding the session in the url)!No access! I must say that i dont have this problem when using latin character sets!! When i use utf language files this happens although everything else is fine! I remember this since 2.0.15 is somebody going to tell us what is going on with this error or fix it for good? It gets quite annoying!

Use custom session is of
repairing the db is not working and even if it did, this is not how this problem can or should be solved

i notice here the character encoding is utf-8, why are the language files of the installation package in latin?
is there a utf-8 package of XOOPS we could download directly?
how is it possible to login to some and not loggin in to others???
www.guidemap.gr - Beta is out...

3
kerkyra
Re: Login Problems
  • 2008/2/17 12:49

  • kerkyra

  • Just can't stay away

  • Posts: 553

  • Since: 2005/2/14


anyone?
www.guidemap.gr - Beta is out...

4
Gringo
Re: Login Problems
  • 2008/2/29 13:26

  • Gringo

  • Just popping in

  • Posts: 12

  • Since: 2006/1/23


Does anyone have any help on this topic at all?

5
hiflyer
Re: Login Problems
  • 2008/3/9 17:24

  • hiflyer

  • Not too shy to talk

  • Posts: 107

  • Since: 2006/3/7 3


Oh yay. I upgraded from 2.0.17 to 2.0.18.1 and now the issue is back on one site (other sites are fine).
Same result on multiple computers/users with IE7, Firefox 2, Safari & Blazer (Palm Treo browser).
Tried the following with no affect:
kernel/session.php regenerate = false
clearing cookies
repair/optimize session db table
custom session - off

Help!

6
mubarak
Re: Login Problems
  • 2008/3/9 18:57

  • mubarak

  • Just popping in

  • Posts: 3

  • Since: 2008/3/9 1


Hi guys,

for me is a problem introduced with 2.0.18.1:

file kernel/session.php line 78:

2.0.18
var $enableRegenerateId = true;

2.0.18.1
var $enableRegenerateId = false;


I had problems with login with personal sessions.
I have put true the var $enableRegenerateId in the kernel/session.php and everything seems to work fine.

I don't know if they set it to false for something else.

Is it so or is it a simple forgot?

If you don't need personal session also setting my_session to 0 in the xoops_config table in the use_mysession field can work.

Hope it help.

ciao

7
mubarak
Re: Login Problems
  • 2008/3/9 19:30

  • mubarak

  • Just popping in

  • Posts: 3

  • Since: 2008/3/9 1


Sorry, I just read now the change log 2.0.18.1:

Improved: Turned enableRegenerateId off in XOOPS session to avoid problems with IEs (phppp)

It avoid some problems but it seems it generates other problems ... i think best thing now is don't use personal session.

Ciao

8
hiflyer
Re: Login Problems
  • 2008/3/10 13:56

  • hiflyer

  • Not too shy to talk

  • Posts: 107

  • Since: 2006/3/7 3


mubarak -

Thanks - it works!
The old fix was to change kernel/session.php to regenerate = false but apparently that now creates the bug in 2.0.18.1...!
Set it to true and now it's working fine (even in IE)!
(But my 4 other 2.0.18.1 sites work fine with no change to that file/switch...)
That should keep phppp up at night for a while. I might try mirroring the trouble site and upgrading to 2.3.0a and see what happens.

9
kerkyra
Re: Login Problems
  • 2008/3/17 8:21

  • kerkyra

  • Just can't stay away

  • Posts: 553

  • Since: 2005/2/14


and what about the charset! what this have to do with anything like that? When I use utf the problem apears! when latin is used the problem is gone!!! how can this be explained?
www.guidemap.gr - Beta is out...

10
benCorpo
Re: Login Problems
  • 2008/3/19 13:56

  • benCorpo

  • Just popping in

  • Posts: 17

  • Since: 2006/2/5 2


Found the problem and I have a solution.

This line (line #262) in include/common.php is emptying the user info:
// Remove expired session for xoopsUserId
if ( $xoopsConfig['use_mysession'] && $xoopsConfig['session_name'] != '' && !isset($_COOKIE[$xoopsConfig['session_name']]) && !empty($_SESSION['xoopsUserId']) ) {
unset( $_SESSION['xoopsUserId'] );
}

For some reason, right after the login, I suspect the cookie to contain the wrong info, thus preventing anyone from login anymore.

I commented out the line #263 (the unset()) and everything is back to normal!

Hope this is useful.
Ben

Login

Who's Online

65 user(s) are online (45 user(s) are browsing Support Forums)


Members: 0


Guests: 65


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Jul 31
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits