xoops forums

Catzwolf

Home away from home
Posted on: 2007/11/1 1:09
Catzwolf
Catzwolf (Show more)
Home away from home
Posts: 1392
Since: 2007/9/30
#11

Re: Which modules are php5 compatible?

Shine, I totally love the fact that you are trying to bring this subject to the forefront and to the attention of developers and the community alike, but it is apparent that due to the ever increasing fragmentation of this community, you plight maybe falling on deaf ears as it seems another topic ragarding module development was totally ignored by the people I thought it would have interested most, the developers but I guess I was wrong.

I just hope that someone realises the importance of this issue and starts to address it correctly.

But I wish you well though.

Shine

Just can't stay away
Posted on: 2007/11/1 8:14
Shine
Shine (Show more)
Just can't stay away
Posts: 822
Since: 2002/7/22
#12

Re: Which modules are php5 compatible?

Thanks Catz.
Deaf ears....hmz.....

I did a search on XOOPS org...

https://xoops.org/modules/newbb/viewto ... hp?topic_id=61481&forum=1 (regarding php5)
https://xoops.org/modules/newbb/viewto ... p?topic_id=61472&forum=28 (Blank page in smartfaq 1.08 running on PHP 5)
https://xoops.org/modules/newbb/viewto ... id=274328#forumpost274328 (PHP 5 and Top page)
https://xoops.org/modules/newbb/viewto ... id=274043#forumpost274043 (xyp4all and php5?)
https://xoops.org/modules/newbb/viewto ... id=272506#forumpost272506 (xRoster and php5)
https://xoops.org/modules/newbb/viewto ... id=272382#forumpost272382 (Weblinks module php5?)
https://xoops.org/modules/newbb/viewto ... id=273243#forumpost273243 (Poll module not working)
https://xoops.org/modules/newbb/viewto ... id=271813#forumpost271813 (Php5?)
https://xoops.org/modules/newbb/viewto ... id=269048#forumpost269048 (xDonations with PHP 5)
https://xoops.org/modules/newbb/viewto ... e=flat&order=ASC&start=60 (php4-5 subject matter enhanced/Moving to Php5 - XOOPS Compatibility - Garrath's List - Testing.)
https://xoops.org/modules/newbb/viewto ... id=266117#forumpost266117
https://xoops.org/modules/news/article.php?storyid=3602 (Questionnaire regarding Supporting PHP5 and MySQL5)(Migrating to PHP5)
https://xoops.org/modules/newbb/viewto ... id=257839#forumpost257839 (Very few modules working - WHAT is wrong?!?!?)
https://xoops.org/modules/newbb/viewto ... id=253908#forumpost253908 (xAsseT & PHP5 Issue)
https://xoops.org/modules/newbb/viewto ... id=253680#forumpost253680 (xlanguage and php 5.2)
https://xoops.org/modules/newbb/viewto ... id=252089#forumpost252089 (mysql5 and php5)
https://xoops.org/modules/news/article.php?storyid=3728 (PHP5 and MYSQL5 Questionnaire results) and http://xoobs.net/modules/news/article.php?storyid=39

This is just a small inventory of php5 questions regarding modules compatibility questions.
So,........how many new threads need to start again to get a clear inventory.....

Also the same question on xoopsaddons: http://xoopsinfo.com/modules/newbb/vi ... php?topic_id=416&forum=33

Again..... BUMP

Shine

Just can't stay away
Posted on: 2007/11/4 13:39
Shine
Shine (Show more)
Just can't stay away
Posts: 822
Since: 2002/7/22
#13

Re: Which modules are php5 compatible?

Bump

Peekay

XOOPS is my life!
Posted on: 2007/11/4 15:30
Peekay
Peekay (Show more)
XOOPS is my life!
Posts: 2335
Since: 2004/11/20
#14

Re: Which modules are php5 compatible?

Lack of system requirements in the repository has been my favourite whinge for literally years. I am very dissapointed that neither Xoops.org or the new add-ons site have really addressed the issue. As more commercial web hosts upgrade PHP next year, the chance of finding a module that works will be even harder.

The lack of an attribute search feature in the downloads software makes finding PHP 5 compatible modules impossible even when the developer has been gracious enough to provide a proper spec.

If it's of any help, following my post in March 2005 there are some PHP 5 compatible modules listed at the end of the thread. Also, I recall the user artigas tested quite a few modules and posted the results, but it would take some digging to compile a definitive list.

I always believed there should be two top-level categories in the module repository - 'Supported' and 'Un-supported'. To get your module listed in the supported category the dev has to provide a full spec. No spec?... then your module goes in the unsupported category with all the old, dodgy modules.

It'll never happen.
A thread is for life. Not just for Christmas.

Anonymous

Posted on: 2007/11/4 16:01
Anonymous
Anonymous (Show more)
Posts: 0
Since:
#15

Re: Which modules are php5 compatible?

I run XOOPS 2.0.17.1 with:

PHP 5.2.3
Server type: Apache
Perl version: 5.8.5 (patched)
MySQL version: 4.1.20 (patched)
Register Globals: "Off"

and can confirm that the following modules work fine for me:

eXtCal 2.0.4
xyp4all 1.58RC
News 1.56
CBB 3.08 (with Frameworks 1.10 and xoopseditors 1.10)
wflinks 1.03b
Smartsection 2.13
istats 2.2
wiwimod 0.8.3 (fully functional, wasn't so in PHP 4.4.7)
Protector 3.04
xcgallery 2.0.3
xoopspoll 1.1
weather 1.3

HTH

kaotik

Just can't stay away
Posted on: 2007/11/4 16:11
kaotik
kaotik (Show more)
Just can't stay away
Posts: 861
Since: 2004/2/19
#16

Re: Which modules are php5 compatible?

Marco did some excellent work regarding this a couple of years back. He came up with an excel table that module developers would fill out and it would automatically judge the module by determining which items were mandatory, which were optional and how the module was classified.
I would highly recommend reviving this work since it it's very well done. If anyone is interested I could provide the excel file, I'm not sure if the version I have is current however.

Marco

Home away from home
Posted on: 2007/11/4 16:17
Marco
Marco (Show more)
Home away from home
Posts: 1256
Since: 2004/3/15
#17

Re: Which modules are php5 compatible?

check my website, the file is still accurate !
Do synergy or die.

kaotik

Just can't stay away
Posted on: 2007/11/4 16:32
kaotik
kaotik (Show more)
Just can't stay away
Posts: 861
Since: 2004/2/19
#18

Re: Which modules are php5 compatible?

I see my version is current
Nice job Marco. Now if only the majority of module developers were to use it, users would really benefit from the standards it creates.

Catzwolf

Home away from home
Posted on: 2007/11/11 22:57
Catzwolf
Catzwolf (Show more)
Home away from home
Posts: 1392
Since: 2007/9/30
#19

Re: Which modules are php5 compatible?

The problem is that we don't have many module developers left anymore since people here tend to forget HOW IMPORTANT THEY ARE to Xoops.

No one seems to be addressing this issue in a proper manner, i.e. documentation that developers could rely on for:
1. Compatability with new core,
2. Compatablitiy with newer versions of PHP5 or Mysql.

I personally think that DJ is waiting to see if someone else will pick this up and create a module development team or address this issue in another way, well I was going to do it, but I am not now. DJ whether you like it or not it is your responsibility to provide the tools required to the developer Community.

Haven't you noticed people asking and asking over and over again for this to be sorted out? Or you still going to think that it is up to the community to fix it?