Zero Sized Reply

..I read the zero sized reply problem thread..but i still do not know the solution..

My site is working fine except for the weblog 1.46 module..which gives me following

The following error was encountered:

* Zero Sized Reply

-- the site is working fine in XAMPP on my laptop..this problem is with the site on the server..

what could be the problem here ?


Re: Zero Sized Reply
  • 2006/11/11 16:55

  • Bender

  • Home away from home

  • Posts: 1899

  • Since: 2003/3/10

Do you run squid on your server?

(if it is your server can you test without squid?)

Google for this problem and you will find a lot of issues but no general solution. There seems to be no fix all causes thing for this problem.
Sorry, this signature is experiencing technical difficulties. We will return you to the sheduled signature as soon as possible ...

Re: Zero Sized Reply
  • 2006/11/11 17:28

  • m0nty

  • XOOPS is my life!

  • Posts: 3337

  • Since: 2003/10/24

i get that problem everytime i try to view profiles or use the search on xoops.org when i'm logged in.

a few others experience the same problem, but we're in the minority. we don't understand why and believe me, we've looked for solutions as have the admins here on xoops.org, and we/they can't see anything wrong at all.

we've tried different computers etc, still problem is there.. i tried giving my login info to JD to try, as he can view profiles etc, but when he logged in with my account, he got the same. a blank page etc..

when i used the library computers, they returned a zero sized reply error.. so i'm stumped and just learnt to live with it.

you could try with a different user account, see if it works then.

Re: Zero Sized Reply

..yea its pretty strange..now the weblog seems to work but weblinks module shows a zero sized reply.

now i am making the site on xampp instead of the server and copying the database...my only concern is that users shouldnt be getting the zero sized reply.

do you think i should change my host ??? we should have a list of hosts on which other xoopsers are surely not getting this problem.

this is really bad...


Re: Zero Sized Reply
  • 2006/11/21 13:44

  • mclindy

  • Just popping in

  • Posts: 38

  • Since: 2005/1/23

Check to see if you have enabled custom sessions in your preferences. If you have, disable it. One of the reasons you get this error is a cookie problem. I just finished troubleshooting a similar occurrence yesterday. I was stumped until I tried to view the site through a connection that uses SQUID. From home I got an empty page, but I got the Zero Sized Reply message from work so I Googled SQUID and read their FAQ, which pointed me to cookies.

Here's my link in the XOOPS Support Forum that contains a link to the SQUID FAQ that I found helpful. It has a list of other issues that might cause the zero sized reply.

However, since XOOPS has functioned very consistently for me for more than three years (until I tried to set up custom sessions, that is) my guess is you have a cookie issue that causes problems with a particular module (in my case it was WF-Downloads 3.1 Final).

I was just thinking that one way to troubleshoot this is to make the module available to anonymous users for a brief time then try to post or do whatever it is you want to do, then change it back to how you had it. If you can do what you want anonymously but can't when you are logged then in IMHO that suggests that the cookie your site is setting to keep you logged in is causing a problem with that module and/or some other aspect of XOOPS, your server, etc.


Who's Online

633 user(s) are online (34 user(s) are browsing Support Forums)

Members: 0

Guests: 633



Goal: $100.00
Due Date: Jul 31
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits