WF-Downloads --> blank page --> Zero Sided Reply --> Squid?
  • 2006/11/20 15:33

  • mclindy

  • Just popping in

  • Posts: 38

  • Since: 2005/1/23

Hello gang. I have tried to troubleshoot this myself to no avail. I went through every step of the FAQ about white or blank pages and nothing fixed the problem. Here's the gist:

I am using WF-Downloads 3.1 final.

Until this weekend there were only about ten files but I added another seven and now I have this issue.

I can download some files fine. However, when I click "download now" on other files a blank page opens and then nothing happens. In debug mode nothing comes up. At home I just get nothing. I have looked at the entries for the files that work and compared them to those that don't and I don't see any differences (e.g. file names, locations, etc.).

When I try to download the affected files at work I get this in the new browser window:

The requested URL could not be retrieved

While trying to retrieve the URL:http://www.mysite.com/modules/wfdownloads/visit.php?cid=15&lid=15

The following error was encountered:

* Zero Sized Reply

Squid did not receive any data for this request.

Your cache administrator is root.

The file still doesn't download but at least I have some info. This is all I have to go on.

I noticed something similar a few months ago when I tried to attach files to forum entries. Uploads go fine, but when I tried to download them I got the same blank page. At that time I thought it was a problem with the forum module so I just switched over to using WF-Downloads.

Anyway I am stumped. Any ideas? Thanks.

EDIT 11/20 9:32 GMT-8: Strangely, some files you can download if you aren't logged in, but when you log in you get the error. I don't think it's a simple permission problem because I have double & triple checked that. Also, this happens inside of the same category, e.g. when logged in I can download files A and B, but not C; then anonymously I can download all three or maybe only B and C. This doesn't appear to be random--the same issue is always with the same files. I have tried deleting the file and entry then reuploading. The upload is successful and the file appears but has the same problem. I'm thinking this is something with the database but I have no idea what could make this happen.

Installation info.

I am running my own server using CentOS 9.4
Xoops 2.0.16
PHP 5 (not sure of exact version but pretty recent as of 11/20/06 was installed with xampp from ApacheFriends)
MySQL 5 (again, recent but not sure, from ApacheFriends)
WF-Downloads 3.1 Final
eXtGallery 1.0
Wordpress for XOOPS 2.04
Forum 2.02
News 1.44

Re: WF-Downloads --> blank page --> Zero Sided Reply --> Squid?
  • 2006/11/20 17:22

  • mclindy

  • Just popping in

  • Posts: 38

  • Since: 2005/1/23

Solved, mostly.

From SQUID Frequently Asked Questions: Troubleshooting

11.51 Why do I sometimes get ``Zero Sized Reply''?

This happens when Squid makes a TCP connection to an origin server, but for some reason, the connection is closed before Squid reads any data. Depending on various factors, Squid may be able to retry the request again. If you see the ``Zero Sized Reply'' error message, it means that Squid was unable to retry, or that all retry attempts also failed.

What causes a connection to close prematurely? It could be a number of things, including:

1. An overloaded origin server.
2. TCP implementation/interoperability bugs. See the System-Dependent Weirdnesses section for details.
3. Race conditions with HTTP persistent connections.
4. Buggy or misconfigured NAT boxes, firewalls, and load-balancers.
5. Denial of service attacks.
6. Utilizing TCP blackholing on FreeBSD.

You may be able to use tcpdump to track down and observe the problem.

Some users believe the problem is caused by very large cookies. One user reports that his Zero Sized Reply problem went away when he told Internet Explorer to not accept third-party cookies.

Here are some things you can try to reduce the occurance of the Zero Sized Reply error:

1. Delete or rename your cookie file and configure your browser to prompt you before accepting any new cookies.
2. Disable HTTP persistent connections with the server_persistent_connections and client_persistent_connections directives.
3. Disable any advanced TCP features on the Squid system. Disable ECN on Linux with echo 0 > /proc/sys/net/ipv4/tcp_ecn/.
4. Upgrade to Squid-2.5.STABLE4 or later to work around a Host header related bug in Cisco PIX HTTP inspection. The Cisco PIX firewall wrongly assumes the Host header can be found in the first packet of the request.
SQUID Frequently Asked Questions

Reading this reminded me that I changed my preferences to custom session because I wanted to limit the time users were logged in. After reading about cookie problems in the SQUID FAQ I went back and disabled custom sessions and now WF-Downloads seems to be working fine. This still doesn't explain the problem I had with the forums, but maybe it means that it was a problem with the forum module after all. Further, it doesn't explain why some files worked and some didn't if cookies were to blame. I'd like to understand exactly what happened but am happy that it's working again.

If you have any further info or have had a similar issue please post your thoughts here. I couldn't find any pages that relate to this and I doubt if I'm the only one that has ever had this problem.


Who's Online

76 user(s) are online (37 user(s) are browsing Support Forums)

Members: 0

Guests: 76



Goal: $100.00
Due Date: May 31
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits