1
Chappy
xcGallery ecard problem
  • 2004/10/24 7:56

  • Chappy

  • Friend of XOOPS

  • Posts: 456

  • Since: 2002/12/14


I tried to report this to the xcgallery support site but it appears that they are down over there, so I'll post here.

I was having difficulty with the ecard functionality on xcgallery. When I sent cards they were returned to me with the following error:

Quote:
A message that you sent could not be delivered to one or more of its
recipients. This is a permanent error. The following address(es) failed:

myname@email.com
SMTP error from remote mailer after end of data:
host domain.com [123.45.678.62]: 550 Administrative prohibition


I got the following information from our hosting provider about the error:

Quote:
When we checked the logs the error we observed was:

syntax error in 'From:' header when scanning for sender: missing or malformed local part (expected word or "<") in ""Site Name" address@domain.com"

Please check the script and see if the 'From' part in it is given correctly.

Please do not hesitate to contact us for any further assistance.


I noted that the file ecard.php has the following line:

Quote:
$mail->setFrom('"'.$xoopsConfig['sitename'].'" '.$xoopsConfig['adminmail'].'');


I changed that line to this:

Quote:
$mail->setFrom($xoopsConfig['adminmail']);


Thereafter, it worked fine. Not sure what it's all about. I think the settings on our hosting provider are pretty conventional and I don't have any filters set up, so that isn't it...

Anyway, if someone else has problems, maybe you can try this. And maybe its a good idea to try it too? Oh, and if someone has an idea about how I can fix that line so it will include the sitename but won't have problems, I'd be greatful to know about it.

2
zcreem
Re: xcGallery ecard problem
  • 2004/10/24 19:41

  • zcreem

  • Friend of XOOPS

  • Posts: 34

  • Since: 2004/9/2 8


I had some funnys with this module too, some mail servers processed the mail others apparantly not although I didn't recieve any bounce messages or any other indication of a problem except on one of my email accounts I never recieved the e-card and on another I did but hours later, funnyly enough to my email acount on the same mail server the ecard is there the moment I release the button, I suspect that as you have discovered there is a small syntantic error that is blowing the cobbles of some mail server, which of course are not all the same.
I will look a little deeper thanks to your lead and keep the thread posted.

3
sylvainb
Re:xcGallery ecard problem
  • 2004/10/24 20:16

  • sylvainb

  • Not too shy to talk

  • Posts: 168

  • Since: 2003/2/11


By the way,
I you plan to use php5 (or your host forces you to use it), you should replace all instances of scandir in searchnew.php (there are 4 of it) with xcscandir for example.
Because this is a function implemented in php5.

4
zcreem
Re:xcGallery ecard problem
  • 2004/10/24 20:39

  • zcreem

  • Friend of XOOPS

  • Posts: 34

  • Since: 2004/9/2 8


Good tip thanks

5
Chappy
Re:xcGallery ecard problem
  • 2004/10/25 20:48

  • Chappy

  • Friend of XOOPS

  • Posts: 456

  • Since: 2002/12/14


Thanks for the responses. I look forward to any updates.

6
Stewdio
Re:xcGallery ecard problem
  • 2004/10/25 20:56

  • Stewdio

  • Community Support Member

  • Posts: 1560

  • Since: 2003/5/7 1


I have often wondered what heappened to the development of this great module. IT has been on the same version (1.1RC) for what seems like close to a year. It certainly has been ages and I too had problems with e-cards, so I disabled it and forgot about it. I only stuck with it because of it's wonderful layout. Administration has been and always will be a pain for me.

I just downloaded and installed the real Coppermine script, which xcGallery is based from. This will be my full time image manager from now on as I see little hope of renewed interest in this great little module.

Login

Who's Online

71 user(s) are online (56 user(s) are browsing Support Forums)


Members: 0


Guests: 71


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Apr 30
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits