1
catalin
Blank Page after login - only users
  • 2003/12/20 14:59

  • catalin

  • Just popping in

  • Posts: 30

  • Since: 2003/9/4 7


using theme oz_BG ( www.cyber-cup.ro ) my users get a blank page after login ...

and only normal users get that ...

admin and moderators CAN login and get the web-page displayed but NORMAL USERS get a blank page.

i tried with a normal user ... and i get a blank page in every browser ...

using the admin account ... everything works fine ...

2
Herko
Re: Blank Page after login - only users
  • 2003/12/20 16:02

  • Herko

  • XOOPS is my life!

  • Posts: 4238

  • Since: 2002/2/4 1


Can you turn on php-debug in the system admin -> preferences -> general settings page, and then login as a normal user and report for us the errors you get displayed?

Herko

3
catalin
Re: Blank Page after login - only users
  • 2003/12/20 16:44

  • catalin

  • Just popping in

  • Posts: 30

  • Since: 2003/9/4 7


believe me .. i turned on php-debug, solved the general problems the site haved ( man ... i should turn this thing on more often ... i had 250 erors ... shit ), but not a thing ...

i tried looking at the user.php, checklogin.php, usrinfo.php ... the cookies work fine ... but pages aren`t being displayed when a normal user logs in ...

BTW if i log in ... i don`t get no error mesaje ( even with debug ON ) , just a blank page, and if I want to view the source ... the page is realy blank, there isn`t a line of HTML code in the hole page.

Does after login XOOPS suports redirecting ?!? It may be a cause ...

the weird thing it that it alows acces ( displayes the pages ) only for admin and moderators ... and if i were to make all the users moderators ... i would solve the problem of them loging in ...

I looked at xoopsjs.php ... but i was scared to do anything ... i would try to replace it ... with the ORIGINAL xoopsjs.php ( i made some changes since the first XOOPS ) .. but i don`t know if it will work ...

Anyway ... if someone knows what is the problem ... pls help me ... I am desperate here ... i have 1600 unique vizitors a day ... i must solve this quickly ...

4
catalin
Re: Blank Page after login - only users
  • 2003/12/20 16:49

  • catalin

  • Just popping in

  • Posts: 30

  • Since: 2003/9/4 7


btw in the XOOPS DEFAULT theme this shit does not happen ...

i realy need help here ...

5
catalin
Re: Blank Page after login - only users
  • 2003/12/20 16:52

  • catalin

  • Just popping in

  • Posts: 30

  • Since: 2003/9/4 7


and more weird ... if it was something with the theme then why doesn`t it procces the theme and show something when i view the source of the web-page ...

6
sunsnapper
Re: Blank Page after login - only users

My first guess is a block turned on for Registered Users that's not turned on for others. However, that theory has some holes in it (since I'm thinking Admin and Mods probably have most of the same blocks turned on?).

Another thought is that perhaps you have set a default module (such as news) and then not given read access rights to that module for registered users. (I doubt this one too, but, it's a starting point...)

I assume you have already tried the this:
http://wiki.xoops.org/wakka.php?wakka=TroubleshootingBlankPage

7
catalin
Re: Blank Page after login - only users
  • 2003/12/20 17:40

  • catalin

  • Just popping in

  • Posts: 30

  • Since: 2003/9/4 7


been there, done that ...

this is a test for all of you ...

i made a test user :

user : regenesis

pass : regenesis


try loging in ... see the errors ... help me

8
catalin
Re: Blank Page after login - only users
  • 2003/12/20 17:50

  • catalin

  • Just popping in

  • Posts: 30

  • Since: 2003/9/4 7


k, with the account goes through the " Welcome .... if the page ... " and after refresh ... BOOM ... hte blank page ... ( a blank page with no source )

what can it be ?!? ...

9
catalin
Re: Blank Page after login - only users
  • 2003/12/20 18:09

  • catalin

  • Just popping in

  • Posts: 30

  • Since: 2003/9/4 7


damn it i tried everything from making another group acces for al users ... but nothing ... still ... the blank page appears ...

Xoops Core TEAM - HELP ME PLSSSS ... im going nuts


( i need people to be able to login so they can post in the forums )

10
wtravel
Re: Blank Page after login - only users

Hi,

So when you log in as registered user with admin rights (not the webmaster account) you can see the main page as well?

Can you try to make a new account, give admin rights to news only and for the rest the normal access rights, and enable all blocks you have on normally?

See if you can login and get pages displayed.

Also, untill the problem is fixed, you can make a working theme your default theme, and for your test accounts, set the new theme that causes the problems as their default theme. That way they will not have any disturbance (other than the different theme). You could post a temporary news item in which you explain ....

Login

Username:
Password:

Lost Password? Register now!

Who's Online

82 user(s) are online (60 user(s) are browsing Support Forums)


Members: 0


Guests: 82


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Dec 31
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits