11
davidl2
Re: Please post modules that you know DONT WORK in Xoops 2.2.2
  • 2005/8/25 16:33

  • davidl2

  • XOOPS is my life!

  • Posts: 4843

  • Since: 2003/5/26


Phppp's Wiki (sorry - i've just taken some strong medicine and cannot remember the name!) can have various permissions set - so it is ideal for this purpose

(In fact, perhaps suitable to move the XOOPS wiki on to perhaps?)

12
Mithrandir
Re: Please post modules that you know DONT WORK in Xoops 2.2.2

Definitely looking into moving the Dev Wiki to phppp's DokuWiki port - but need to work on the data migration and have absolutely no time for that right now.
"When you can flatten entire cities at a whim, a tendency towards quiet reflection and seeing-things-from-the-other-fellow's-point-of-view is seldom necessary."

Cusix Software

13
davidl2
Re: Please post modules that you know DONT WORK in Xoops 2.2.2
  • 2005/8/25 16:56

  • davidl2

  • XOOPS is my life!

  • Posts: 4843

  • Since: 2003/5/26


Agreed ... at least it is something to look forward to for the future

I've been running the wiki ok on my test 2.2.x site ... so should be able to get something done soon...

14
gestroud
Re: Please post modules that you know DONT WORK in Xoops 2.2.2
  • 2005/8/25 19:00

  • gestroud

  • Home away from home

  • Posts: 1538

  • Since: 2004/12/22


A suggestion:

Each module in the Modules Repository has a compatibility listing, e.g. Platform: XOOPS 2.0.x. It's supposed to let us know what version of XOOPS the module will work with.

Is it possible to update the compatiblity listing of each module as results become available from users?

It might be better to do it bit by bit, unless someone wants to wait until there's a master list and tackles it all at once or in teams. I have a feeling it'll be a pretty long list.

EDIT: Probably be better to wait until there's a definitive list approved by XOOPS admin. Then it could be divided amongst volunteers who could change the module listing by making modification requests.

15
Mithrandir
Re: Please post modules that you know DONT WORK in Xoops 2.2.2

The platform and requirements is all very well - but the problem is that they are usually perceived as MINIMUM requirements.

Does a module that works with 2.0.x automatically work with 2.2.x? No, that's the reason why we want this differentiation
Does a module that works with 2.2.x not work with 2.0.x? Some would not work with 2.0.x, but most would work for now.

How do we say "this module works with both 2.0.x and 2.2.x"?
"When you can flatten entire cities at a whim, a tendency towards quiet reflection and seeing-things-from-the-other-fellow's-point-of-view is seldom necessary."

Cusix Software

16
mclindy
Re: Please post modules that you know DONT WORK in Xoops 2.2.2
  • 2005/8/25 19:41

  • mclindy

  • Just popping in

  • Posts: 38

  • Since: 2005/1/23


How about letting people vote?

Perhaps by default a compatability table could be added to each module listing. Hopefully, as new versions are added it would be easy to display yet another row for the new version.

Registered users could "vote" with yes, yes with bugs, no. The votes could be displayed using the modules that already exist or scores could be given and averaged to produce a "compatability score" for each release.

Sure a few people would be jerks, and a few others would screwed up their implementation of the module 'cause they don't know what they're doing yet, but overall it should average out and be useful.

Just a thought. Thanks for all of your hard work.

17
Shine
Re: Please post modules that you know DONT WORK in Xoops 2.2.2
  • 2005/8/25 21:09

  • Shine

  • Just can't stay away

  • Posts: 822

  • Since: 2002/7/22


Quote:
How do we say "this module works with both 2.0.x and 2.2.x"?

Unless I understand it wrong (in that case forget my reply) but can't this be 'simply' added during filling in the version compatibility? That what is used at the repository right now? Can't this section be slowly upgraded?
Considering some modules we know they aren't XOOPS 2.2.x compatible and php5 (some smart modules version for instance)
Version: 2.0.x & 2.2.x

I think another very important thing that needs to be included is the php version compatibility. Modules only testing for the works within XOOPS 2.0.x and/or 2.2.x isn't enough. If it isn't clear on what php version the module has been tested also.
Therefore I think a second field has to be added also:
phpversion:

As I understand it some modules, regardles which XOOPS version, don't work within php5. My knowledge isn't enough to know if php5 compatible modules will also work within php4. I know there are scripts/(modules?) which only work within php5 and not in php4 and vice versa.
Shattering a light on this matter the same time would be great.

Grtz., Shine

18
gestroud
Re: Please post modules that you know DONT WORK in Xoops 2.2.2
  • 2005/8/25 21:20

  • gestroud

  • Home away from home

  • Posts: 1538

  • Since: 2004/12/22


Quote:

Mithrandir wrote:
How do we say "this module works with both 2.0.x and 2.2.x"?


I don't know, you're the developer

Seriously though, I'm sure that a sentence stating what versions the modules are compatible with can be added to the modules' descriptions through a modification request -- once a list is devised. It should definitely be a requirement for any new modules.

19
hyperpod
Re: Please post modules that you know DONT WORK in Xoops 2.2.2
  • 2005/8/26 0:24

  • hyperpod

  • Quite a regular

  • Posts: 359

  • Since: 2004/10/4


Voting wont work...
It allows people like Bush to continue a senseless war.

We just need to have a XOOPS 2.0+/2.2+ module compatibility coding party! BYOB, BYOM, BYOP



Daniel Hall / XOOPS Module Development & Theme Design
Free XOOPS Support > My Wish List

20
brash
Re: Please post modules that you know DONT WORK in Xoops 2.2.2
  • 2005/8/26 0:25

  • brash

  • Friend of XOOPS

  • Posts: 2206

  • Since: 2003/4/10


I can code MS-DOS batch files. Does that help...
IT Headquarters
Innovative IT Solutions

Login

Username:
Password:

Lost Password? Register now!

Who's Online

65 user(s) are online (34 user(s) are browsing Support Forums)


Members: 0


Guests: 65


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Jan 31
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits