xoops forums

Mamba

Moderator
Posted on: 2017/1/14 13:00
Mamba
Mamba (Show more)
Moderator
Posts: 10750
Since: 2004/4/23
#21

Re: Adslight 2.2 error after upgrade 2.5.8

What PHP version do you have?
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

masel

Friend of XOOPS
Posted on: 2017/1/14 13:11
masel
masel (Show more)
Friend of XOOPS
Posts: 30
Since: 2004/10/6
#22

Re: Adslight 2.2 error after upgrade 2.5.8

Quote:

Mamba wrote:
What PHP version do you have?


PHP 5.6.25

Adslight 2.2 Beta 3 2015/02/23 It works without error.

Yurdal

Friend of XOOPS
Posted on: 4/11 16:43
Yurdal
Yurdal (Show more)
Friend of XOOPS
Posts: 361
Since: 2005/3/27
#23

Re: Adslight 2.2 error after upgrade 2.5.8

I'm afraid we are pulling a dead horse here
Adslight doesnt work with xoops 2.5.8.1 and up
Tried with 2.5.9. and 2.5.10 RC , tried with php 5.6 and php 7.2 version but still no luck

Tried several versions of adslight 2.2 beta 3 and beta 4 none of them work
Xoops core Updates from 2.7.x have broke the module that is very important to me

How to further now ?

zyspec

Module Developer
Posted on: 4/12 3:02
zyspec
zyspec (Show more)
Module Developer
Posts: 1039
Since: 2004/9/21
#24

Re: Adslight 2.2 error after upgrade 2.5.8

@yurdal,

It looks like quite a few corrections have been made in Mamba's fork and he's submitted a pull request to XoopsModules25. Looks like if he can integrate the pull request into the main branch on XoopsModules25 then we can test that version to see how to proceed.

Yurdal

Friend of XOOPS
Posted on: 4/12 7:59
Yurdal
Yurdal (Show more)
Friend of XOOPS
Posts: 361
Since: 2005/3/27
#25

Re: Adslight 2.2 error after upgrade 2.5.8

Quote:

zyspec wrote:
@yurdal,

It looks like quite a few corrections have been made in Mamba's fork and he's submitted a pull request to XoopsModules25. Looks like if he can integrate the pull request into the main branch on XoopsModules25 then we can test that version to see how to proceed.


I hope so, in the meantime to create really functional website i must downgrade to older version because of lack of the module support of the newer core

I really love Xoops(since 2005) but last years lot of themes and modules that where used are broken or doesn't function well , sad to see.
I 'm trying to work around by using older core but it should't

zyspec

Module Developer
Posted on: 4/12 14:15
zyspec
zyspec (Show more)
Module Developer
Posts: 1039
Since: 2004/9/21
#26

Re: Adslight 2.2 error after upgrade 2.5.8

Can you tell us which modules you use? We may be able to get them functional with newer versions of XOOPS without a lot of work. What I've typically found is that there are changes in PHP MySQL(i), etc. that require changes that make it so the modules don't operate correctly.

Yurdal

Friend of XOOPS
Posted on: 4/12 14:52
Yurdal
Yurdal (Show more)
Friend of XOOPS
Posts: 361
Since: 2005/3/27
#27

Re: Adslight 2.2 error after upgrade 2.5.8

I think the core modules that should be compatible with 2.5.10 at least:

-Newbb
-Adslight
-Publisher
-Liaise (making forms)
-Content module
-Extgallery
-Oledrion
-Extcal
-TDMdownload or similar download module

IMHO, This are the modules that at least needed to make a good website

Mamba

Moderator
Posted on: 4/14 3:08
Mamba
Mamba (Show more)
Moderator
Posts: 10750
Since: 2004/4/23
#28

Re: Adslight 2.2 error after upgrade 2.5.8

Richard did some major debugging, so you can test now AdsLight 2.3 RC1:

https://github.com/mambax7/adslight/releases/tag/2.3_RC1
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

Yurdal

Friend of XOOPS
Posted on: 4/14 11:34
Yurdal
Yurdal (Show more)
Friend of XOOPS
Posts: 361
Since: 2005/3/27
#29

Re: Adslight 2.2 error after upgrade 2.5.8

Hi, Mamba thanks for support,
Just downloaded and installed, after that after modifing thins in the admin section i get his error

Error : Error: Class 'XoopsModules\Adslight\Helper' not found
-------------------------------
After making a catagroy some definitions are not set:
Image directory:
../modules/adslight/assets/images/img_cat/..
Display price: _AM_ADSLIGHT_OUI _AM_ADSLIGHT_NON (in this category)
Moderate this category _AM_ADSLIGHT_OUI _AM_ADSLIGHT_NON
Moderate subcats of this category _AM_ADSLIGHT_OUI _AM_ADSLIGHT_NON
-------------------------------------------
After deleting of the default main categories, i cant add a new main category

didnt get any error but ididnt add any catagory

Using xoops 2.5.10RC ,php 7.2, MariaDB 10.2

Mamba

Moderator
Posted on: 4/14 14:12
Mamba
Mamba (Show more)
Moderator
Posts: 10750
Since: 2004/4/23
#30

Re: Adslight 2.2 error after upgrade 2.5.8

This is frustrating

Let me check again with MariaDB (I only use MySQL)
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs