xoops forums

Zirafka

Just popping in
Posted on: 2016/10/16 6:48
Zirafka
Zirafka (Show more)
Just popping in
Posts: 66
Since: 2008/8/9 1
#1

Upgrade from 2.5.7.2 to 2.5.8.

I want upgrade my XOOPS site from version 2.5.7.2 to 2.5.8. But have problem with login as administrator. I wrote name and password, click to login button and page si redirecting back.

Information from XOOPS:
XOOPS version XOOPS 2.5.7.2
PHP version 5.5.34
MySQL version
Server apache2handler
OS Linux
safe_mode Off
register_globals Off
magic_quotes_gpc Off
allow_url_fopen On
fsockopen On
post_max_size 100M
max_input_time 60
output_buffering 4096
max_execution_time 30
memory_limit 128M
file_uploads On
upload_max_filesize

Information from PHP MyAdmin:

MySQL

Server: Localhost via UNIX socket
MySQL version: 5.1.73-0ubuntu0.10.04.1-log
Protocol version: 10
User: zirafoviny@localhost
Character set v MySQL: UTF-8 Unicode (utf8)

Webserver

Apache/2.2.14 (Ubuntu)
MySQL client: 5.1.73
PHP extension: mysqli

Resized Image

First load of upgrade script (http://chaoz.zirafoviny.cz/_hic_sunt_ ... oops/xoops_upgrade_01.gif).

Resized Image

After click to login button (http://chaoz.zirafoviny.cz/_hic_sunt_ ... oops/xoops_upgrade_02.gif).

Resized Image

Xoops administration page (http://chaoz.zirafoviny.cz/_hic_sunt_ ... oops/xoops_upgrade_03.gif).

On my "test server" on local computer it´s all ok. Upgrade run pas with cca 30 seconds. But on my local computer working WAMP server.

Any ideas what´s wrong? Thank you :)

geekwright

Quite a regular
Posted on: 2016/10/16 15:32
geekwright
geekwright (Show more)
Quite a regular
Posts: 262
Since: 2010/10/15
#2

Re: Upgrade from 2.5.7.2 to 2.5.8.

Interesting, usually I hear it doesn't work on WAMP ;)

I've been looking into this, but don't have any real answers yet. But I do have a couple of thoughts.

Cookies might have something to do with it. Since you have a XOOPS running on zirafoviny.cz/ and are upgrading a system on zirafoviny.cz/_test/ there is some chance that the cookies are interfering is some way? Try and delete the cookies for the domain, and then retry the upgrade. (In Chrome, I would suggest using incognito mode to try the upgrade, but I'm not that familiar with Opera currently.)

Also, it is possible there could be a related error message being swallowed. In upgrade/index.php on line 24 you should see:
error_reporting(0);


Try and change that as follows and retry the upgrade to see if it reveals anything relevant:
error_reporting(-1);


If neither of these reveal the issue, I'll investigate further.

Zirafka

Just popping in
Posted on: 2016/10/16 18:23
Zirafka
Zirafka (Show more)
Just popping in
Posts: 66
Since: 2008/8/9 1
#3

Re: Upgrade from 2.5.7.2 to 2.5.8.

Thank you. I tried to change the setting to "error_reporting (-1);" but the result is the same.
I tried to delete cookies, the result is the same.
I tried the procedure in Firefox, the result is the same.
The update script does not write any errors.

www.zirafoviny.cz functional web
directory www.zirafoviny.cz/_test is directory for testing.

After the update files, I can not log into the system. It's the same result as updates.

Mamba

Moderator
Posted on: 2016/10/16 20:04
Mamba
Mamba (Show more)
Moderator
Posts: 10750
Since: 2004/4/23
#4

Re: Upgrade from 2.5.7.2 to 2.5.8.

Try to remove all cache files from /xoops_data/caches/ folders - sometimes it helps.

Also, clear the "sessions" table in your database.

In addition - sometimes people place the "xoops_data" and "xoops_lib" outside of the Document Root, as they should, but then forget to copy the latest files from the upgrade there. So make sure that you copy the "xoops_data" and "xoops_lib" files to the right location.
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

Zirafka

Just popping in
Posted on: 2016/10/16 20:50
Zirafka
Zirafka (Show more)
Just popping in
Posts: 66
Since: 2008/8/9 1
#5

Re: Upgrade from 2.5.7.2 to 2.5.8.

Thanks for the inspiration Mamba :)

Table sess_ip was setting to varchar(15). After change to varchar(32) all ok and upgrade finished on cca 10 seconds

Mamba

Moderator
Posted on: 2016/10/16 21:37
Mamba
Mamba (Show more)
Moderator
Posts: 10750
Since: 2004/4/23
#6

Re: Upgrade from 2.5.7.2 to 2.5.8.

Fantastic!!!! I'm very happy to hear it!

In the upgrade for XOOPS 2.5.9 we'll need to make sure that the "session" table is set to 32 then.
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

geekwright

Quite a regular
Posted on: 2016/10/18 0:45
geekwright
geekwright (Show more)
Quite a regular
Posts: 262
Since: 2010/10/15
#7

Re: Upgrade from 2.5.7.2 to 2.5.8.

Thanks for the report and the persistence! That helps a lot.

I just opened issue 239 on GitHub to track this. It is actually a tricky little problem.

Glad you got it fixed. Thanks again!