xoops forums

mjoel

Quite a regular
Posted on: 2014/11/28 10:59
mjoel
mjoel (Show more)
Quite a regular
Posts: 307
Since: 2006/12/9
#1

Common Utilities Troubleshooting

Hi

Im trying xoops 2.5.7.1 and common utilities in localhost...i have followed the intruction in rm readme..but i received the error below...


Common Utilities 2.2.7.5
XOOPS 2.5.7.1

Apache 2.2.26
PHP 5.3.27
Mysql 5.5.34


-----------------------------------

( ! ) Parse error: syntax error, unexpected T_USE, expecting T_FUNCTION in C:\Program Files\VertrigoServ\www\test\modules\rmcommon\class\helpers\httprequest.class.php on line 14
Call Stack
# Time Memory Function Location
1 0.0020 415632 {main}( ) ..\admin.php:0
2 0.0030 436952 include( 'C:\Program Files\VertrigoServ\www\test\modules\system\header.php' ) ..\admin.php:34
3 0.0040 459104 include_once( 'C:\Program Files\VertrigoServ\www\test\include\cp_header.php' ) ..\header.php:18
4 0.0050 482600 include_once( 'C:\Program Files\VertrigoServ\www\test\mainfile.php' ) ..\cp_header.php:24
5 0.0090 605488 include( 'C:\Program Files\VertrigoServ\www\test\include\common.php' ) ..\mainfile.php:75
6 0.2380 5768376 XoopsPreload->triggerEvent( ) ..\common.php:359
7 0.2380 5768808 call_user_func ( ) ..\preload.php:140
8 0.2380 5768984 RmcommonCorePreload::eventCoreIncludeCommonEnd( ) ..\preload.php:140
9 0.2380 5769616 RMEvents->run_event( ) ..\core.php:139
10 0.2390 5771616 call_user_func_array ( ) ..\events.php:122
11 0.2390 5771632 Twop6RmcommonPreload::eventRmcommonXoopsCommonEnd( ) ..\events.php:122
12 0.2390 5771848 rmc_autoloader( ) ..\events.php:0

mjoel

Quite a regular
Posted on: 2014/11/28 11:02
mjoel
mjoel (Show more)
Quite a regular
Posts: 307
Since: 2006/12/9
#2

Re: Common Utilities Trouble

one more thing do i have to disable the inline debug mode after installing rmcommon ?

bitcero

Quite a regular
Posted on: 2014/11/30 3:18
bitcero
bitcero (Show more)
Quite a regular
Posts: 318
Since: 2005/11/26
#3

Re: Common Utilities Troubleshooting

rmcommon needs PHP 5.4.

You can disable the inline debug if you wish.

Zap_English

Quite a regular
Posted on: 2016/5/30 6:45
Zap_English
Zap_English (Show more)
Quite a regular
Posts: 384
Since: 2016/5/24
#4

Re: Common Utilities Troubleshooting

On github it says rmcommon needs

PHP >= 5.3
XOOPS >= 2.5 installed and running

I just checked and my live server is running php 5.4.45

but when I installed rmcommon it crashed the entire website. I had to delete the subbdir's to get it back and then uninstall the non-existent module

ryuaka

Just popping in
Posted on: 2016/5/30 22:35
ryuaka
ryuaka (Show more)
Just popping in
Posts: 32
Since: 2011/9/24
#5

Re: Common Utilities Troubleshooting

I strongly recommend use PHP 5.6 with the last release of Common Utilities wich is 2.3.2.5 (as far as I know).

If your are testing or making a project in local, try to use Wamp Server (x32 or x64) it works really well and it's prepared for XOOPS (I guess). I was using XAMPP before, but since the last release everything goes bad so I decide to move on to Wamp Server.

I'm using the next modules and characteristics for testing without errors:

- XOOPS 2.5.7.2
- Common Utilities 2.3.2.5
- xThemes 1.6.3.6
- MyWord 2.2.5.4
- Professional Works 2.2.1.8 RC
- PHP 5.6.16
- MySQL 5.7.9

If you use xThemes, sometimes could show a blank page in your site, but you just have to delete in xoops_cache the file xoops_XXXXXX_system_modules_active.php and reload the site again, and that solve the problem forever.

Finally if you don't have the last release of XOOPS Mexico modules, visit Red Mexico and bitcero repositories in GitHub.

Zap_English

Quite a regular
Posted on: 2016/5/30 23:15
Zap_English
Zap_English (Show more)
Quite a regular
Posts: 384
Since: 2016/5/24
#6

Re: Common Utilities Troubleshooting

I'm using rmcommon 2.3.2.5 with XOOPS 2.5.7.2 on a WAMPSERVER (64 BITS & PHP 5.6.15 & PHP 7) 3 Apache : 2.4.17 MySQL : 5.7.9 PHP : 5.6.16 PHP : 7

I downloaded and installed some of your modules today from the rmcommon site.

bXpress 1.2
QuickPages 2

advform

Rmcommon keeps telling me to update bXpress Forums 1.2.3.1 RC. I update it, and it says it's updated, but then it goes back into the update available list.

I installed AdvancedForms for Common Utilities and I was able to create forums (not mentioned as a requirement)

However, I can't assign a category. The dropdown list is empty

Any ideas?

And when I uploaded rmcommon to my live site running php 5.4.45 XOOPS 2.5.7.2 rmcommon it crashed the entire website. I had to delete the subbdir's to get it back and then uninstall the non-existent module

Zap_English

Quite a regular
Posted on: 2016/6/1 11:33
Zap_English
Zap_English (Show more)
Quite a regular
Posts: 384
Since: 2016/5/24
#7

Re: Common Utilities Troubleshooting

This morning RMCOMMON told me updates for RMCommon and bxpress were available

I let it update rmcommon and when it finished I got

Quote:

Fatal error: Cannot make non static method XoopsSystemGui::validate() static in class XoopsGuiRedmexico in D:\wamp64\www\rfu\modules\system\themes\redmexico\redmexico.php on line 27
Call Stack
# Time Memory Function Location
1 0.0140 618888 {main}( ) ...\updates.php:0
2 0.5360 6149272 show_available_updates( ) ...\updates.php:896
3 0.5460 6291824 xoops_cp_header( ) ...\updates.php:78
4 0.5540 6315768 XoopsSystemCpanel::getInstance( ) ...\cp_functions.php:28
5 0.5540 6316072 XoopsSystemCpanel->__construct( ) ...\cpanel.php:47
6 0.5540 6316352 XoopsSystemCpanel->loadGui( ) ...\cpanel.php:34
7 0.5590 6343912 include_once( 'D:\wamp64\www\rfu\modules\system\themes\redmexico\redmexico.php' ) ...\cpanel.php:63


It still shows 2 updates available from the dashboard and I get the same error if I click on the updates

justinebaby

Just popping in
Posted on: 2016/6/2 7:59
justinebaby
justinebaby (Show more)
Just popping in
Posts: 21
Since: 2015/12/17
#8

Re: Common Utilities Troubleshooting

Hello,

You can try the new update of RMcommon, now in 2.3.2.8 version.

with the best.

Zap_English

Quite a regular
Posted on: 2016/6/2 9:21
Zap_English
Zap_English (Show more)
Quite a regular
Posts: 384
Since: 2016/5/24
#9

Re: Common Utilities Troubleshooting

I did

It took down the entire website, so I've given up on it