11
barryc
Re: Cannot post to forums
  • 2013/6/14 2:45

  • barryc

  • Just can't stay away

  • Posts: 480

  • Since: 2004/3/20


I haven't tried all of these yet, but I am sure the posts are in the tables because I can see them when logged on as an ordinary registered user. I only get the error when logged on as admin.

I did find an error log on modules/newbb and it is posted below. The errors seem to do with Protector. Interestsingly, when I try to open any of the tabs in Protector I get the same 500 error. Below is the error log

Barry Cooper

Error log follows:

[12-Jun-2013 16:24:09 America/Denver] PHP Strict Standards: Non-static method Protector::getInstance() should not be called statically in /home1/barrycne/nwk_lib/modules/protector/include/precheck_functions.php on line 12
[12-Jun-2013 16:26:51 America/Denver] PHP Strict Standards: Non-static method Protector::getInstance() should not be called statically in /home1/barrycne/nwk_lib/modules/protector/include/precheck_functions.php on line 12
[12-Jun-2013 16:27:29 America/Denver] PHP Strict Standards: Non-static method Protector::getInstance() should not be called statically in /home1/barrycne/nwk_lib/modules/protector/include/precheck_functions.php on line 12
[12-Jun-2013 16:29:54 America/Denver] PHP Strict Standards: Non-static method Protector::getInstance() should not be called statically in /home1/barrycne/nwk_lib/modules/protector/include/precheck_functions.php on line 12
[12-Jun-2013 16:29:57 America/Denver] PHP Strict Standards: Non-static method Protector::getInstance() should not be called statically in /home1/barrycne/nwk_lib/modules/protector/include/precheck_functions.php on line 12
[12-Jun-2013 16:30:00 America/Denver] PHP Strict Standards: Non-static method Protector::getInstance() should not be called statically in /home1/barrycne/nwk_lib/modules/protector/include/precheck_functions.php on line 12
[12-Jun-2013 16:30:40 America/Denver] PHP Strict Standards: Non-static method Protector::getInstance() should not be called statically in /home1/barrycne/nwk_lib/modules/protector/include/precheck_functions.php on line 12

12
barryc
Re: Cannot post to forums
  • 2013/6/14 17:12

  • barryc

  • Just can't stay away

  • Posts: 480

  • Since: 2004/3/20


I cannot figure out where to get the value following # in your second suggestion below. I can get the post_id from the newbb tables, but where do I find the other value?

Incidentally, I set up a second test ID as admin and have the same problem with it. It does only affect admin users.

Barry

Quote:

irmtfan wrote:
You have a 500 error in submitting the post and in modules/newbb/viewtopic.php so Im sure it is not related to newbb. Im sure you have an issue in your configurations.
Newbb will work on php 5.2 but you will miss some few features.
If i were you i would do these:
- go to Cpanel and in modules/newbb and see if there is any error_log file there.
- provide us a full php info.
- try to see the topic by post_id instead of topic_id eg here:
this:
https://xoops.org/modules/newbb/viewto ... id=354122#forumpost354122
instead of this:

https://xoops.org/modules/newbb/viewtopic.php?topic_id=76153

- go to the _bb_posts table and find if posts exist there.

Usually 500 errors are very hard to debug but we will try to help you.

13
barryc
Re: Cannot post to forums
  • 2013/6/15 19:49

  • barryc

  • Just can't stay away

  • Posts: 480

  • Since: 2004/3/20


An update:

I got frustrated trying to figure out what the problem was so I tried a complete new install for this small site. That required some work to re-enter registered users, re-intall modules, etc. but it seemed the simplest thing to do. The good news is that the problems are no longer there. I have to believe that I had one or more corrupted files during my initial install.

Thanks to those who tried to help.

Barry

14
xoobaru
Re: Cannot post to forums
  • 2013/6/16 14:19

  • xoobaru

  • Just can't stay away

  • Posts: 494

  • Since: 2010/12/2


Youre not alone there brother, I had to do that once or twice.

15
irmtfan
Re: Cannot post to forums
  • 2013/6/20 2:43

  • irmtfan

  • Module Developer

  • Posts: 3419

  • Since: 2003/12/7


sorry I did not back to you for one week.

to access a topic in newbb just this link with post_id is enough:
https://xoops.org/modules/newbb/viewtopic.php?post_id=354122

But as i said before 500 errors are usually coming from bad php configurations so a full php info will show us many things.

Now i see you solved your issue so maybe you had some corrupted files as you mentioned.

Login

Who's Online

75 user(s) are online (49 user(s) are browsing Support Forums)


Members: 0


Guests: 75


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Aug 31
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits