xoops forums

barryc

Just can't stay away
Posted on: 2013/6/11 23:21
barryc
barryc (Show more)
Just can't stay away
Posts: 480
Since: 2004/3/20
#1

Cannot post to forums

I have just begun work on a new web site using Xoops 2.5.6. I installed NewBB 4.3 and set up some categories and forums. I just tried to post a message to one forum. I can type in the message but when I try to submit it I get an error, as shown below. If I look at the forum content I see the post and the link seems to be right, e.g. http://www.nwkillies.org/modules/newbb/viewtopic.php?topic_id=7. If I click on that message heading I get the same error message, as below. The address nwkillies.org is an add-on domain on the server serving my personal domain. It is running PHP version 5.2.17, mySQL 5.5.32-log.

The error below occurs using Chrome. Using Safari (on a Mac) I just get a while page, no error message. I also just tried to post to xNews 1.70 and could not. I tried from both the user side and the admin side and nothing appears when I post.

The fact that both fail suggests something wrong on the server but I have no idea what. Any suggestions would be welcomed.

Server error
The website encountered an error while retrieving http://www.nwkillies.org/modules/newbb/viewtopic.php?topic_id=7. It may be down for maintenance or configured incorrectly.
Here are some suggestions:
Reload this webpage later.
HTTP Error 500 (Internal Server Error): An unexpected condition was encountered while the server was attempting to fulfill the request.

Barry Cooper

xoobaru

Just can't stay away
Posted on: 2013/6/12 0:16
xoobaru
xoobaru (Show more)
Just can't stay away
Posts: 494
Since: 2010/12/2
#2

Re: Cannot post to forums

mmm...

Php 5.2 is quite old. Alot of things have changed in php and the web since. Browsers too. Chrome didn't even exist then, so no surprise that might not be compatible. Not sure how far back the 2.5.6 to php version compatibility was tested for, or are being currently used successfully with. Best guess is it is php version.

Permissions problem? Probably not because it let you create, just not submit.

Lots of people are using 4.3 myself included, without the issue you describe.

barryc

Just can't stay away
Posted on: 2013/6/12 0:25
barryc
barryc (Show more)
Just can't stay away
Posts: 480
Since: 2004/3/20
#3

Re: Cannot post to forums

Well, 2.5.6 is supposed to be compatible with PHP >=5.2, even though 5.3 is recommended.

Barry Cooper

xoobaru

Just can't stay away
Posted on: 2013/6/12 2:21
xoobaru
xoobaru (Show more)
Just can't stay away
Posts: 494
Since: 2010/12/2
#4

Re: Cannot post to forums

I think someone (Chefry?) recently posted his host is running 5.2, but with newbb? Who knows.

I would ask your hoster to provide php error log for the time window you were known to be attempting to submit. Any errors there? They have to do a temporary setup for this in php.ini.

Be sure to have them disable it again once you get the logs you need.

barryc

Just can't stay away
Posted on: 2013/6/12 23:13
barryc
barryc (Show more)
Just can't stay away
Posts: 480
Since: 2004/3/20
#5

Re: Cannot post to forums

I think my hosting company has helped me find the problem. First, we upgraded my PHP version to 5.3.25. That did not fix the problem. The techs at my hosting company then looked more closely at the problem. Here is what they report:

"The error is not a php error, its actually not outputting anything from that page. There appears to be (as far as I can tell) a variable that is not getting set correctly called $isadmin

in this file
~/public_html/nwkillies/modules/newbb/viewtopic.php

on line 87
$isadmin = newbb_isAdmin($forum_obj);"


I was indeed logged in as admin when I had this problem. To test this I created a test user with simple registered user status and logged in under that name. Lo and behold, I was able to see a couple of test posts I had created as admin and when I click on them I can read the post. Therefore the problem seems to be a bug in newbb related to being logged in as admin. I also posted a test message as a registered user and it shows up.

The sad news is that xNews 1.70 is not working even when logged in as a registered user. Test posted news does not show up. I will probably downgrade to 1.68, which is the version listed in Mamba's green and yellow form.

I have also installed XoopsPoll as modified by zyspec and that is working.

Should I report this apparent bug in newBB somewhere specific?

Barry Cooper

Mamba

Moderator
Posted on: 2013/6/13 0:06
Mamba
Mamba (Show more)
Moderator
Posts: 10792
Since: 2004/4/23
#6

Re: Cannot post to forums

Quote:
The sad news is that xNews 1.70 is not working even when logged in as a registered user. Test posted news does not show up. I will probably downgrade to 1.68,

You cannot really "downgrade, because xNews is a "forked" module, so I don't really know how compatible it is. As far as I know, it was never finished.

Just make sure that you have good backup of the DB.
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

barryc

Just can't stay away
Posted on: 2013/6/13 0:20
barryc
barryc (Show more)
Just can't stay away
Posts: 480
Since: 2004/3/20
#7

Re: Cannot post to forums

Mamba,

is there another news module you can recommend? I assumed the one I found on Sourceforge was the one you refer to in your green and yellow form.

I recently found a post you made regarding the basic module pack for 2.5.5 and i assume that most if not all of those work in 2.5.6. As I gave up the webmaster position on the large site I used to maintain, I am a bit out of touch with recent developments on Xoops. Is there some recent post listing the modules available for 2.5.6. I must say I've been frustrated trying to find modules that are known to work.

Barry

Mamba

Moderator
Posted on: 2013/6/13 0:36
Mamba
Mamba (Show more)
Moderator
Posts: 10792
Since: 2004/4/23
#8

Re: Cannot post to forums

Quote:
I recently found a post you made regarding the basic module pack for 2.5.5 and i assume that most if not all of those work in 2.5.6

Yes, all the in green should work without problems.

For News, in addition to News, you can try Publisher. Many people are using it with success and like it, as it has tons of features.
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

chefry

Home away from home
Posted on: 2013/6/14 1:43
chefry
chefry (Show more)
Home away from home
Posts: 1005
Since: 2006/10/14
#9

Re: Cannot post to forums

For main page/news I'm using Article Version : 2 on one of my sites

Works fine with 2.5.6

And I'm using the latest version of Newbb from simple-xoops.de

There were some problems, particularly with lastposticon.png but if you send me a pm I can tell you how to fix it

My host is still at php 5.2

irmtfan

Module Developer
Posted on: 2013/6/14 1:53
irmtfan
irmtfan (Show more)
Module Developer
Posts: 3419
Since: 2003/12/7
#10

Re: Cannot post to forums

You have a 500 error in submitting the post and in modules/newbb/viewtopic.php so Im sure it is not related to newbb. Im sure you have an issue in your configurations.
Newbb will work on php 5.2 but you will miss some few features.
If i were you i would do these:
- go to Cpanel and in modules/newbb and see if there is any error_log file there.
- provide us a full php info.
- try to see the topic by post_id instead of topic_id eg here:
this:
https://xoops.org/modules/newbb/viewto ... id=354122#forumpost354122
instead of this:

https://xoops.org/modules/newbb/viewtopic.php?topic_id=76153

- go to the _bb_posts table and find if posts exist there.

Usually 500 errors are very hard to debug but we will try to help you.