11
Shiroku
Re: blank custom blocks + rss not working
  • 2013/1/21 21:46

  • Shiroku

  • Just popping in

  • Posts: 33

  • Since: 2006/9/24


I did a regular 2.4.5 to 2.5.5 upgrade, too.
The problem is related to the following step of the official upgrade guide:
Quote:

2. Delete the /modules/system directory on your current XOOPS site (to get rid of any old unnecessary files).

and the upgrade package does not contain all the templates files.

12
Mamba
Re: blank custom blocks + rss not working
  • 2013/1/21 22:04

  • Mamba

  • Moderator

  • Posts: 11335

  • Since: 2004/4/23


This advise should be ONLY for people doing the "full upgrade".

If you use the "upgrade files", they contain only files that are different. If you delete all the original files, then obviously you'll be missing all of those that were not different from the 2.5.5 version, as obviously, they were not included in the upgrade package.
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

13
Shiroku
Re: blank custom blocks + rss not working
  • 2013/1/23 20:16

  • Shiroku

  • Just popping in

  • Posts: 33

  • Since: 2006/9/24


Quote:
This advise should be ONLY for people doing the "full upgrade".


I'm agree with you, but the upgrade instruction contains the following notes:

Quote:

Upgrading from previous versions older than 2.5.0:

[...]
2. Delete the /modules/system directory on your current XOOPS site (to get rid of any old unnecessary files).
[...]


and it was the cause for our blank blocks

Link to the page: XOOPS 2.5.5 Final Released


14
Mamba
Re: blank custom blocks + rss not working
  • 2013/1/23 20:40

  • Mamba

  • Moderator

  • Posts: 11335

  • Since: 2004/4/23


Sorry for the misunderstanding!

I've updated the text to make it clear there that this is for Full Update.
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

15
Shiroku
Re: blank custom blocks + rss not working
  • 2013/1/25 22:20

  • Shiroku

  • Just popping in

  • Posts: 33

  • Since: 2006/9/24


Sorry Mamba, but in my opinion the upgrade guide is still not correct (or maybe the upgrade package does not cointain all the required files).

I try to better explain the situation and I will start from "the beginning" just to be sure that my feeling will be eplained correctly.

It is possible to install xoops 2.5.5 in 3 different ways:
1. fresh installation (using the latest xoops package)
2. installation from previous xoops version, that can be split in:
2.1 installation from xoops version 2.5.0
2.2 installation from versions older than 2.5.0

We made a full upgrade from xoops version 2.4.5 (step "2.2" mentioned above) and we got the "blank blocks issue" because some templates file were missing in the following directories:
/modules/sytem/templates/
/modules/sytem/templates/blocks/

At this stage, we can have two alternatives to explain the issue:
1. the upgrading package for xoops versions olders than 2.5.0 does not contain all the templates files
2. the following step of the official upgrade guide:
Quote:

2. Delete the /modules/system directory on your current XOOPS site (to get rid of any old unnecessary files).

is wrong, and it should be removed.


16
donny
Re: blank custom blocks + rss not working
  • 2013/1/27 15:08

  • donny

  • Just popping in

  • Posts: 21

  • Since: 2006/11/5


I agree with what Shiroku said. There is obviously a problem here. I agree that it is nice to get rid of "old unnecessary files", but it seems that not all of them are unnecessary.

And it is not even a custom module that has problems, it is the system module blocks that are not working properly.

I believe this should be investigated more, if not for a fix for the current release, than definitely for the next upgrade cycle that will come with XOOPS 2.6.


Login

Who's Online

220 user(s) are online (70 user(s) are browsing Support Forums)


Members: 0


Guests: 220


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Dec 31
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits