1
Shiroku
Re: blank custom blocks + rss not working
  • 2013/1/25 22:20

  • Shiroku

  • Just popping in

  • Posts: 33

  • Since: 2006/9/24


Sorry Mamba, but in my opinion the upgrade guide is still not correct (or maybe the upgrade package does not cointain all the required files).

I try to better explain the situation and I will start from "the beginning" just to be sure that my feeling will be eplained correctly.

It is possible to install xoops 2.5.5 in 3 different ways:
1. fresh installation (using the latest xoops package)
2. installation from previous xoops version, that can be split in:
2.1 installation from xoops version 2.5.0
2.2 installation from versions older than 2.5.0

We made a full upgrade from xoops version 2.4.5 (step "2.2" mentioned above) and we got the "blank blocks issue" because some templates file were missing in the following directories:
/modules/sytem/templates/
/modules/sytem/templates/blocks/

At this stage, we can have two alternatives to explain the issue:
1. the upgrading package for xoops versions olders than 2.5.0 does not contain all the templates files
2. the following step of the official upgrade guide:
Quote:

2. Delete the /modules/system directory on your current XOOPS site (to get rid of any old unnecessary files).

is wrong, and it should be removed.




2
Shiroku
Re: blank custom blocks + rss not working
  • 2013/1/23 20:16

  • Shiroku

  • Just popping in

  • Posts: 33

  • Since: 2006/9/24


Quote:
This advise should be ONLY for people doing the "full upgrade".


I'm agree with you, but the upgrade instruction contains the following notes:

Quote:

Upgrading from previous versions older than 2.5.0:

[...]
2. Delete the /modules/system directory on your current XOOPS site (to get rid of any old unnecessary files).
[...]


and it was the cause for our blank blocks

Link to the page: XOOPS 2.5.5 Final Released




3
Shiroku
Re: blank custom blocks + rss not working
  • 2013/1/21 21:46

  • Shiroku

  • Just popping in

  • Posts: 33

  • Since: 2006/9/24


I did a regular 2.4.5 to 2.5.5 upgrade, too.
The problem is related to the following step of the official upgrade guide:
Quote:

2. Delete the /modules/system directory on your current XOOPS site (to get rid of any old unnecessary files).

and the upgrade package does not contain all the templates files.



4
Shiroku
Re: blank custom blocks + rss not working
  • 2013/1/12 12:10

  • Shiroku

  • Just popping in

  • Posts: 33

  • Since: 2006/9/24


Please follow the steps below.

1- Compare the upgraded xoops site with the backup copy and check if the upgraded xoops site contains all templates files located in the following directories:
/modules/sytem/templates/
/modules/sytem/templates/blocks/

2- In "Admin Panel/Preferences/General settings" mark as "yes" the option "Allow changes to themes and templates"

3- Update system module (and other modules e.g. News)

4- Clear the application cache (smarty_cache, xoops_cache, etc.)

5- Clear the browser cache

6- Navigate the site and check the content of the blocks

After that, you can mark as "no" the option mentioned in step #2



5
Shiroku
Re: blank custom blocks + rss not working
  • 2012/12/26 16:40

  • Shiroku

  • Just popping in

  • Posts: 33

  • Since: 2006/9/24


fixed: it was required to also update the themes files



6
Shiroku
Re: blank custom blocks + rss not working
  • 2012/12/25 15:14

  • Shiroku

  • Just popping in

  • Posts: 33

  • Since: 2006/9/24


There are several custom blocks, in the following you will find just the content of one of them (custom HTML block):

<div class="xo-blockcontent"><div id="mainmenu">  <!--<class='menuMain' href='{X_SITEURL}modules/forum/'>Forum</a>--> <class='menuMain' href='{X_SITEURL}modules/news/submit.php'>Scrivi una guida</a> <class='menuMain' href='{X_SITEURL}modules/xoopspoll/'>Sondaggi</a> <class='menuMain' href='{X_SITEURL}modules/news/article.php?storyid=7'>Scambio banner</a> <class='menuMain' href='{X_SITEURL}modules/news/article.php?storyid=122'>Firefox Search Bar</a>  </div></div>


My feeling is that the problem is not related to the content of the block for the following reasons:
- ALL custom blocks are not working in News module
- the blocks are correctly displayed when different pages/modules are loaded
- I tried to create a new custom html block with very simple content (just a word) and it doesn't work



7
Shiroku
Re: blank custom blocks + rss not working
  • 2012/12/25 11:49

  • Shiroku

  • Just popping in

  • Posts: 33

  • Since: 2006/9/24


Thank you for your feedback: some files were missing in the "[...]/modules/system/templates/" and "[...]/modules/system/templates/blocks/" directories.

RSS are now generated in a correct way.

About "blank blocks", the content is displayed in all pages but there is an exception: the content is still not visible in the pages related to the News module (only the title of the block is displayed).
As usual, I updated the modules, I deleted the cache (both browser and xoops) and I checked the access rights, but the problem still remain.

Any suggestion about this "sub"-issue?
Thank you.

PS: Merry Christmas :)



8
Shiroku
blank custom blocks + rss not working
  • 2012/12/22 19:33

  • Shiroku

  • Just popping in

  • Posts: 33

  • Since: 2006/9/24


Hi all!
I just upgraded a local version of my xoops site (from v.2.4.5 to 2.5.5).

I faced 2 main issues:

1. the content of all custom blocks is not displayed (only the title of the block is shown). I created new HTML and PHP blocks, I updated the system module, I deleted the cache (both browser and xoops) and I checked the access rights, but the problem still remain.

2. RSS feed generation doesn't work. The [xoops_site]/backend.php page returns the following message (my English translation):
Error during xml readingno element found
Address
http://localhost/.../backend.php
Line number 1column 1:


Any suggestion?
Thank you!



9
Shiroku
Re: news 1.64 topics and parent topics
  • 2010/5/2 17:43

  • Shiroku

  • Just popping in

  • Posts: 33

  • Since: 2006/9/24


ok, thanks!



10
Shiroku
Re: news 1.64 topics and parent topics
  • 2010/4/24 22:21

  • Shiroku

  • Just popping in

  • Posts: 33

  • Since: 2006/9/24


or.... there is a different module that works in the way as I want?




TopTop
(1) 2 3 »



Login

Who's Online

108 user(s) are online (62 user(s) are browsing Support Forums)


Members: 0


Guests: 108


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: May 31
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits