xoops forums

Mamba

Moderator
Posted on: 2012/8/8 22:59
Mamba
Mamba (Show more)
Moderator
Posts: 10992
Since: 2004/4/23
#1

News 1.68 Beta 1 released for XOOPS 2.5.5

News 1.68 Beta with normalized table names and updated TCPDF by Black_beard is ready for testing.

Download: XOOPS SVN

As next, we'll be looking at RSS issues and SEO by Roby73
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

DCrussader

Friend of XOOPS
Posted on: 2012/8/9 8:53
DCrussader
DCrussader (Show more)
Friend of XOOPS
Posts: 573
Since: 2005/7/4 7
#2

Re: News 1.68 Beta 1 released for XOOPS 2.5.5

Since is News, and there is News by the same author string, there should be search and replace on all Story, Stories with Article, Articles.

Outdated translations including englishUTF8 must go.

modinfo.php
Lines 122-127 must go, there is no SPAW and Koivi anymore (damn, Koivi was good editor).

Line 150 must be corrected, Tinyeditor is tinymce (yack)

For lines 186 to 190 someone desire punishment!

main.php
Line 9 must be removed with whole function
define('_NW_BYTESMORE',"%s bytes more"); - The news module is a content, not File Download management.

Line 18
define('_NW_THESCOOP',"The Scoop");
This is "Intro"

hmmm, the mess is full - main.php is full with Stories/Articles... should be Article, Articles everywhere

Line 102-112, instead of adding function for every single social network, use
http://www.addthis.com/

Line 120-131 - same, single function to one service - http://www.addthis.com/


admin.php
Someone really want punishment, guys are u really don't have work to do ? I can find u a lot of work!

Line 197-208

Is this MS Office Document or language file ?
Next module with such lines will be dropped, bcz this is the only content module will correct it once, next version - nope, no more corrections in future for modules with pseudo-formatted language files.

Wondering if 2.6.0 was adopted the Joomla! 1.5 INI files, how u will loose precious time to play with such crap?

newsletter.php must be moved into SQL with function in the module - the whole template to be edited/modified from within the module.

Removed invalid spaces, converted to UTF-8 without BOM
http://sourceforge.net/projects/gtlt/ ... ws-1.68Beta1.zip/download

TX Task - https://www.transifex.com/projects/p/xoops-mods-i18n/r/news167rc/

@Mamba - can u make sub-forum Archive and to lock and move News 1.67 RC thread there, with all old versions for other modules

DCrussader

Friend of XOOPS
Posted on: 2012/8/9 14:13
DCrussader
DCrussader (Show more)
Friend of XOOPS
Posts: 573
Since: 2005/7/4 7
#3

Re: News 1.68 Beta 1 released for XOOPS 2.5.5

(Newbb is the most useless forum ever)
Why I should add new post instead to edit and add to previous....?
why post can't contain more then 5 links and why there is no error message, white page is not professional?

anyway
Tell a Friend must be removed as function - common way for spamming users.

The old Nuke way of rating content to be removed and replaced with something like this
http://www.9lessons.info/2009/08/vote ... -jquery-ajax-and-php.html
where there are xxx positive and zzz negative votes
or with 5 starts
http://extensions.joomla.org/extensio ... es/ratings-a-reviews/4901
such simple plugin can be ported easily

Due the need of eliminating invalid intervals, all previously done translations need to be updated, they're from 98 to 93%

irmtfan

Module Developer
Posted on: 2012/8/10 1:46
irmtfan
irmtfan (Show more)
Module Developer
Posts: 3419
Since: 2003/12/7
#4

Re: News 1.68 Beta 1 released for XOOPS 2.5.5

DCrussader:
i said before that honestly developing this news module is wrong and meaningless when we have publisher in our hands.
Just seems Trabis is absent and his modules are orphaned.
the right way is finding some dedicated developers that:
1- choose one content module between current candidates (publisher, fmcontent, ...)
2- developing that chosen core content module to its extend (Clone, SEO, full feature and bug free)
3- create importing scripts from any possible current content modules. News 1.68 is the most important one. then go for others.
4- announce the birth of this core content module in xoops.org news and also announce that all other content modules like news 1.68, smartcontent, xcontent, ... are dead unless a developer continue developing them. (which is totally insane and waste of time IMO)

Quote:

why post can't contain more then 5 links and why there is no error message, white page is not professional?

this is because of protector settings not newbb.

pw-kw

Just popping in
Posted on: 2012/8/10 6:36
pw-kw
pw-kw (Show more)
Just popping in
Posts: 50
Since: 2007/2/1 8
#5

Re: News 1.68 Beta 1 released for XOOPS 2.5.5 / request for a function

news is one of the best modules for xoops! Only one function is missing ...

Is there a possibility to include the funktion "No Line Feed" / "linebreak conversion"? Similar to the funtion in xcontent?

DCrussader

Friend of XOOPS
Posted on: 2012/8/10 9:15
DCrussader
DCrussader (Show more)
Friend of XOOPS
Posts: 573
Since: 2005/7/4 7
#6

Re: News 1.68 Beta 1 released for XOOPS 2.5.5

Then protector should be removed from 2.6.0 and added as optional module in /extras.
Currently protector causes only troubles!

fmContent - thanks, but no - prefer to use Dreamweaver for making sites, instead CMS with such content management
Publisher - never managed to see even working Tech. Preview release or alpha

Quote:

developing that chosen core content module to its extend (Clone, SEO, full feature and bug free)


This can happen by making one new from scratch... otherwise XOOPS should be renamed to FORK, everything here is fork from the fork. There are tons of good developers and can be motivated to make such, and as I said before, diplomat is needed to solve the PR problems with rest communities. With current "war games" I'll not be surprised if tomorrow see WishOOPS or redOOPS.

Imagine XOOPS with all good points taken from banned one, cube, xoosla and xoops x3 planed features - nor joomla or wordpress can take the first position in the Content Management Systems for ages. (Dreams, dreams...)

Quote:

news is one of the best modules for xoops! Only one function is missing ...

+1

With current features provided by 2.5, News is the only capable module to handle the missing part in the abbreviation CMS for XOOPS.

AngeloRocha

Just can't stay away
Posted on: 2012/8/10 18:29
AngeloRocha
AngeloRocha (Show more)
Just can't stay away
Posts: 603
Since: 2010/6/8 1
#7

Re: News 1.68 Beta 1 released for XOOPS 2.5.5

Prune news in admin side:

Resized Image

Mamba

Moderator
Posted on: 2012/8/10 19:38
Mamba
Mamba (Show more)
Moderator
Posts: 10992
Since: 2004/4/23
#8

Re: News 1.68 Beta 1 released for XOOPS 2.5.5

Quote:
Prune news in admin side:

Thanks Angelo, it's now fixed in SVN
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

irmtfan

Module Developer
Posted on: 2012/8/11 4:21
irmtfan
irmtfan (Show more)
Module Developer
Posts: 3419
Since: 2003/12/7
#9

Re: News 1.68 Beta 1 released for XOOPS 2.5.5

There are a few issues reported with publisher.
Also i review its code and they are really professional.
And the most important feature for a content module is the ability for cloning which only publisher have it until now.
If you review this news 1.68 codes you can see it is full of hardcodes so that it takes one month for me to remove all these hardcodes.
and even after that it dont have 100 features of publisher module.
So why we should bother ourselves?

Anyway, news/makepdf.php is not support RTL languages.
you should add this:
//create the A4-PDF...
$pdf=new TCPDF(PDF_PAGE_ORIENTATIONPDF_UNITPDF_PAGE_FORMATtrue_CHARSETfalse);
// START irmtfan hack to add RTL-LTR local
// until _RTL added to core 2.6.0
if (!defined('_RTL')) {
    
define('_RTL',false);
}
$pdf->setRTL(_RTL);
// END irmtfan hack to add RTL-LTR local


also you can safely remove these lines:
if (is_file(XOOPS_ROOT_PATH.'/Frameworks/tcpdf/config/lang/'.$xoopsConfig['language'].'.php')) {
    require_once( 
XOOPS_ROOT_PATH.'/Frameworks/tcpdf/config/lang/'.$xoopsConfig['language'].'.php');
} else {
    require_once( 
XOOPS_ROOT_PATH.'/Frameworks/tcpdf/config/lang/english.php');
}

There is no need for them in any languages.

I already sent the request for _RTL=true/false definition to the sf.net tracker.

black_beard

Just popping in
Posted on: 2012/8/11 6:01
black_beard
black_beard (Show more)
Just popping in
Posts: 59
Since: 2012/6/24
#10

Re: News 1.68 Beta 1 released for XOOPS 2.5.5

@irmtfan, see here. this causes problems with sites having a charset iso-8859-1