1
liamgavin
XOOPS module installation problem?
  • 2011/12/19 9:49

  • liamgavin

  • Just popping in

  • Posts: 1

  • Since: 2011/12/19


I recently installed XOOPS in my pc to create my own site. At installation i got problems like :

Strict Standards: Non-static method XoopsDatabaseFactory::getDatabase() should not be called statically, assuming $this from incompatible context in G:\xampp\htdocs\xoops\install\class\dbma… on line 47

Strict Standards: Non-static method XoopsLogger::getInstance() should not be called statically, assuming $this from incompatible context in G:\xampp\htdocs\xoops\install\class\dbma… on line 49

I got many of these errors and i fixed them,I got rid of these notifications by changing the following line in the php.ini file:

Line 516: error_reporting = E_ALL | E_STRICT

TO

Line 516: error_reporting = E_ALL & ~E_NOTICE & ~E_DEPRECATED

Now my xoops works fine, But when i try to install certain modules like xnews i get an error that says :

Unable to install eguide. Error(s):Installing Event GuideYou have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'TYPE=MyISAM' at line 17

Everytime, How do i fix this? Somebody please help?



http://poemsabout-family.blogspot.com/

2
Mamba
Re: XOOPS module installation problem?
  • 2011/12/19 10:57

  • Mamba

  • Moderator

  • Posts: 11211

  • Since: 2004/4/23


Replace all:

TYPE=MyISAM

with

ENGINE=MyISAM
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

3
BlueStocking
HELP: XOOPS module installation ~ Please and Thank You!

Question: clean install, no admin panel, white blank sheet with 0 left hand corner. Address.. http://upnrunnin.hypermart.net/PISO/admin.php -
MySQL Version 5.0.45 ~
PHP 4.4.9 ~
Can anyone help?

BTW nice to be back!!!

UPDATE: Blast from the past https://xoops.org/modules/smartfaq/faq.php?faqid=80
____
C. Possible Fixes (Compiled off of the XOOPS Forums)
[1] In the php.ini, make sure that register_globals=on. You can check this by creating a test script with this single line of code:
Line of code is missing :(
_____
Found line of code here: http://freevps.us/thread-1450.html
_____
Globals were turned OFF... Hypermart Live person help turned Globals ON.
_____
Problem ~not~ solved.
_____
Went to mysql, turned on config debuging (set to 1 from 0)
_____
http://upnrunnin.hypermart.net/PISO/admin.php
https://xoops.org/modules/repository .. It is time to get involved - XOOPS.ORG

4
zyspec
Re: XOOPS module installation problem?
  • 2012/1/31 0:13

  • zyspec

  • Module Developer

  • Posts: 1092

  • Since: 2004/9/21


BlueStocking.... Welcome back!

I noticed the link above looks like it now has a working installation.

Can you tell us which version of XOOPS? Your post says you're using PHP 4.4.9 - the latest versions of XOOPS require >= PHP 5.2

5
BlueStocking
Re: XOOPS module installation problem?

Doesn't give me an admin panel - I added block visible from the mysql database. Do you see anything from the error msgs (user profile etc.) that might help?
https://xoops.org/modules/repository .. It is time to get involved - XOOPS.ORG

6
Mamba
Re: XOOPS module installation problem?
  • 2012/1/31 6:06

  • Mamba

  • Moderator

  • Posts: 11211

  • Since: 2004/4/23


Welcome back!

I would try to update PHP version. The current version of XOOPS is not anymore supported on PHP < 5.2
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

7
BlueStocking
Re: XOOPS module installation problem?

Hi Mamba...
I've been gone so long I've became a newbee again! Since I use hypermart.net as server, does change php version mean I will have to change my many years site server to use Xoops? They have a link to download Xoops via a script, which I did in another directory ~with the same white page result. Now, I would call changing servers a major delima!

Anyone else here use hypermart and how did they solve this problem? Earlier version of Xoops maybe??? I'll give that a try if I can find one on the site here.

Thanks for the response and help... will report back after another install of older version.


https://xoops.org/modules/repository .. It is time to get involved - XOOPS.ORG

8
Mamba
Re: XOOPS module installation problem?
  • 2012/1/31 17:08

  • Mamba

  • Moderator

  • Posts: 11211

  • Since: 2004/4/23


Ask the people at hypermart.net to update you to PHP 5
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

9
BlueStocking
Re: XOOPS module installation problem?

http://upnrunnin.hypermart.net/PISO/

Makes sense.. If all else fails I will give that a try. The homepage theme looks nice, its a shame the admin panel doesn't. I REALLY think I had this problem before on initial setup, (old versions) the fault being globals were not set to 'on' via hypermart.
Its been to long ago, so not really sure.
https://xoops.org/modules/repository .. It is time to get involved - XOOPS.ORG

10
BlueStocking
Re: XOOPS module installation problem?

WOW ... That new xoops looks nice. Went to hypermart and they upgraded the php and it came booming in... very impressive. Thanks loads!!!

Now to shop around for some new modules...

do you recommend anything in particular?
https://xoops.org/modules/repository .. It is time to get involved - XOOPS.ORG

Login

Username:
Password:

Lost Password? Register now!

Who's Online

57 user(s) are online (34 user(s) are browsing Support Forums)


Members: 0


Guests: 57


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Dec 31
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits