xoops forums

wetsteve

Just popping in
Posted on: 2011/8/14 16:17
wetsteve
wetsteve (Show more)
Just popping in
Posts: 46
Since: 2006/12/5
#1

XIM Chat module

I installed this module on http://ts.vmoa.net this is a site that is under developement and not yet public...
It is bassed on 2.5.1a

XIM worked fine when I was logged on as webmaster... There is another individual who also is in the webmaster group, and we could "chat" with out any problems as long as we were logged in as webmasters... and using FireFox...

There are some Bugs in the Theme we are using ixt0270456harley and it does not like IE8 or 9 when I try to log on as webmaster... everything freezes and the site display gets very funky...

Back to XIM.... when logged on as a registered user the module would not work at all in FireFox, IE or Chrome...

I had to deactivate the module...

Any help would be greatly appreciated...

WetSteve

andrax

Just popping in
Posted on: 2011/8/15 2:19
andrax
andrax (Show more)
Just popping in
Posts: 60
Since: 2010/9/10
#2

Re: XIM Chat module

Hi wetsteve,

I'll do some tests with the module in XOOPS 2.5.1a, to see if I can identify what is happening, so I have an answer, I post here
Luiz Carlos (Andrax)
"whoever wants to become great among you must be your servant" – Jesus
http://guxbrasil.org
http://about.me/LuizCerqueira

vmax2extreme

Friend of XOOPS
Posted on: 2011/8/15 12:40
vmax2extreme
vmax2extreme (Show more)
Friend of XOOPS
Posts: 133
Since: 2011/2/26
#3

Re: XIM Chat module

Thanks Andrax,

We look forward to hearing back from you on your testing results. Hopefully its a simple fix.

andrax

Just popping in
Posted on: 2011/8/16 23:25
andrax
andrax (Show more)
Just popping in
Posts: 60
Since: 2010/9/10
#4

Re: XIM Chat module

Hey there,

Sorry for the delay.

I did the tests and the solution is really simple...

1)First of all, edit xoops_version.php, in line 40, modify the value 0 to 1, getting as below:
$modversion['hasMain'] = 1;

I've already sent this "fix" to SVN

2)Then go in the Modules Administration, and update the module XIM.

3) After that, just go to Groups Manager and determine which groups have permission to access the module (Module Access rights)

P.s: Or if you prefer, simply perform step 1 and reinstall the module

I hope this solves your problem ... anything just give a shout.

Andrax
Luiz Carlos (Andrax)
"whoever wants to become great among you must be your servant" – Jesus
http://guxbrasil.org
http://about.me/LuizCerqueira

wetsteve

Just popping in
Posted on: 2011/8/17 4:28
wetsteve
wetsteve (Show more)
Just popping in
Posts: 46
Since: 2006/12/5
#5

Re: XIM Chat module

Hey Andrax;

Thank you for the reply I have done as instructed... And it appears that that did indeed fix part of the problem.... Everything seems to work in Fire Fox... in IE9 the chat box opens and I can see the Friends online however when I click on a friend the actual chat pop up does not open... unless I refresh the page I think the "heart beat" is not working in IE9...

Also after I refresh and get the chat pop up I can input text but there is no way to send it... In Fire Fox after I type I hit "enter" and the text message is sent... in IE9 when I hit "enter" after inputting my message... I get a carriage return not a send...

If you would like I will send you Privately a username & password so you can log on as a registered user...

Later/WetSteve

andrax

Just popping in
Posted on: 2011/8/17 5:54
andrax
andrax (Show more)
Just popping in
Posts: 60
Since: 2010/9/10
#6

Re: XIM Chat module

HuMmm... IE... (I'll always hate IE)

Sorry, but this case will take a little longer...

Luckily I don't need to use Windows ,
so I don't have IE available as an browser option (Thanks God! )

I'll need a time to build an environment and perform some more tests with the (junk) IE9 (or perhaps the Culex appear with the solution before then ) Who took care of this part of compatibility with IE, was the Culex, at least in most cases (but I'm sure everything was working well, both in Xoops 2.4.5 and IE8)...

Meanwhile, please check if there is a problem with the theme you are using, maybe some other javascript code may be causing a conflict

Andrax
Luiz Carlos (Andrax)
"whoever wants to become great among you must be your servant" – Jesus
http://guxbrasil.org
http://about.me/LuizCerqueira

vmax2extreme

Friend of XOOPS
Posted on: 2011/8/17 12:34
vmax2extreme
vmax2extreme (Show more)
Friend of XOOPS
Posts: 133
Since: 2011/2/26
#7

Re: XIM Chat module

I've also tested in IE 7 & IE8. Both cant even open a chat window from the footer bar. When I send an IM from firefox to the IE7/8 clients, the box comes up to respond, but there is no send button as WetSteve states. So basically IE doesnt work still, but firefox seems fine.

culex

Module Developer
Posted on: 2011/8/20 22:00
culex
culex (Show more)
Module Developer
Posts: 705
Since: 2004/9/23
#8

Re: XIM Chat module

I have run some tests in both IE 8 and 9 but everything seems fine.. Sounds like IE in some cases breaks the heartbeat maybe ??

I'll run some tests, in the mean time if any other users have a quick fix please write back.
Programming is like sex:
One mistake and you have to support it for the rest of your life.

wetsteve

Just popping in
Posted on: 2011/8/22 22:52
wetsteve
wetsteve (Show more)
Just popping in
Posts: 46
Since: 2006/12/5
#9

Re: XIM Chat module

Don't waste your time... your module is broken and most likely unfix-able... I purchased CometChat and installed it... I recommend this product to any webmaster that wants to add an IM feature to their site... forget this XIM module it had so many bad affect on the website I had to completely uninstall it I am sure glad it was free!

culex

Module Developer
Posted on: 2011/8/23 14:40
culex
culex (Show more)
Module Developer
Posts: 705
Since: 2004/9/23
#10

Re: XIM Chat module

Sorry you fell this way, but happy you found a solution..

Quote:
your module is broken and most likely unfix-able

There exists no such a thing... IE6 being the nearest exception.
Programming is like sex:
One mistake and you have to support it for the rest of your life.