xoops forums

tedsmith

Home away from home
Posted on: 2011/8/2 22:07
tedsmith
tedsmith (Show more)
Home away from home
Posts: 1151
Since: 2004/6/2 1
#1

Upgrading from 2.4.4 to 2.5.1.a - What do I need to know?

Hi

My sites have been running nicely for some time using Xoops 2.4.4. Though I'm an Xoops user of some 7 years, i've learned it's best to get all the facts before you being a significant upgrade!

I'd like to upgrade it to the latest 2.5.1a but note that the installation guide for sites using pre 2.5 only cover an upgrade from 2.4.5 to 2.5. I am using 2.4.4, as stated.

Is there a big jump or something significant that I will need to do with regard to 2.4.4 to 2.4.5 and then go from 2.4.5 to 2.5.1a? If so, can anyone tell me before I begin? Or can I go from 2.4.4. to 2.5.1.a without trouble?

Thanks

Ted

redheadedrod

Home away from home
Posted on: 2011/8/2 22:19
redheadedrod
redheadedrod (Show more)
Home away from home
Posts: 1296
Since: 2008/2/26
#2

Re: Upgrading from 2.4.4 to 2.5.1.a - What do I need to know?

2.4.5 was a bug fix. You should be able to follow the upgrade directions for 2.5.1a and it should do everything for you from 2.4.4.. Obviously make sure you back up your site before you upgrade. There is a slight chance you could run accross a module with issues with 2.5 but you won't know for sure until you actually try it.


You should only go to 2.4.5 if you are coming from 2.3.3 or older to make sure your modules work with the php5 code in 2.4.5 before upgrading to 2.5.1. Any of the 2.4 serious would work so there is no need to upgrade from 2.4.4 before going to 2.5.1. If you then have any issues with your modules it is likely due to a bug with 2.5.1 and needs to be addressed with the core.

Rodney

wammes

Not too shy to talk
Posted on: 2011/8/3 15:08
wammes
wammes (Show more)
Not too shy to talk
Posts: 101
Since: 2002/1/3 1
#3

Re: Upgrading from 2.4.4 to 2.5.1.a - What do I need to know?

And remember to get your custom templates out of your database!
You cannot acces them after upgrading!

deepak267

Quite a regular
Posted on: 2011/8/4 14:26
deepak267
deepak267 (Show more)
Quite a regular
Posts: 352
Since: 2008/8/15
#4

Re: Upgrading from 2.4.4 to 2.5.1.a - What do I need to know?

if possible try to install all your module on a test/Devlelopment box on xoops 2.5.1a. this will give you an opportunity that if there are any kind of compatibility issue.

All the best.

Deepak

tedsmith

Home away from home
Posted on: 2011/10/5 20:44
tedsmith
tedsmith (Show more)
Home away from home
Posts: 1151
Since: 2004/6/2 1
#5

Re: Upgrading from 2.4.4 to 2.5.1.a - What do I need to know?

I took the plunge today, straight from 2.4.4 to 2.5.3 and, as far as I can tell, all has gone OK! Followed the "Upgrading from previous versions older than 2.5.0:" section to the letter.

Thanks for the help.