xoops forums

alien-shot

Just popping in
Posted on: 2011/1/31 13:36
alien-shot
alien-shot (Show more)
Just popping in
Posts: 42
Since: 2009/8/21
#1

2.5 Modules

People, and which modules can be used on version 2.5? Can create a set of standard modules!
At the moment, look no module for the articles!

nmshah

Just can't stay away
Posted on: 2011/1/31 17:36
nmshah
nmshah (Show more)
Just can't stay away
Posts: 556
Since: 2007/7/2 8
#2

Re: 2.5 Modules

I have a website running on xoops 2.5 and the following modules are working without any problems

1. Defacer 1
2. mytabs 2.2
3. mymenus 1.1
4. simpli wiki 1.1
5. publisher (the latest trunk)
6. tadgallery 1.3
7. xforms 1.2
8. X-Aggregator 2.25
9. Tell a Friend 1.05


piCal .93 (Everything works except date selection via calender which is not working while adding/editing an event)

Kindly add other modules that you have tested with xoops 2.5 so that we can have a list for others as well.

redheadedrod

Home away from home
Posted on: 2011/1/31 19:36
redheadedrod
redheadedrod (Show more)
Home away from home
Posts: 1296
Since: 2008/2/26
#3

Re: 2.5 Modules

imenu does NOT work with 2.5. It does not allow the child menus to work under 2.5.

Also the module "groups" just shows a white page with 2.5.

Both of these modules work fine with 2.4.5

nmshah

Just can't stay away
Posted on: 2011/2/1 10:41
nmshah
nmshah (Show more)
Just can't stay away
Posts: 556
Since: 2007/7/2 8
#4

Re: 2.5 Modules

Since module compatibility is a problem with almost every xoops upgrade and its obviously very difficult for any single person to keep on checking all modules with a every xoops version, is there a possibility to have a wiki page for each xoops version.

The wiki page will then have two links on it, one that leads to a page with list for compatible modules and another that leads to a list of incompatible modules.

Both the pages with compatible and incompatible list should be allowed to be edited by registered members, so that as we upgrade our sites to a newer xoops version, we automatically test the existing modules on our site and simply update the list on the wiki pages.

jph000

Just popping in
Posted on: 2011/3/11 2:43
jph000
jph000 (Show more)
Just popping in
Posts: 60
Since: 2004/8/2 2
#5

Re: 2.5 Modules

Regarding XOOPS 2.5, on a test site I've got the following modules working okay:

stockquotes 0.1
news 1.66
xoopheadline 1
smartfaq 1.08
wflinks 1.06
sections 1
liaise 1.26
xoopspoll 1
wvleather 0.9

However, most modules have been modified to run under PHP 5 and PHP 5.3 and validated for XHTML 1.0 Transitional. No PHP errors. Validation passed. No CSS level 2.1 errors.

As modified, wflinks 1.06 has some deprecations remaining. (I tried wflinks 1.08 but the Latest Listings feature is broken.)

XOOPS Version XOOPS 2.5.0
PHP Version 5.3.5
mySQL Version 5.1.53-log
Server API cgi-fcgi
OS Linux
safe_mode Off
register_globals Off
magic_quotes_gpc Off
allow_url_fopen On
fsockopen On

Mazarin

Just can't stay away
Posted on: 2011/3/11 14:05
Mazarin
Mazarin (Show more)
Just can't stay away
Posts: 533
Since: 2008/12/10
#6

Re: 2.5 Modules

I use WF-Links 1.08 on a 2.5 installation and the latest listings is working fine for me.

On topic, as I have mentioned before (although I of course realize this would take some work), I think it would highly beneficial to have a very clear indication (suitable icons or similar) in the module repository to show which versions of Xoops it compatible with, similar to what they have on joomla.org (although I must admit that using my sites from 2.3, upgrading to 2.4 and then 2.5, I haven't really encountered many, if any, compatibility issues, I guess I've been lucky).

Regarding XoopsPoll, v 1.31 works with 2.5 and version 1.32 (which Mamba is working on) is exclusively for 2.5.

fdeconiac

Quite a regular
Posted on: 2011/3/11 17:36
fdeconiac
fdeconiac (Show more)
Quite a regular
Posts: 278
Since: 2008/11/29
#7

Re: 2.5 Modules

Here is the list of module i'm using - working with xoops 2.5 :

system 2.1
profile 1.67
xnews 1.71
faq 1.15
liaise 1.27
TDMDownloads 1.5
multimenu 2.08
Iframes 1.6
videotube 1.85
lexikon 1
sitemap 1.3
mylinks 1.11
tag 2.3
evennew 2.1 (would need some updates ...)
extgallery 1.09 (with the last updates by voltan and others)
xplorer 0.1 (would need some updates/refresh ...)
adslight 1.11
Slideshow 2.1
Protector 3.4

jph000

Just popping in
Posted on: 2011/3/11 18:04
jph000
jph000 (Show more)
Just popping in
Posts: 60
Since: 2004/8/2 2
#8

Re: 2.5 Modules - wflinks 1.08

> by Mazarin on 2011/3/11 6:05:33
> I use WF-Links 1.08 on a 2.5 installation and the latest listings is working fine for me.

Thanks for the note re wflinks 1.08 working okay for you. Something I'll need to investigate further, eh.

jph000

Just popping in
Posted on: 2011/3/15 21:43
jph000
jph000 (Show more)
Just popping in
Posts: 60
Since: 2004/8/2 2
#9

Re: 2.5 Modules - wflinks 1.08 - testing update

On another XOOPS 2.5 test site, I replaced wflinks 1.06 with 1.08. Seemed like Latest Listings feature worked but then not.

Missing /include/config.php (perhaps legacy item) caused 2 PHP errors. [Update: Found thread where McDonald said to remove include line.]

Submit (new link) does not work from main menu sidebar:

/modules/wflinks/submit.php

So, needed to add a new link in administration area:

/modules/wflinks/admin/index.php?op=edit

A few PHP deprecation warnings.

Http links in a wflink's description do not work, and generate html validation errors. Using the insert link in the editor, the bracketed url syntax, also does not work, and messes up the submitter block. (This feature works in wflinks 1.06. Perhaps a sanitizer issue?)

Other issues with wflinks 1.08: 1. Clicking on a category does not list category's links. 2. Clicking on a wflinks View Full Details displays an empty Visit Link area. 3. Same problem when click on a Top WF-Link.

XOOPS Version XOOPS 2.5.0
PHP Version 5.3.5
mySQL Version 5.1.53-log
Server API cgi-fcgi
OS Linux
safe_mode Off
register_globals Off
magic_quotes_gpc Off
allow_url_fopen On
fsockopen On

Update March 16, 2011: In another thread found the mod suggested by McDonald for wflinks/templates/wflinks_index.html regarding wfllink versus link. The repository copy did not have the the mod. Fixed Latest Listings and problems 1, 2, 3 above. Country name still a problem.