xoops forums

thgirblam

Just popping in
Posted on: 2010/10/4 13:02
thgirblam
thgirblam (Show more)
Just popping in
Posts: 32
Since: 2004/8/14
#1

Russian (.ru) users signing up

Hello,

One of my sites is a support site for our local Boy Scouts troop located in the central US area. Recently I have been getting users signing up with email addresses ending in .ru, sometimes several a day.

I initially had the site setup as user activated memberships but when I audited my memberships and noticed the .ru email addresses I deleted the .ru users and changed it to moderator activated. Since then I get registration notices of users with .ru email address frequently. I don't approve their membership but that hasn't seemed to detour them. I'm just curious if there is something I should be watching for or if anyone else has experienced this.

XOOPS Version - XOOPS 2.3.2
PHP Version - 5.2.14
MySQL Version - 5.0.91-log

Mark

ghia

Community Support Member
Posted on: 2010/10/4 14:08
ghia
ghia (Show more)
Community Support Member
Posts: 4953
Since: 2008/7/3 1
#2

Re: Russian (.ru) users signing up

See this

You can also alter the settings of your Captcha in /class/captcha/config.php and /class/captcha/config.image.php or use an alternative as eg ReCaptcha or the Sexy captcha.

thgirblam

Just popping in
Posted on: 2010/10/16 13:28
thgirblam
thgirblam (Show more)
Just popping in
Posts: 32
Since: 2004/8/14
#3

Re: Russian (.ru) users signing up

Not sure why I wasn't notified of your reply since I had the "Notify me of new posts in the current thread." option checked.

I added .ru$| to my blocked domains and hope this stops the registration attempts.

Thank you ghia
Thanks,
Mark
______
XOOPS Version XOOPS 2.5.0
PHP Version 5.2.14
mySQL Version 5.0.91-log

thgirblam

Just popping in
Posted on: 2010/10/20 23:59
thgirblam
thgirblam (Show more)
Just popping in
Posts: 32
Since: 2004/8/14
#4

Re: Russian (.ru) users signing up

I placed the following information into the area that says "Enter IP addresses that should be banned from the site":

.ru$|.cn$|.in$|mailinator.com$|

but it has had no effect on blocking .ru email addresses from signing up for accounts. Is there something else I have to enable or maybe my syntax needs modified to make this work?

I'm not sure how to alter the settings of my Captcha. Are there instructions for doing this someplace that I could be pointed to?

Thanks

Mark

ghia

Community Support Member
Posted on: 2010/10/21 1:05
ghia
ghia (Show more)
Community Support Member
Posts: 4953
Since: 2008/7/3 1
#5

Re: Russian (.ru) users signing up

Wrong place!
Set it in 'Enter emails that should not be used in user profile' in the User settings preferences.

For the Captcha you have to edit the listed PHP files.
But as the email setting may cure your problem and you seems not too expierenced, this may not be needed.

MACTEP

Not too shy to talk
Posted on: 2010/10/21 8:10
MACTEP
MACTEP (Show more)
Not too shy to talk
Posts: 127
Since: 2009/4/4 5
#6

Re: Russian (.ru) users signing up

Oпять руccкие винoваты...
Гpoxнуть 6ы тe6e caйт, дa ты нe зaпиcaл eгo в пpoфилe...

awf2000

Just popping in
Posted on: 2010/10/21 8:20
awf2000
awf2000 (Show more)
Just popping in
Posts: 44
Since: 2007/5/7 5
#7

Re: Russian (.ru) users signing up

у меня на сайте тоже полезли спам-боты регистрироваться с мыльниками на мейл.ру

ghia

Community Support Member
Posted on: 2010/10/21 9:44
ghia
ghia (Show more)
Community Support Member
Posts: 4953
Since: 2008/7/3 1
#8

Re: Russian (.ru) users signing up

English please!

chefry

Home away from home
Posted on: 2010/10/26 14:14
chefry
chefry (Show more)
Home away from home
Posts: 1005
Since: 2006/10/14
#9

Re: Russian (.ru) users signing up

He said he is also getting spambots on his site with emails addressed from mail.ru