1
rkennett
install with hosted site will not connect to DB
  • 2010/5/25 13:36

  • rkennett

  • Just popping in

  • Posts: 19

  • Since: 2004/12/17


I have my site hosted with fatcow and I am attempting to install Xoops 2.4.4. The install proceeds just fine until /page_dbconnection.php . Where I either find the page resets or I receive an error message stating "Could not connect to the database server."

Naturally I have proceeded and passed the steps in htdocs for path et al and I have good login credentials with permissions but I am stumped.

The one thing that seems suspicious to me is the first prompt for Database where mysql is the only option. If that is intended as database name I am introuble as I am not permitted to name my DB mysql. Apparently reserved by the host.

If that is the issue I would like to know if there is a work around. If that is not the issue then I am totally lost. Thank you for any support.

2
Burning
Re: install with hosted site will not connect to DB
  • 2010/5/25 14:14

  • Burning

  • Theme Designer

  • Posts: 1163

  • Since: 2006/8/22


hi'

You have to provide many informations :
• server hostname
• username
• password

... if one information is missing or wrong, connection is not possible
Still learning CSS and... english

3
ghia
Re: install with hosted site will not connect to DB
  • 2010/5/25 14:20

  • ghia

  • Community Support Member

  • Posts: 4953

  • Since: 2008/7/3 1


MySQL is not the name of the database but the type. The databasename has to be filled on the next form.

If you can't connect this may also indicate that you do not have sessions. Check your hosters' documentation of what to do for enabling sessions in PHP.

4
bjuti
Re: install with hosted site will not connect to DB
  • 2010/5/25 14:58

  • bjuti

  • Just can't stay away

  • Posts: 871

  • Since: 2009/1/7 2


With some host you need to make database first, they doesn't allow Xoops to do it.

5
Peekay
Re: install with hosted site will not connect to DB
  • 2010/5/25 18:08

  • Peekay

  • XOOPS is my life!

  • Posts: 2335

  • Since: 2004/11/20


Yes, as bjuti says, most likely you need to create the database first. FatCow provide some information here
A thread is for life. Not just for Christmas.

6
rkennett
Re: install with hosted site will not connect to DB
  • 2010/5/26 4:35

  • rkennett

  • Just popping in

  • Posts: 19

  • Since: 2004/12/17


Thanks to all for the responses though with the possible exception of the response from ghia regarding "sessions" all bases are covered. I did create the DB in advance, I have the server host name, user name and password. I am unfamiliar with "sessions". I will check with fatcow regarding sessions.
Thanks

7
ghia
Re: install with hosted site will not connect to DB
  • 2010/5/26 7:49

  • ghia

  • Community Support Member

  • Posts: 4953

  • Since: 2008/7/3 1


I saw this.
I have doubts on saving the session data inside the document root. I suspect a security risk. To avoid?

8
rkennett
Re: install with hosted site will not connect to DB
  • 2010/5/28 17:01

  • rkennett

  • Just popping in

  • Posts: 19

  • Since: 2004/12/17


Well I have made it through the install and the issue with finding the DB Path was resolved once my host changed the account from a sub account to it's own account... go figure. However, I am not out of the woods... the Xoops Directory has no index.php file and as a result I have no app to run.

I am not certain the whole process went cleanly as the second to last step I had to run 3 times and it seemed somewhat unusual. Each time it ran one of the selected options appeared to be installed after which I gotadmin setup (as I recall) and then the Welcome to your Xoops site.

Not sure what to do at this point...


9
rkennett
Re: install with hosted site will not connect to DB
  • 2010/5/29 13:49

  • rkennett

  • Just popping in

  • Posts: 19

  • Since: 2004/12/17


Thanks for the help. I relized the issue I have now is different and should be a new topic. I will mark this one resolved. The issue was two fold - sessions and the way the host had configured the DB. Had set up this domain as a sub account to another sharing the same DB. Once those two issues were resolved we sailed through the install - untill the last step. New Topic - No Index in Xoops Directory
Thanks again

hmmmm.... whats the difference between solved and fixed?

10
Peekay
Re: install with hosted site will not connect to DB
  • 2010/5/29 16:32

  • Peekay

  • XOOPS is my life!

  • Posts: 2335

  • Since: 2004/11/20


Fixed = It was broken.

Solved = It wasn't broken... it was a fault at my end!



I would re-install from scratch. Double check the folder permissions. If still no joy, you need to nag your host again.
A thread is for life. Not just for Christmas.

Login

Who's Online

94 user(s) are online (64 user(s) are browsing Support Forums)


Members: 0


Guests: 94


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Jan 31
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits