1
tommyZ
stinky server configuration for xoops 2.3 - 2.4
  • 2009/12/26 16:40

  • tommyZ

  • Friend of XOOPS

  • Posts: 89

  • Since: 2005/1/4 1


Hi

A week ago I had to migrate servers from one shared hosting to another. What can normally be a simple transfer turned out to be a nightmare...

Modules would not work, database value altered, and debugging had to take place for hours... not to mention that the new host did not have good tools (its using plesk CP) and I could not upload archived files which means I had to upload 4K+ files a few times!

anyway, after breaking the problem into pieces, and trying the exact configuration on other servers, I found out that its the server that is massing it all up, but I am still not sure exactly what is causing the error....

I turned php values on and off, I tried hosting the database on its original mysql, i even try older version of XOOPS (2.3), and regardless of what I do, piCal values are changed, and xdirectory is broken... there might be other bugs I have not yet found.

meantime, my client has decided to change solutions, and to move to a Virtual Private Server, which will hopefully end all our problems (security, stability, etc...)

the problematic server config is:

Plesk Control Panel 8.6 - via reseller

XOOPS Version XOOPS 2.4.2
PHP Version 5.2.11
mySQL Version 4.1.22
Server API apache2handler
OS Linux
safe_mode On
register_globals Off
magic_quotes_gpc Off
allow_url_fopen Off
fsockopen On
allow_call_time_pass_reference Off
post_max_size 256M
max_input_time 60
output_buffering 4096
max_execution_time 30
memory_limit 40M
file_uploads On
upload_max_filesize 256M

not sure about openbasedir...

(from the Plesk info)

Services
Apache ASP support No (Component was not installed)
SSI support Yes
PHP support Yes (PHP 'safe_mode' on)
CGI support Yes
Perl support No
Python support No
FastCGI support No (Component was not installed)
Miva support No (Component was not installed)
ColdFusion support No (ColdFusion is not supported by the license key)


xoops debug info:

such errors appear:

Warning: Class 'XoopsTree' is deprecated, check 'XoopsObjectTree' in tree.php in file /class/xoopstree.php line 49

Warning: MyTextSanitizer::makeTareaData4Show is deprecated in file /class/module.textsanitizer.php line 852

Warning: MyTextSanitizer::makeTboxData4Show is deprecated in file /class/module.textsanitizer.php line 784


bottom line: sometime a server sucks! and its not the developers fault!

2
tommyZ
Re: stinky server configuration for xoops 2.3 - 2.4
  • 2009/12/26 16:56

  • tommyZ

  • Friend of XOOPS

  • Posts: 89

  • Since: 2005/1/4 1


Could it be module compatibility and php 5.2?

just found this page:

https://xoops.org/modules/mediawiki/index.php/ModuleCompatibility

3
ghia
Re: stinky server configuration for xoops 2.3 - 2.4
  • 2009/12/26 23:13

  • ghia

  • Community Support Member

  • Posts: 4953

  • Since: 2008/7/3 1


If you use UTF-8, you definitly need MySQL 5 !

The deprecated messages are harmless and may be ignored.

Check all your files are correct uploaded. Use the file check tool (see release notes) ot take a new backup and compare it to the old.
Verify permissions for the special directories (see release notes).
Empty the cache directories (except index.html)
Empty the sessions table in the database.

Verify no old paths or URL's are present in the files (eg mainfile and theme) and/or database.

For the broken modules check their install and readme files, if there are permissions to be set for some directories.
What is or is not working?



4
andrey3761
Re: stinky server configuration for xoops 2.3 - 2.4

Quote:
safe_mode On


safe_mode Off !

5
tommyZ
Re: stinky server configuration for xoops 2.3 - 2.4
  • 2009/12/27 17:55

  • tommyZ

  • Friend of XOOPS

  • Posts: 89

  • Since: 2005/1/4 1


Hi ghia

Thank you for this valuable checklist, I will go through it as i migrate to a new server (Virtual Private Server, woohoo!)

Andrey: Can you clarify on that? Can I not run XOOPS with php sade mode enabled? I think I've done it before.

I'd like to create the most secure environment possible.

Thanks in advance,

Tom

6
dbman
Re: stinky server configuration for xoops 2.3 - 2.4
  • 2009/12/27 18:00

  • dbman

  • Friend of XOOPS

  • Posts: 172

  • Since: 2005/4/28


Quote:
Andrey: Can you clarify on that? Can I not run XOOPS with php sade mode enabled? I think I've done it before.


Andrey is correct, If you can turn safe mode off you should. Check the information here.

7
andrey3761
Re: stinky server configuration for xoops 2.3 - 2.4

Quote:
Thank you for this valuable checklist, I will go through it as i migrate to a new server (Virtual Private Server, woohoo!)


For me XOOPS it is installed on Virtual Private Server.
Now I do caching Smarty in memcahe...

Quote:
Andrey: Can you clarify on that? Can I not run XOOPS with php sade mode enabled? I think I've done it before.


Sending email from a server will not work...

Login

Username:
Password:

Lost Password? Register now!

Who's Online

62 user(s) are online (32 user(s) are browsing Support Forums)


Members: 0


Guests: 62


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Dec 31
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits