xoops forums

ghia

Community Support Member
Posted on: 2009/5/27 4:26
ghia
ghia (Show more)
Community Support Member
Posts: 4954
Since: 2008/7/3 1
#91

Re: Database problem

And you used the same data to fill the fields?
Connecting to the database is a two step process as also indicated in your example:
- First you connect to the MySQL server. for this you need the hostname, username and password.
- Second you select a database to use, with the databasename.
When it fails already in the first step, then there is something wrong with host, user or pasword.
(Are you in need to use another port than standard? Or are you using blank fields?)
I admit that the name of the first selection box is bad choosen. It should be called database type. But that doesn't change functionality.

Try once this modification in order to have more error reporting from the function.
if ( ! ( $link = ($func_connect$vars['DB_HOST'], $vars['DB_USER'], $vars['DB_PASS'], true ) or die(mysql_error()) ) ) {


Other option is that you do the upgrade of your working 2.0.18 to 2.3.3 as described in the release notes. (do also the file check after the upload).

korafa

Just popping in
Posted on: 2009/5/27 15:58
korafa
korafa (Show more)
Just popping in
Posts: 16
Since: 2008/8/12
#92

Re: Database problem

Quote:
And you used the same data to fill the fields?

Yes

Quote:
Connecting to the database is a two step process as also indicated in your example: - First you connect to the MySQL server. for this you need the hostname, username and password. - Second you select a database to use, with the databasename.


That's just it, in the XOOPS 2.3.3 install, I do not get the option of telling it which database to use. All I get is MySQL for an option in the dropdown. I can input the hostname, username and password, but I never get the option for the database.

At this point, I may just go the upgrade route since this is working, but I'll keep at it so this issue can get resolved for all who experience it.

CeroKool

Just popping in
Posted on: 2009/10/14 20:01
CeroKool
CeroKool (Show more)
Just popping in
Posts: 30
Since: 2007/7/17
#93

Re: Database problem

I also have FatCow. At first I thought it was the host. MySQL Database looked like it didn't work. There was no error. At the very first pass it would come back and ask to input info again.

SOLUTION:
Not a good one but it worked.

Download 2.3.3b
Downlaod 2.0.18.2 (http://sourceforge.net/projects/xoops/files/) which is a Stable Release
Extract htdocs from 2.0.18.2 - DON'T INSTALL yet
Extract files/folders specified for upgrade from 2.3.3b
Upload htdocs content to the XOOPS root folder.
Go to the website and you will be promoted to install Xoops
Complete the set up and click to view your site. No need to login.
On the address bar, at the end after / type: upgrade
Example: http//subdomain.yourdomain.com/upgrade
Log in if prompted and follow instructions displayed.
Delete install and upgrade folders, and set read only permissions for mainfile
Log in to the administration section of your XOOPS website and go to modules
Update the System module.

That worked for me.

ghia

Community Support Member
Posted on: 2009/10/15 1:12
ghia
ghia (Show more)
Community Support Member
Posts: 4954
Since: 2008/7/3 1
#94

Re: Database problem

If I got this right, you were using the install directory from 2.0.18?
(because the 2.0.18 packacge has be combined with these files from 2.3.3:
1. Move the "upgrade" folder inside the "htdocs" folder (it's been kept out as it's not needed for full installs) on your local machine
2. Delete htdocs/mainfile.php, htdocs/install/, htdocs/cache/, htdocs/extras/, htdocs/template_c/, htdocs/themes/ and htdocs/uploads/ from the "htdocs" folder on your LOCAL machine
)

CeroKool

Just popping in
Posted on: 2009/10/21 21:34
CeroKool
CeroKool (Show more)
Just popping in
Posts: 30
Since: 2007/7/17
#95

Re: Database problem

Except the delete part. Rather, I just didn't extract those files in to the htdocs in my local machine.

But for some reason i couldn't install XOOPS directly from 2.3.3b. That is why I went the not-so-long way.

So, yes, I made 2.0.18 in to 2.3.3b upgrade ready. Uploaded it.
Installed. And upgraded it. With out having to upload anything else. Finally:
- mainfile as read only
- delete upgrade & install folders

Timelord1957

Just popping in
Posted on: 2010/8/6 19:43
Timelord1957
Timelord1957 (Show more)
Just popping in
Posts: 2
Since: 2010/8/6 1
#96

Re: Database problem - Re: Unable to create table

There IS ONE OTHER "BUG" in the Database installation part of XOOPS that I discovered that DEFINITELY prevents the installation and it has NOTHING to do with Permissions - Database or OTHERWISE!

The creators of the SQL scripts add the table type (TYPE=MYISAM) to the end of each table creation line. Some sites (like my home system) are not set up to select a storage type. MY MySQL server, for example is explicitly INNODB. It is the current stable release of MySQL, by the way. Since the servers are mine, I was able to discover the error by locating the script in question, adding a connect line (ie. CONNECT MYDATABASE) at the beginning and executing it from the Unix Shell (BASH in My case) as:

# cd /rootlocation/install/sql
# vi mysql.structure.sql

(insert the correct connect line and save)

mysql -u mjmgr -p <mysql.structure.sql

And you get the error that TYPE=MYISAM is not a valid SQL command for this MySQL installation.

The fix? Re-Edit the file, removing the connect command and go to each table creation line and REMOVE the TYPE=MYISAM option.

(You can use SED or other methods if you are confident enough.)

The installation process then works GREAT - EXCEPT that ANY MODULES you want have the EXACT SAME PROBLEM! Prior to installing or activating the modules, you need to be able to access the command line (Unix) or other editors (Windows) to make the same change!

Xoops creators and developers need to REMOVE the TYPE=MYISAM options and let the database use whatever the default is for that installation!

Xoops would be the BEST SYSTEM I HAVE SEEN and I would USE it if I didn't have to keep correcting this one error for EVERY PART that I wish to utilize!

ghia

Community Support Member
Posted on: 2010/8/6 21:52
ghia
ghia (Show more)
Community Support Member
Posts: 4954
Since: 2008/7/3 1
#97

Re: Database problem

Timelord1957, Welcome to the XOOPS forum!

Thank you for reporting this!
The TYPE=MyISAM is deprecated in the latest MySQL versions and has to be replaced by ENGINE=MyISAM
I guess this would also work on your system.
An entry has already been made in our bug tracker on SourceForge.

Timelord1957

Just popping in
Posted on: 2010/8/7 15:47
Timelord1957
Timelord1957 (Show more)
Just popping in
Posts: 2
Since: 2010/8/6 1
#98

Re: Database problem

Yes. I discovered the "ENGINE=" later in the day when trying Joomla (which has the same problem). In all actuality, unless there is a specific reason to USE the MYISAM engine, it would be JUST as easy to leave the TYPE=/ENGINE= option out. I installed fine without either of these.

FYI, I STILL prefer XOOPS to Joomla, Drupal and DotNetNuke (the latter mainly because it seems to be limited to Microsoft platforms).