1
Daethian
CBB 3.08
  • 2008/8/24 13:14

  • Daethian

  • Quite a regular

  • Posts: 305

  • Since: 2005/3/4 1


Issues I'm having:
Some users are being sent to site admin group
Some users are not being grouped at all
Some users are not being assigned a rank (based on post count)
Joined dates are all the same and from 1969

In an attempt to fix the usergroup issue I deleted all but the three default groups and then recreated them but it doesn't seemed to have helped.

I did the same with the rank groups and that seemed to have created the problem with some users not being reassigned when I created new rank groups.
http://www.artfire.com/daethian
My Artfire store- Vintage Jewelry and New Bead Jewelry

2
Daethian
Re: CBB 3.08
  • 2008/8/24 13:42

  • Daethian

  • Quite a regular

  • Posts: 305

  • Since: 2005/3/4 1


Tried updating the module from ACP and got the following:

Got error 134 from storage engine
Got error 134 from storage engine
http://www.artfire.com/daethian
My Artfire store- Vintage Jewelry and New Bead Jewelry

3
Mamba
Re: CBB 3.08
  • 2008/8/24 18:33

  • Mamba

  • Moderator

  • Posts: 11201

  • Since: 2004/4/23


There are some links here

One of them (click here) says:
Quote:
"Got error 134 from storage engine"
-- you can ignore the error. It usually means that the script is trying to remove a non-existing record from database, which makes no harm if the removal is not executed; or it could indicate crash of your database, which obvious not your case.

In your case you could have a database crash. If this is the case, you might need to repair your tables via phpMyAdmin.
Support XOOPS => DONATE
Use 2.5.10 | Docs | Modules | Bugs

4
Daethian
Re: CBB 3.08
  • 2008/8/26 0:46

  • Daethian

  • Quite a regular

  • Posts: 305

  • Since: 2005/3/4 1


I'll give it a try thanks
http://www.artfire.com/daethian
My Artfire store- Vintage Jewelry and New Bead Jewelry

5
Daethian
Re: CBB 3.08
  • 2008/8/28 0:22

  • Daethian

  • Quite a regular

  • Posts: 305

  • Since: 2005/3/4 1


ran a table repair on all the forum tables and still the same error
http://www.artfire.com/daethian
My Artfire store- Vintage Jewelry and New Bead Jewelry

6
sakyant
Re: CBB 3.08
  • 2008/9/1 4:51

  • sakyant

  • Just popping in

  • Posts: 13

  • Since: 2006/8/13


my bb2 was great.. since i installed bb3 and the frameworks folder it wont work.
I get an error message saying there is a refferal to a non object in
frameworks\xoopseditor\.....
I looked at the two module packs i had and saw 3 differnet frameworks folders! one called art, and the other two one calld frameworks 102 i think and the last one called Frameworks in the community pack folder.
I examined the contents of each fomder and saw they differ noticeably
How do i know which damned folder is the right one to incorporate with the new bb
also the table entries from my old database entries from the old forum are differently named to the new ones.. this makes a simple import of tables impossible!
so basically i have lost 2000 members and 5 years of forum posts.
because of "upgrading"
I wont be upgrading again on my new forum which is unfortunately now a separate newbb3 as a stand alone.
The amount of modules and different versions has got too much with xoops.. XOOPS used to be really great but it has now too many issues and bugs becazuse of an over complication of matters.
edit and hack to improve, not to just fiddle..
I know the nature of open source movement is mutual helping to get a project together.. but i think that bthis overworking of things will cause the open source movement to fail in the end...
paid alternatives release only working versions and declare a non official version ans possibly having bugs and only recommended for developers.
I think that the open source movement should also have a separate repositiory for modules that are not confirmed as working and easy to install.
and another section for the ones still in development phase and suffering bugs.
I have stpped using zoops now for my future sites and changed to website baker because of these problems and the destruction of my database through upgrading. Once i upgraded pd downloads and it just blasted my whole module! all the folders with uploaded files were deleted!
i wish i had learned to not update that time.. as i decided to update the bb forum i was so scared that this was going to happen.
I notice the xoopsforge site is down and that also the forums here have bugs.. jeez the developers themselves cant even sort thewir own forum out how the hell am i going to as a 43 year old tattooist and little programing knowledge?
serves me right for opting for open source i suppose, but with the few penies i make off the sit5e i couldnt afford a paid option.
You know the problem about some countries having many different plugs for electricity?
your shaver has the wrong plug for the hole!
well that is what is happening here too - i think we should have a universals standard and i mean even with code, such as all thes encodings (tis 620, thai-windows 874, iso 88 blah blah..
i mean my hosts have an installed script of phpbb3.. so i install it and set up all the forums
then i start to insert Thai language categories
and what happens??
all you see is question marks!
cant chage it either becaue the autyomatic script installer tells phpbb3 to install the sql DB witha utf8 collation (as does smf forums tell you on installing that if you wish multilanguagfes then use utf8
well funnily enough, if you use Thai the only way to make the browser display it without having to go to "view\encoding etc", is to set the collation to Thai windows-874
but MySQL on php my admin only has thai tis-620
which makes your browser see a load of swedish with stricken zeros
why doesnt MySQL have the option to set windows-874?
my forum was supposed to be bilingual and nnow i cant do thai on it i would have to reinstall andcreate a new db .
Seems the web world thinks everyone is european or american
or it just hasnt occured to anyone yet maybe.
Thais spend all their nlives in internet shops.. i mean what a market they are the ultimate consumer they fall into rapture at every washing powder ad! 500 page impressions on my thai pages makes me more money on adsense than 18000 impressions on the english section! they click on anything the thais.
Thailand has a XOOPS site and they also have their own thai XOOPS version.
it has a lot of bugs though too.
Hope XOOPS solves it's problems but i am going to opt for other alternatives now as i cant afford to mess about lke this.. i am not a developer or tester i am a websitye owner and need to have a product that works efficiently with no data loss.

7
sakyant
Re: CBB 3.08
  • 2008/9/1 5:02

  • sakyant

  • Just popping in

  • Posts: 13

  • Since: 2006/8/13


forgot to add that it also caused my chess module to stop working..
Fatal error: Cannot re-assign $this in /modules/chess/class/chessgame.inc.php on line 119.
This happened afte installing frameworks and deleting my old forum.
the
other modules seem also now slower as the database tables are all confused and have holes in them.
Someone has made a real big spelling mistake somewhere.
I thnk there is some problem with the png files for the forum category and forum creation interface too, as i only got the "edit" buttons to appear after 3 uploads.
gif or png seem to have problems (i have gd2 library no image magick)
I was scratching my head a bit as i could create a forum, but not edit it,
I hovered my mouse over where the image should be but no link was there.. so i suppose in the html template for the "edit" buttons on the forum admin category and forum interface, has a javasscript "onclick" type link instead of the a href= blah blah html alternative .. i reckon this because that would cause the mouse to not see a link on hover as it would with pure html hyperling and an image inserted between the code. I suggest (assuming i am right in my theory) that bthis code be changed to make the link functional with or without the gif/png icon for edit.gif etc in the admin forum categories.
If i am wrong, then why was ther no link till the edit icon appeared?
wierd i find!

8
Anonymous
Re: CBB 3.08
  • 2008/9/1 9:10

  • Anonymous

  • Posts: 0

  • Since:


Quote:
sakyant wrote:

I get an error message saying there is a refferal to a non object in
frameworks\xoopseditor\.....


??

I'm wondering if you have things installed correctly, i.e. as follows:

xoops_root/Frameworks
xoops_root/class/xoopseditor
xoops_root/modules/newbb

Is this how you have it?

9
ghia
Re: CBB 3.08
  • 2008/9/1 11:00

  • ghia

  • Community Support Member

  • Posts: 4953

  • Since: 2008/7/3 1


It seems to me that you are mixing up mySQL character sets and collations. A collation is only for sorting and makes no difference for storing the representation.
I think for Thai UTF-8 is a good choice as character set and utf8_unicode_ci as collation.
The problem is that not all users have an UTF-8 font on their computer.

10
Daethian
Re: CBB 3.08
  • 2008/9/1 13:14

  • Daethian

  • Quite a regular

  • Posts: 305

  • Since: 2005/3/4 1


sakyant I understand your frustration trust me. I migrated a huge site from Nuke to XOOPS and now I look like a bit of a dolt as there are so many bugs and security issues in my XOOPS install. I have so much time invested in XOOPS at this point I have to try to ride it out until it is what I promised everyone it would be.
http://www.artfire.com/daethian
My Artfire store- Vintage Jewelry and New Bead Jewelry

Login

Username:
Password:

Lost Password? Register now!

Who's Online

69 user(s) are online (44 user(s) are browsing Support Forums)


Members: 1


Guests: 68


Mamba,

more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Nov 30
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits