1
paulizaz
WF-Channel all versions - Blank Page
  • 2008/4/23 14:12

  • paulizaz

  • Not too shy to talk

  • Posts: 120

  • Since: 2007/1/18


If I click on 'Create Page' button in administration or if I click 'WF-Channel' on the site and then click 'Modify' on the blank page I get an administration page which says:

"Edit Mode: You can edit this pages properties here. Click the submit button to make your changes permanent or click Cancel to return you were you where."

However there are no buttons (no submit or cancel) or options to create a page, it is completely blank. The admin index page says:

"WARNING: No Default page set, please select one
Total Number of Pages: 0
Total Refer Emails Sent: 0"

HOW do you select one?

I have uplodaed a file which you can only see in the Upload "Select HTML Document:" drop down menu.


AM I missing something here or is there a major problem? I do not know how to create a page or get started.

Please help?

I'm using XOOPS 2.0.18.1 / I have tried both WF-channel versions / I have WF-Resource installed

2
Catzwolf
Re: WF-Channel all versions - Blank Page
  • 2008/4/23 17:32

  • Catzwolf

  • Home away from home

  • Posts: 1392

  • Since: 2007/9/30


hiya,

Not sure why this is happening, but can you trun on php debugging and let me know the errors that it reports please.

I will be releasing a new version this weekend after I have tested a few things out.

Catz

3
paulizaz
Re: WF-Channel all versions - Blank Page
  • 2008/4/24 8:56

  • paulizaz

  • Not too shy to talk

  • Posts: 120

  • Since: 2007/1/18


Thanks catzwolf,

Visiting the page (mysite.com/modules/wfchannel/index.php):


All errors (1) queries (28) blocks (4) extra (0) timers (6)

NoticeConstant THEME_MODULE4_SUB4 already defined in file /language/english/theme.php line 88



If I click 'Create Page' button in admin:
Fatal errorXoopsFormEditor::require_once() [function.require]: Failed opening required '.....public_html/class/xoopseditor/xoopseditor.php' (include_path='.:/usr/lib/php:/usr/local/lib/php'in /...../public_html/modules/wfresource/class/xoopsforms/formeditor.php on line 66
All errors 
(4queries (9blocks (0extra (0timers (3)
Errors
Notice
Constant THEME_MODULE4_SUB4 already defined in file /language/english/theme.php line 88
Warning
: include_once(/class/xoopseditor/xoopseditor.php) [function.include-once]: failed to open streamNo such file or directory in file /modules/wfresource/class/xoopsforms/formselecteditor.php line 35
Warning
: include_once() [function.include]: Failed opening '/class/xoopseditor/xoopseditor.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php'in file /modules/wfresource/class/xoopsforms/formselecteditor.php line 35
Warning
XoopsFormEditor::require_once(/class/xoopseditor/xoopseditor.php) [function.XoopsFormEditor-require-once]: failed to open streamNo such file or directory in file /modules/wfresource/class/xoopsforms/formeditor.php line 66

4
Shine
Re: WF-Channel all versions - Blank Page
  • 2008/4/24 9:20

  • Shine

  • Just can't stay away

  • Posts: 822

  • Since: 2002/7/22


Have you installed the needed: wfresource ???

5
paulizaz
Re: WF-Channel all versions - Blank Page
  • 2008/4/24 9:27

  • paulizaz

  • Not too shy to talk

  • Posts: 120

  • Since: 2007/1/18


Yea I have this installed,

If this seems to be the problem, do you have a link to the latest download so that I an make sure I have the latest version. I could download and re-install, but I dont think it will help ?

6
Catzwolf
Re: WF-Channel all versions - Blank Page
  • 2008/4/24 10:30

  • Catzwolf

  • Home away from home

  • Posts: 1392

  • Since: 2007/9/30


You don't have the editor framework by DJ installed and I have fixed this error for the next version.

Ok here is what to do to work around this little issue for now.

Download this file and overwrite the original one and you should have it working again.

formloaderfix

If you have any other issues let me know :)

Catz

7
paulizaz
Re: WF-Channel all versions - Blank Page
  • 2008/4/24 11:27

  • paulizaz

  • Not too shy to talk

  • Posts: 120

  • Since: 2007/1/18


Thanks very much.

Thats seems to have worked nicely. Keep up the good work :)

8
stujol
Re: WF-Channel all versions - Blank Page
  • 2008/4/24 17:44

  • stujol

  • Just popping in

  • Posts: 5

  • Since: 2008/2/26


I've installed wf-channel 2.02 and wf-resource 1.03 and the formloader fix. I have XOOPS 2.0.18.1 running on Apache 2.2.8 with PHP 5.2.5 and MySQL 5.0.51a-community-nt. windows 2003 server. I get the following error after clicking the submit button.

"Error: 1364 Field 'wfc_search' doesn't have a default value"

9
Catzwolf
Re: WF-Channel all versions - Blank Page
  • 2008/4/24 19:55

  • Catzwolf

  • Home away from home

  • Posts: 1392

  • Since: 2007/9/30


Use phpmyadmin to change the default value of this field.

Better still, change the 'null field' from 'not null' to 'null' and then save. You should be able to save your pages now.

Any more problems or you are unsure how to do this, let me know.

Catz

10
stujol
Re: WF-Channel all versions - Blank Page
  • 2008/4/25 19:13

  • stujol

  • Just popping in

  • Posts: 5

  • Since: 2008/2/26


That fixed it. thanks for the help

Login

Who's Online

104 user(s) are online (78 user(s) are browsing Support Forums)


Members: 0


Guests: 104


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Apr 30
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits