1
JS
Xoops not sending mail to everyone
  • 2007/11/6 23:23

  • JS

  • Just popping in

  • Posts: 87

  • Since: 2002/12/16


I'm haveing an issue with XOOPS not able to send e-mail to everyone when I select registered users when useing the mail users section of the admin area.

Basicaly what happends is I have about 400 users on my site and I go to mail all registered users and only 8 mails go out and XOOPS gives me a white screen. Is there a know issue with this or is there a mail module I could install that would allow better mailing capability?

Thanks!
[img align=left]http://www.theood.com/modules/roster/sig.php?name=Talric [/img]

2
nachenko
Re: Xoops not sending mail to everyone
  • 2007/11/6 23:32

  • nachenko

  • Quite a regular

  • Posts: 356

  • Since: 2005/1/18


It could be an "out of memory" problem.

Use XOOPS info to check your PHP configuration. Look for Memory limit or something like that. If it's 8 Mbytes, this is too low, 16 should be more than enough.

3
JS
Re: Xoops not sending mail to everyone
  • 2007/11/6 23:46

  • JS

  • Just popping in

  • Posts: 87

  • Since: 2002/12/16


I checked the memory and expanded and I still have the issue :(
[img align=left]http://www.theood.com/modules/roster/sig.php?name=Talric [/img]

4
xlurker
Re: Xoops not sending mail to everyone
  • 2007/11/7 3:46

  • xlurker

  • Just popping in

  • Posts: 7

  • Since: 2007/11/2


Unless I'm mistaken, XOOPS is hard coded to only allow a maximum of 200 emails to be sent. A lot of ISPs will blacklist either your domain, IP, or both if you send out more than 100 emails at a time.

For mass mailings, you're better off to use a mailing list manager like http://www.phplist.com/

5
nachenko
Re: Xoops not sending mail to everyone
  • 2007/11/7 8:49

  • nachenko

  • Quite a regular

  • Posts: 356

  • Since: 2005/1/18


A customer of mine send thousands in bunches of 100. That is, he clicks on "send", the system send 100, then a window loads with a list of the users mailed and a button saying: click "Next" to send next 100.

It works fine.

The problem is how to test he system without bothering your registered users. You should locate the mail function in the code, comment the line that actually sends the mail and activate the debug console.

Look for this in file "modules/system/admin/mailusers.php"

$xoopsMailer->send(true);

This is the line you should comment, so you DON'T SEND MAILS, but all other processes are done.

Tell us what happens.

6
MadFish
Re: Xoops not sending mail to everyone
  • 2007/11/7 9:37

  • MadFish

  • Friend of XOOPS

  • Posts: 1056

  • Since: 2003/9/27


Quote:
Unless I'm mistaken, XOOPS is hard coded to only allow a maximum of 200 emails to be sent. A lot of ISPs will blacklist either your domain, IP, or both if you send out more than 100 emails at a time.


Can anyone confirm this? Interesting bit of info.

7
trabis
Re: Xoops not sending mail to everyone
  • 2007/11/7 13:59

  • trabis

  • Core Developer

  • Posts: 2269

  • Since: 2006/9/1 1


It happened to me when I changed servers.
I had to set the email settings on xoops. Set email to sendmail() and add the servername, etc.

8
BlueStocking
Re: Xoops not sending mail to everyone

=== Giba 2007-11-07 ===

* - Xmail Solve this problem. If a host does not allow more than 200 e-mails per hour, it will monitor this for you automatically. Alpha version has been distributed to team tests.
* -
----

Posted for Giba by BS

BTW: STAFF GET GIBA ACCESS, PLEASE... THIS HAS GONE ON TO LONG.
https://xoops.org/modules/repository .. It is time to get involved - XOOPS.ORG

9
JS
Re: Xoops not sending mail to everyone
  • 2007/11/8 0:26

  • JS

  • Just popping in

  • Posts: 87

  • Since: 2002/12/16


One thing I wanted to add was that I am using smtpauth and not sendmail. And I checked with the smtp provider I trying to relay through and they are only seeing 10 to 11 e-mails come from me each time. I have looked through the phpmail stuff and everything looks to be in order.....


Anyone have any more ideas I may try?
[img align=left]http://www.theood.com/modules/roster/sig.php?name=Talric [/img]

10
nachenko
Re: Xoops not sending mail to everyone
  • 2007/11/11 23:30

  • nachenko

  • Quite a regular

  • Posts: 356

  • Since: 2005/1/18


You get this blank screen even when you activate the Debug PHP console?

Login

Username:
Password:

Lost Password? Register now!

Who's Online

80 user(s) are online (49 user(s) are browsing Support Forums)


Members: 0


Guests: 80


more...

Donat-O-Meter

Stats
Goal: $100.00
Due Date: Nov 30
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $100.00
Make donations with PayPal!

Latest GitHub Commits